• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 468
  • Last Modified:

Sharing DSL Via Ethernet

Hi
I would like to share my internet connection (dsl) with my brothers house using the following setup.Not concerned whether both pc's can see one another or not.

 Internet--Netopia2247---eth|Cisco2503|serial---modem----modem--serial|Cisco1601|eth----PC2
                     |      
                  |      
                 Pc1

Netopia 192.168.0.254    eth0(2503) 192.168.0.21     s0(2503) 192.168.1.20               s0(1601)192.168.1.21     eth0 (1601)192.168.2.20             pc 192.168.2.68
all 24bit mask



I can access the internet from Pc1 but unable to  do so from PC2. I can ping from pc2 to netopia but unable to ping any address on internet.

As I am quiet new to all of this perhaps some would tell me what Im doing wrong.If cisco's need configuring please list step by step


Config of both routers-

Cisco2503#sh run
Building configuration...

Current configuration : 909 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Cisco2503
!
enable password 7 050F0701254D4058
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Ethernet0
 description connected to My Lan
 ip address 192.168.0.21 255.255.255.0
!
interface Serial0
 description connected to Cisco1601
 ip address 192.168.1.20 255.255.255.0
 encapsulation ppp
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 no ip address
 shutdown
!
router rip
 version 2
 network 192.168.0.0
 network 192.168.1.0
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0
ip route 192.168.2.0 255.255.255.0 192.168.1.21
no ip http server
!
snmp-server community public RO
!
line con 0
 exec-timeout 0 0
 password 7 08254D400D180B
 login
line aux 0
line vty 0 4
 password 7 1301161C0F0D0A
 login
!
end








Cisco1601#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Cisco1601
!
enable password 7 03005A05020E2F1D
!
ip subnet-zero
no ip domain-lookup
!
!
!
interface Ethernet0
 description connected to NO LAN
 ip address 192.168.2.20 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 description connected to Cisco2503
 ip address 192.168.1.21 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
!
router rip
 version 2
 network 192.168.1.0
 network 192.168.2.0
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0
ip route 192.168.0.0 255.255.255.0 192.168.1.20
!
snmp-server community public RO
!
line con 0
 exec-timeout 0 0
 password 7 06020E2F484F07
 login
 transport input none
line vty 0 4
 password 7 06020E2F484F07
 login
!
end

Cisco1601#      
 
0
Tob1
Asked:
Tob1
2 Solutions
 
edbedbCommented:
That's a lot of settings to sift through. The short answer is you don't need a router at your brothers house. Just have the his wireless adapter connect directly to your router.
0
 
NothingSiriusCommented:
Does sound like a lot of hardware.

 How far is your brother's computer from your equipment? More than 300 feet? More than wireless distance? Basically, is he in the next town and you're trying to get him dialup speed internet without having to pay for another connection? I assume when you say "modems" you are talking dial-up modems?




0
 
_Commented:
I agree.
Though the second router isn't as big a problem as the serial modems. I don't understand why those are in ther at all.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
Istvan KalmarCommented:
Hi,

you need to configure NAT on Cisco2503:

interface Ethernet0
 description connected to My Lan
 ip nat out
 ip address 192.168.0.21 255.255.255.0
!
interface Serial0
 description connected to Cisco1601
 ip nat ins
 ip address 192.168.1.20 255.255.255.0
 encapsulation ppp

ip nat inside
ip nat inside source list 100 Ethernet0 overload
access-list 100 deny ip 192.168.2.0 0.0.0.255 192.168.1.0 0.0.0.255
access-list 100 deny ip 192.168.2.0 0.0.0.255 192.168.0.0 0.0.0.255
access-list 100 deny ip 192.168.2.0 0.0.0.255 any
ip route 0.0.0.0 0.0.0.0 192.168.0.254  

0
 
Tob1Author Commented:
Ikalmar
Thank you for quick reply.Configured 2503 as instructed but still unable to ping ip address on internet.
I have wireshark running at ethernet inface on netopia and when i ping an external ip this is what I see      342.610254      Cisco_8c:87:67      CDP/VTP/DTP/PAgP/UDLD      CDP      Device ID: Cisco2503  Port ID: Ethernet0  
310      354.036906      Cisco_8c:87:67      Broadcast      ARP      Who has 143.166.224.202?  Tell 192.168.0.21
311      356.514364      Cisco_8c:87:67      Broadcast      ARP      Who has 143.166.224.202?  Tell 192.168.0.21
If you need any more info just shout
Regards and thanks
0
 
Tob1Author Commented:
Solved
Whong configuration in cisco 2503

Following lines
ip route 0.0.0.0 0.0.0.0 Ethernet0
ip route 192.168.2.0 255.255.255.0 192.168.1.21
replaced with this
ip route 0.0.0.0 0.0.0.0 192.168.0.254
ip default-gateway 192.168.0.254

0
 
Vee_ModCommented:
Tob1,
The information contained in your post of http:#a26104259 was (in part) provided by ikalmar at: http:#a26086146
I am re-opening this question and awarding one-half of the points to that suggestion.

Vee_Mod
Experts Exchange Moderator
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now