?
Solved

VMware Server 2.0 one-to-one NAT through SonicWALL?

Posted on 2009-12-18
14
Medium Priority
?
682 Views
Last Modified: 2012-05-08
I have installed VMware 2.0 on a host and have setup a Windows 2003 machine on it. On my SonicWALL I have setup a one-to-one NAT but it is not working. When I delete the NAT it works fine, going through the default gateway.

So for some reason the one-to-one NAT does not work from the VMware NIC to the SonicWALL. The NIC is currently set to bridged mode and works fine unless I NAT it. Anyone have any idea how I can get the NAT working?
0
Comment
Question by:NetworkConsultant01
  • 4
  • 4
  • 4
12 Comments
 
LVL 24

Expert Comment

by:ryder0707
ID: 26085825
What is not working? Incoming traffic from external or the VM cant go Internet?
0
 
LVL 1

Author Comment

by:NetworkConsultant01
ID: 26087746
Both, can't get out or go in.
0
 
LVL 18

Expert Comment

by:Ravi Agrawal
ID: 26096203
Have you set the Properties of the NIC of the NIC to use Vm-nat & not bridged?

It can be set under the VM console where you can upgrade (add hardware) to a virtual machine.

Ravi.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
LVL 1

Author Comment

by:NetworkConsultant01
ID: 26097108
Yes, NAT does not work either.
0
 
LVL 24

Expert Comment

by:ryder0707
ID: 26100714
How do you actually set the NAT? From what IP add to what IP add?
0
 
LVL 1

Author Comment

by:NetworkConsultant01
ID: 26100720
From the private IP of the guest to the public IP that I want it to have.
0
 
LVL 24

Accepted Solution

by:
ryder0707 earned 1000 total points
ID: 26100733
If you config the same NAT but on a physical host, does it works? Maybe its not problem with the vmware but the way you setup the NAT.
Should be no problem with NAT to a bridged VM, as the VM is already considered part of physical network.
0
 
LVL 18

Assisted Solution

by:Ravi Agrawal
Ravi Agrawal earned 1000 total points
ID: 26101799
Is vmnat service running and you have not disabled it.

Set the vm to obtain ip automatically and set the mode to vmnat in host virtual network settings & nic property of vm as said above.

also check firewall configs on both host and vm.

Ravi.
0
 
LVL 1

Author Comment

by:NetworkConsultant01
ID: 26386301
We were unable to get the one-to-one NAT working and as such decided to proceed without it.
0
 
LVL 18

Expert Comment

by:Ravi Agrawal
ID: 26386894
I do not object to the Author's closing the question but on the grounds "No other answers were correct" seems a like a hammer on my head as the answers provided here were very much in line with what was being discussed. I have seen many places where the answers provided were correct but just because of the inability of the Author to follow the advice given, they just vaporize.

Anyways, NetworkConsultant01 if you wish to keep the discussion open, at least I am willing to guide you step by step how to set the thing up as I think I know my stuff & if you do wish to close the question, please amend your reason for closing it like you posted in your Comment --
"We decided to proceed without it."

Ravi.
0
 
LVL 24

Expert Comment

by:ryder0707
ID: 26387092
I'm with grtraders
0
 
LVL 18

Expert Comment

by:Ravi Agrawal
ID: 26395822
Comment ID 26100733 of ryder0707 & 26101799 of grtraders (me) should be given points if ryder0707 does not object to my share of points.

The original reason for closure needs to be changed if possible from :
"No other answers were correct" to "We decided to proceed without it."

That's all to it, If it is not possible to do the above, I'm fine with it and the moderator may close the question in the way, it is deemed fit.

Ravi.

0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

HOW TO: Upload an ISO image to a VMware datastore for use with VMware vSphere Hypervisor 6.5 (ESXi 6.5) using the vSphere Host Client, and checking its MD5 checksum signature is correct.  It's a good idea to compare checksums, because many installat…
Ransomware is a malware that is again in the list of security  concerns. Not only for companies, but also for Government security and  even at personal use. IT departments should be aware and have the right  knowledge to how to fight it.
Teach the user how to join ESXi hosts to Active Directory domains Open vSphere Client: Join ESXi host to AD domain: Verify ESXi computer account in AD: Configure permissions for domain user in ESXi: Test domain user login to ESXi host:
This video shows you how easy it is to boot from ISO images for virtual machines with the ISO images stored on a local datastore on the ESXi host.
Suggested Courses

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question