Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 354
  • Last Modified:

always associate a file with a program

I can't associate a .pps file with Microsoft 2007 Powerpoint Reader. "Control Panel, Default Programs, Associate a file type with a Program, select .pps" doesn't list the Reader even though I just re-installed it. If I open the Reader program and select a .pps file, it will open it so the file is good and the Reader works. I've tried the approach of right clicking the file, selecting 'Open With' (Rreader isn't listed), finding the file in Explorer and "selecting the Reader as the default program" (tunnelling down to Programs and selecting the Reader) but no luck.

These approaches have always worked on other Vista machines I support.
0
seniorhelper
Asked:
seniorhelper
  • 3
  • 3
  • 2
  • +1
1 Solution
 
CompanionCubeCommented:
Open a Browser window | select Tools | Folder Options | File Types | New | Extension = "PPT" | Open With - Change | Browse | select the exe for Power Point Reader under the install folder
0
 
_3mp3ror_Commented:
You might also want to try this
http://bit.ly/PxJES
Use this utility to unassociate the file type. Then you can associate the file type as you wish
0
 
seniorhelperAuthor Commented:
CompanionCube -- Vista doesn't seem to have that choice under Tools (XP did).
3mp3ror -- I can't unassociate the file type because I can't ge t it associated in the first place.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
_3mp3ror_Commented:
I suggest uninstalling and then reinstalling from here, running the setup as administrator. 
Power Point 2007SP2
still I think you have the association because you said
"Control Panel, Default Programs, Associate a file type with a Program, select .pps" doesn't list the Reader even though I just re-installed it.
so if I understand correctly you can see the file type (which means IT is in the registry) but you can not set the default program.
Therefore if you use that tool, the registry entry would have been erased after which you could uninstall the software.
another similar problem
http://www.vistaheads.com/forums/microsoft-public-windows-vista-general/39322-powerpoint-viewer-2007-wont-open-pps-ppt-files.html


good luck
0
 
nobusCommented:
here is how to do it in vista :  http://www.annoyances.org/exec/show/article02-500
0
 
seniorhelperAuthor Commented:
3mp3ror: I installed SP1&2 for PPV 2007 and it became the opener for pps files in my computer!! that's progress!
Now I can't open a pps attachment to an email unless I save it first into one of my directories.
0
 
nobusCommented:
did you try my suggestion ?
0
 
seniorhelperAuthor Commented:
Well, I followed the link sgggested by 3mp3ror on 12/18 and changed the registry settings to 'open' which fixed the problem. I rebooted and the registry reverted to 'show', the same problem described in the link. After reentering the registry to 'open' settings, I used the Vista Control Panel Default to select the Viewer 2007. Another reboot and the registry remained in the 'open' settings. Frankly, I'm surprised others don't mention the last step (Default settings) so I'm still a little skeptical and will defer accepting the solution until I can reboot again tomorrow.
nobus: After the above was successful, I explored your suggestion (12/19) and couldn't find a useable solution. As best as I could tell, it would let me create a new file type, but not change the Default problem.
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 3
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now