• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2783
  • Last Modified:

Backup Exec Server Service hangs on Starting

Dear Experts,

I have 2 servers (1 windows 2003, other Windows2008)  each running Backup Exec 12.0 and also has SSO on both enabled.

Just recently both have issues with starting the Backup Exec Server service on them.When I attempt to start the service, the status remains at "starting" forever.And ofcourse , all the other BE services won't start.
The only way I kill stop the service to try again is via the taskmgr.


Please help me fix this.

0
SBlakeXii
Asked:
SBlakeXii
  • 8
  • 5
  • 3
  • +1
1 Solution
 
ob1_Commented:
what happens when you launch the backup exec console - can you open it and try restarting them from Tools > Backup Exec Services?
Also do you have the correct credentials setup under Services Credentials? I use the domain admin account...
0
 
SBlakeXiiAuthor Commented:
I cannot start services from console.

Correct credential used
0
 
ob1_Commented:
Is it the exact same issue on both servers? You may need to reboot 1 of them and see if that fixes the issue...
0
Free recovery tool for Microsoft Active Directory

Veeam Explorer for Microsoft Active Directory provides fast and reliable object-level recovery for Active Directory from a single-pass, agentless backup or storage snapshot — without the need to restore an entire virtual machine or use third-party tools.

 
Jian An LimCommented:
if it is windows 2008, you need to turn off the UAC and see whether it works.
0
 
SBlakeXiiAuthor Commented:
I restarted  both servers but problem still remains.

I will have to turn off UAC and restart the w2k8 after hours and advise result
0
 
Iamthecreator OMAdministrateur Systeme et ReseauxCommented:
Seems to be an issue  with the BEWS database
Kill all processes in the task manager
Start the RAWS first
do not try to to start any other service
Let me know if the remote agent service starts

I need more information
Is this a fresh installation? has it ever worked?
Why have you installed the SSO ? are the 2 servers sharing RLs?
If it worked before what changes did you make around the time it stopped?
Any MS Updates for SQL applied recently?

Look in the windows event logs
you will have events for the Service Control Manager for the BEWS services
post them here for more specific information.
0
 
SBlakeXiiAuthor Commented:

The Remote agent successfully starts when starting it up after stopping all the othe BE services.

more information
Is this a fresh installation? has it ever worked? The installations are on 2 different IBM Blade Chassis located in separate data centres
1 is on our older blade chassis which runs on Windows 2003.
The other was just put in 2 months ago and running on Windows 2008.
It's worked well for about 2 months since we put in the second blade chassis

Why have you installed the SSO ? We have a SAN environment which our different blade server access.
If it worked before what changes did you make around the time it stopped? No change done recently that I can think of.
Any MS Updates for SQL applied recently? No


windows errors ogs are below

Event Type:      Error
Event Source:      Service Control Manager
Event Category:      None
Event ID:      7034
Date:            21/12/2009
Time:            3:10:37 PM
User:            N/A
Computer:      DRAPEBKUP
Description:
The Backup Exec Server service terminated unexpectedly.  It has done this 4 time(s).

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


Event Type:      Error
Event Source:      Service Control Manager
Event Category:      None
Event ID:      7001
Date:            18/12/2009
Time:            8:21:24 PM
User:            N/A
Computer:      DRAPEBKUP
Description:
The Backup Exec Job Engine service depends on the Backup Exec Server service which failed to start because of the following error:
After starting, the service hung in a start-pending state.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


Event Type:      Error
Event Source:      Service Control Manager
Event Category:      None
Event ID:      7022
Date:            18/12/2009
Time:            8:21:24 PM
User:            N/A
Computer:      DRAPEBKUP
Description:
The Backup Exec Server service hung on starting.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.




0
 
Iamthecreator OMAdministrateur Systeme et ReseauxCommented:
Please refer to the following
 After a restart of a Windows Small Business Server 2008 Backup Exec for Windows Server services fail to start; manual starting of these services completes fine.
                                                                          http://support.veritas.com/docs/331626                                 


0
 
SBlakeXiiAuthor Commented:
Update;

As suggested by imjianan, I turned off UAC restarted the server and all the services started up on the BE server on Windows 2008 .
Still getting the same error on the BE on Windows 2003.

0
 
Jian An LimCommented:
okay, we left the windows 2003 issue.

try to disable all your BE services, then reboot, then then enable them see whether it reboot.
start one by one and see whether it has any issue.

make sure your SQL services (BE related) is started before you do anything.

Also check event log and see whether any related message after the reboot.
SQL service might start but corrupted in some where ...
0
 
SBlakeXiiAuthor Commented:
Done as advised but nom change.Same errors keep on appearing on the eventlog
0
 
SBlakeXiiAuthor Commented:
Tried all but none of them seem to fix it.

The last link is the closest description to what the problem I am experiencing with the same C++ error message.
The resolution said to put in a missing key and value in the registry but the suggested key and value were already there.
0
 
Jian An LimCommented:
try to turn off your DEP in windows 2003 server.

0
 
Iamthecreator OMAdministrateur Systeme et ReseauxCommented:
Apply the latest SP for the OS.Reapply if already installed
0
 
SBlakeXiiAuthor Commented:
Thanks for all your help experts. I could not stay another weekend without a fullbackup so I just had to uninstall backup ecec and do a clean install.
0
 
Jian An LimCommented:
on ID:26094394 at least i have able to resolve one of your servers issue, i think i deserved some point for that response.
0
 
SBlakeXiiAuthor Commented:
Apologies limjianan . I got so carried away with trying to fix the Windows 2003 problem that I forgot about the Windows 2008 one which you helped me fix. I do agree you that you do deserve some  points for it.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 8
  • 5
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now