?
Solved

Cisco 831 can't connect to internet

Posted on 2009-12-19
14
Medium Priority
?
394 Views
Last Modified: 2012-08-14
I have Comcast with a static IP, and am unable to connect to the internet.  Using an XP client, I can ping the WAN and LAN interface of the router, just not the Comcast gateway or the internet.   When I ran show ip route the first time, it did not show the proper default gateway.  The gateway should have shown up as 173.160.x.14 after I added the 'ip route 0.0.0.0 .0.0.0.0 173.160.x.14' command, but instead shows up 173.160.x.8, which would normally be the default gateway IP for every ISP except for Comcast for some reason.  So I added the 'ip default-gateway 173.160x.14' command to the list and it still doesn't work.  Is this the problem and is their a workaround?  Or is there something else I am missing?  
******************************************************************************
Router#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 173.160.x.14 to network 0.0.0.0

     173.160.0.0/29 is subnetted, 1 subnets
C       173.160.x.8 is directly connected, Ethernet1
C    192.168.1.0/24 is directly connected, Ethernet0
S*   0.0.0.0/0 [1/0] via 173.160.x.14
******************************************************************************
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip ips po max-events 100
no ftp-server write-enable
!
!
!
!
!
!
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
!
interface Ethernet1
 ip address 173.160.x.13 255.255.255.248
 duplex auto
!
interface FastEthernet1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet2
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet3
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet4
 no ip address
 duplex auto
 speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 173.160.x.14
!
ip http server
no ip http secure-server
ip nat inside source list MyNat interface Ethernet1 overload
!
!
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
!
scheduler max-task-time 5000
end
0
Comment
Question by:B1izzard
  • 8
  • 6
14 Comments
 
LVL 16

Expert Comment

by:memo_tnt
ID: 26087705
hi

add the following to your interfaces

interface Ethernet0
ip nat inside

and

interface Ethernet1
ip nat outside
0
 
LVL 16

Expert Comment

by:memo_tnt
ID: 26087720
plus add the following ACL that permit ip 192.168.1.0 0.0.0.255
0
 
LVL 16

Expert Comment

by:memo_tnt
ID: 26087742
i forgot the ACL

ip access-list extended MyNat
permit ip 192.168.1.0 0.0.0.255  any
0
Free recovery tool for Microsoft Active Directory

Veeam Explorer for Microsoft Active Directory provides fast and reliable object-level recovery for Active Directory from a single-pass, agentless backup or storage snapshot — without the need to restore an entire virtual machine or use third-party tools.

 

Author Comment

by:B1izzard
ID: 26087793
I added both, and even reloaded the router, but no luck.
0
 
LVL 16

Accepted Solution

by:
memo_tnt earned 2000 total points
ID: 26087818
change default route to the following

ip route 0.0.0.0 0.0.0.0 Ethernet1
0
 

Author Comment

by:B1izzard
ID: 26087878
When I changed it to ip route 0.0.0.0 0.0.0.0 Ethernet1, it lost the ability to ping the internet.  I put it back to ip route 0.0.0.0 0.0.0.0 173.160.167.14 and it pings again.
0
 

Author Comment

by:B1izzard
ID: 26087888
It still refuses to ping the gateway from the XP machine for some reason.  Since you suggested trying ip route 0.0.0.0 0.0.0.0 Ethernet1, and my Nat statement also has 'Ethernet1' in it, I'm wondering if it's having problems recognizing 'Ethernet1'.  One would think that your suggestion would work since 'Ethernet1' should equal the ip address.
0
 
LVL 16

Expert Comment

by:memo_tnt
ID: 26087903
wait a second,, you didnt mentioned that you can ping the internet ???
that means you can ping www.google.com
??
if so,, then it's DNS issue

then add
ip name-server 8.8.8.8

or set static DNS to your PC

if it doesnt solve the problme

make a tracert to www.google.com


and send results
0
 

Author Comment

by:B1izzard
ID: 26088006
No I meant that the router lost it's ability to ping the internet.  The router can resolve 4.2.2.2 or www.google.com.  The XP machine can ping 173.160.167.13, but has never been able to ping the 173.160.167.14 gateway.
0
 
LVL 16

Expert Comment

by:memo_tnt
ID: 26088017
what's the tracert results from your XP machine >???
0
 

Author Comment

by:B1izzard
ID: 26088794
tracert 4.2.2.2
1      1ms       1ms     1ms     192.168.1.1
2       *              *           *         Request timed out  (all timed out)
0
 
LVL 16

Expert Comment

by:memo_tnt
ID: 26089872
can you post current configuration ?
0
 

Author Comment

by:B1izzard
ID: 26089890
Thanks.  You were right on.  I messed up the Nat names.  The ip access-list Nat name wasn't identical to the ip nat inside source Nat name.  I fixed that and it is working good now.  Thanks for the help.
0
 
LVL 16

Expert Comment

by:memo_tnt
ID: 26089897
That's well
Best Regards
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Originally, this post was published on Monitis Blog, you can check it here . It goes without saying that technology has transformed society and the very nature of how we live, work, and communicate in ways that would’ve been incomprehensible 5 ye…
This article will show you step-by-step instructions to build your own NTP CentOS server.  The network diagram shows the best practice to setup the NTP server farm for redundancy.  This article also serves as your NTP server documentation.
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question