XP Pro Client Outlook 2007 Connection with SBS Exchange 2003

Posted on 2009-12-19
Last Modified: 2012-06-27
After doing a complete XP Pro reinstall on my Laptop as a result of a Virus, I installed Microsoft Office 2007 again but when creating an Exchange profile I can no longer get http over rpc connection to my Exchange Server 2003.

The issue is that although the Name of the Server is resolved when setting up the Outlook profile, and the Username/Password prompt is displayed as expected, the following message is received:

"Cannot open your default E-mail folders. You must connect to Microsoft Exchange with the current profile before you can synchronize your folders with your offline folder file."

Note also that when I login to the SBS2003 Server locally (on the local domain) and attempt to get Outlook 2007 to connect to the Microsoft Exchange Server, I get the same error above.

Would appreciate nay help here.
Question by:e2e01
    LVL 8

    Expert Comment

    Are you certain there are no SSL certificate errors getting in the way?

    If you browse to https://ExchangeAddress/OWA do you get any warnings or any "broken locks" relating to the certificates?  That would cause an issue like this.

    If you've installed your own SSL certificate, you must browse to "https://SSLCertServer/certsrv" and download the certificate/chain and place them in the trusted root store on the local machine.  You'll then need to close IE and start it again to verify that you don't get any warnings.

    If there are no certificate errors with this, Please verify your firewall settings.  

    Author Comment

    Certificate installed for Exchange Server exactly the same as my desktop which does allow access to the exchan ge Server from Outlook 2007.

    Normal use of Windows firewall - have not changed configuration so I don't believe either of these are teh problems. Also have installed the registry RPC DefConnectOps and still no joy. I also unchecked the Use Cached Exchange MOde. I get the message: "Cannot Open Default E-Mail Folders. Attempt to logon to Microsoft Exchange has failed".

    LVL 8

    Expert Comment

    Ok, I don't mean to hash through all the basics, I just need a place to start:

    Are you setting the user for basic authentication and to use HTTPS first?  If it is set to NTLM it may just continue to prompt you.

    Also, are the internal DNS settings set so when inside the office it knows to look to a local address?  Is his client set to receive IPs and Name Server via DHCP?  

    Have you attempted a repair/reinstall of office just incase something is goofy with the .dlls or files used during the install?

    Again, I know you know what you're doing, I just need a starting block and sometimes the simple stuff is overlooked.

    Author Comment

    OK, so now I am on teh same LAN as the Exchange Server. I have logged into the domain and can look at all network drives, and access Sharepoint on the SBS2003 Server (the host for Microsoft Exchange). However, when I run up Outlook 2007, I just get "Cannot open your default E-mail folders. The attempt to logon to Microsoft Exchange has failed.

    Re-installed Office 2007 last night.
    How do I check whether:

    a) the internal DNS settings are set so that when inside the office it knows to look to a local address?  b) the client is set to receive IPs and Name Server via DHCP?  

    Your continued assistance is much appreciated, haven't seen this behaviour before and have just rebuilt my home machine with success and was able to connect to the Exchange at teh office with success once I followed the Outlook 2007 http over RPC instructions so teh problem is definitely located to this Laptop. I can access my Exchange account from Outlook 2007 on other computers in the office.
    Really don't want to rebuild XP Pro again but unless I can resolve teh problem quickly, might be the only answer.


    LVL 8

    Expert Comment

    ok, have you tried creating a new profile from within Control Panel -> Mail icon?  That would start the item over.

    If you open cmd prompt - start->run->cmd and press enter and type "ipconfig /all" and press enter (no quotes), make sure it announces a DHCP server and that the name servers are legit (make sure its not being hijacked by a virus or anyting, just something I have to check).  If everything looks good there, we can move onto creating the new profile.

    Open the mail icon and choose "show profiles" and choose "Add" and go through the steps of re-creating the account.  When finished back at the main "Mail" screen, just choose to use the new one by default from the drop down menu and the radio button that says "always use this profile".

    could you screen shot your settings for me and post them?  I have Outlook 2007 running on Exchange 2003 rpc over https and I'd just like to see where there may be something missing (if the new profile doesn't work).

    Author Comment

    I think it is important now to resolve the problem at the Local LAN end as this should be alot simpler - I know the Outlook 2007 over RPC is troublesome at the best of times.

    I have my Laptop XP CLient logged into my local domain (i.e. I log-into the SBS2003 Domain with the Microsoft Exchange server on it at the office.

    Could I suggest we get this working first.

    Is there a process for creating a new local profile or is this something XP does automatically. Interestingly enough, I have attached the Laptop to the domain by selecting the domain through the My Computer Properties as http:\\ConnectCOmputer was unsuccessful - think this might be related.
    LVL 8

    Expert Comment

    to connect to the server directly you would use \\servername (without the http).  This machine is joined to the domain correct? If not, it would prevent it from resolving the username/server items.

    Ok, we'll take the RPC bit out of it.  Create a new profile as I described above and please follow these steps after creating the new profile:

    While connected to the LAN for the server on the exchange creation please enter "ServerName.domain.local" or whatever your domain scheme is (, domain.local, this would be the internal domain, you can find this by right clicking My computer, choosing properties, and viewing the "Computer Name" tab and seeing what the "Full computer name" is of the server).

    enter the user's name and choose "check name" to have it resolve.  We won't worry about the RPC bit, we just want to make sure exchange is working properly.

    if this does work, please let me know and I can troubleshoot the RPC bit with you further, it just adds to the problem and we want to make sure DNS settings, laptop config, and username properties/permissions are correct first.

    Thanks, I will be here and can answer quickly

    Author Comment

    OK - I have some more diagnostics. I ran netdiag on the Laptop and have pasted the following output:

    The DC not being available seems to be the key but how do I make it available - looks like the Laptop is not properly connected to the Domain

        Computer Name: ELIOT
        DNS Host Name: eliot.e2eservicesltd.local
        System info : Windows 2000 Professional (Build 2600)
        Processor : x86 Family 6 Model 15 Stepping 6, GenuineIntel
        List of installed hotfixes :

    Netcard queries test . . . . . . . : Passed
        [WARNING] The net card 'Intel(R) PRO/Wireless 3945ABG Network Connection - Packet Scheduler Miniport' may not be working.
        [WARNING] The net card 'Intel(R) PRO/Wireless 3945ABG Network Connection' may not be working.

    Per interface results:

        Adapter : Wireless Network Connection

            Netcard queries test . . . : Failed
            NetCard Status:          DISCONNECTED
                Some tests will be skipped on this interface.

            Host Name. . . . . . . . . : eliot
            IP Address . . . . . . . . :
            Subnet Mask. . . . . . . . :
            Default Gateway. . . . . . :
            Dns Servers. . . . . . . . :

        Adapter : Local Area Connection

            Netcard queries test . . . : Passed

            Host Name. . . . . . . . . :
            IP Address . . . . . . . . :
            Subnet Mask. . . . . . . . :
            Default Gateway. . . . . . :
            Primary WINS Server. . . . :
            Dns Servers. . . . . . . . :

            AutoConfiguration results. . . . . . : Passed

            Default gateway test . . . : Passed

            NetBT name test. . . . . . : Passed
            [WARNING] At least one of the <00> 'WorkStation Service', <03> 'Messenger Service', <20> 'WINS' names is missing.

            WINS service test. . . . . : Passed

    Global results:

    Domain membership test . . . . . . : Passed

    NetBT transports test. . . . . . . : Passed
        List of NetBt transports currently configured:
        1 NetBt transport currently configured.

    Autonet address test . . . . . . . : Passed

    IP loopback ping test. . . . . . . : Passed

    Default gateway test . . . . . . . : Passed

    NetBT name test. . . . . . . . . . : Passed
        [WARNING] You don't have a single interface with the <00> 'WorkStation Service', <03> 'Messenger Service', <20> 'WINS' names defined.

    Winsock test . . . . . . . . . . . : Passed

    DNS test . . . . . . . . . . . . . : Passed

    Redir and Browser test . . . . . . : Passed
        List of NetBt transports currently bound to the Redir
        The redir is bound to 1 NetBt transport.

        List of NetBt transports currently bound to the browser
        The browser is bound to 1 NetBt transport.

    DC discovery test. . . . . . . . . : Passed

    DC list test . . . . . . . . . . . : Failed
        'e2eservicesltd': No DCs are up.

    Trust relationship test. . . . . . : Failed
        'e2eservicesltd': No DCs are up (Cannot run test).
        [FATAL] Secure channel to domain 'e2eservicesltd' is broken. [ERROR_NO_LOGON_SERVERS]

    Kerberos test. . . . . . . . . . . : Passed

    LDAP test. . . . . . . . . . . . . : Passed
        [WARNING] Failed to query SPN registration on DC 'E2ESERVER.e2eservicesltd.local'.

    Bindings test. . . . . . . . . . . : Passed

    WAN configuration test . . . . . . : Skipped
        No active remote access connections.

    Modem diagnostics test . . . . . . : Passed

    IP Security test . . . . . . . . . : Passed
        Service status  is: Started
        Service startup is: Automatic
        IPSec service is available, but no policy is assigned or active
        Note: run "ipseccmd /?" for more detailed information

    The command completed successfully
    LVL 8

    Accepted Solution

    Your IP Address is on a different subnet than your domain controller, which is on a different subnet than your gateway.  Are all the other machines like this?

    is your DC (SBS 2003 server) or  The client should be using the server as its main DNS server, so that would be something to ensure.  

    Why are the name servers and the LAN segments on different schemes/subnets if they are located in the same location?  You may be having trouble with that on the local machine.  Can you run an ipconfig /all on another machine and let me know what its settings are?  

    Again, please check you LAN card settings from within the control panel -> network connections ->tcp/ip -> properties and ensure DHCP is selected for everything.  Also, please check you hosts file (opens with notepad) at C:\windows\system32\drivers\etc\hosts on the laptop to ensure there aren't any hardcoded entries in there.

    Author Comment

    Maniac 47: MANY THANKS - THAT RESOLVED The Issue

    It was because there were a number of hard coded entries in the etc/hosts file as you perceived probably from failed attempts when I was trying to attach from Outlook2007 over http remotely. Will try it from my home tonight but should be Ok so long as I use the same configuration as my Desktop at home.

    LVL 8

    Expert Comment

    Awesome, I'm so glad that worked, I was starting to run out of ideas ;-)

    Author Comment

    Was too premature! Whilst I am able to connect to Exchange locally on the LAN, I am still unable to connect to Exchange remotely from the Laptop using Outlook over rpc. Seems to recognise the Exchange Server, I am still getting failed to open Outlook Default Folders. Can you shed any lighto n this or do I need to Open a new question.  

    Featured Post

    What Security Threats Are You Missing?

    Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

    Join & Write a Comment

    Sorry for my English and Italian screenshots..... Problem: Every Year the number of E-Mails grow dramatically and the space that they take on Exchange Servers or .PST files, grow much more faster, once it was only text, now our E-Mail Archives …
    Get people started with the process of using Access VBA to control Outlook using automation, Microsoft Access can control other applications. An example is the ability to programmatically talk to Microsoft Outlook. Using automation, an Access applic…
    This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …

    734 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    22 Experts available now in Live!

    Get 1:1 Help Now