• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 435
  • Last Modified:

SBS2008 migration changing IP DNS troubles

Hi All,

I have a major problem.  I migrate my sbs2003 to sbs2008 without any problems.
Butm ny setup was like this: server01 is the old sbs server and server1 is the new sbs server.

WAN is conntect to server01 with ip 192.168.1.1
DHCP on second LAN card of server01 192.168.0.1

I did the migration, I connected server1 to the same router, and gave it 192.168.1.2
And on the lan side, he gets an 192.168.0.3

I completed the migration, turned off server01, and gave server1 the same IP adresses as server01
so 192.168.1.1 for the wan side, en 192.168.0.1 for the lan side.

This gave me alot of troubles.  Because the DNS server is acting as 192.168.1.2
So it isn't reachable from the network.
I tried everything i supose, erased the dns records,
did a network fix out the SBS console; only thing that he does is disable my lan adapter, and set the wan adapter on 192.168.1.2

Have somebody a solution???
0
trivin
Asked:
trivin
  • 13
  • 11
2 Solutions
 
Rob WilliamsCommented:
SBS 2008 does not support 2 Network cards.
Disable the WAN card, run the "configure internet access" and"fix my network" wizards under SBS management console / network /connectivity
0
 
trivinAuthor Commented:
How can I have a DHCP server running, and at the same time be connected with a cisco router with a static IP?

The provider configured the cisco router, so I can't change any thing...
0
 
Rob WilliamsCommented:
Are you saying the Cisco router is also a DHCP server?
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
Rob WilliamsCommented:
If so, and you cannot change the router config, the following guide outlines the procedure:
http://sbs.seandaniel.com/2008/10/do-i-absolutely-have-to-run-dhcp-on-sbs.html
0
 
trivinAuthor Commented:
no no, it's not a dhcp server, it's just configured with static ip adresses.
For the port forwarding to my server.

0
 
Rob WilliamsCommented:
I assume then the SBS WAN NIC is configured with 192.168.1.1.
If that is the case you just need to disable one NIC and assign the other that address then run the wizards. The LAN clients, printers and such will have to be updated from the old subnet to the new. The ones using DHCP of course will automatically be updated on reboot.

It is important to use these wizards and then the "Set up your Internet address" wizard to configure your incoming services such as mail, OWA, RWW. Basically follow all the "getting started tasks" on the home page of the SBS server console.
0
 
trivinAuthor Commented:
Then I have to change all the static IP's, but okay, it's done know.

And indeed the 1.2 is gone.  Only 1.1 now.
But he can't fix the exchange connectors..
He said, that he cant connect.
0
 
trivinAuthor Commented:
damn eh... Still can't receive mails... I played with the receive connector a hundred times, it's doesn't change.  I get always a warning client cannot authenticate.

I tried to run the internet connection wizzard alot, he can't create the connector
0
 
Rob WilliamsCommented:
If the internet connection wizard will not run, run the fix my network wizard first.
Exchange will not work properly until you also run the "Set up your Internet address" wizard.
What are you referring to with the Exchange connector? POP connector? There should be no need to manually configure Exchange, everything can be done using the wizards in the SBS console.
0
 
trivinAuthor Commented:
I use an smtp connector to send mails, to a smtp server, that works.
But receiving doesn't work.

Fix my network wizzard, was the same issue, could not connect the smtp connectors.

I did that serveral times...
I just rebooted the server, and I'm triyng again
0
 
Rob WilliamsCommented:
The wizards will prompt you to enter the SMTP connector address, I believe though the wizard refers to it as a Smart Host.

You should likely run the SBS Best Practices analyzer to see if it will help determine any issue which are not allowing the wizards to run.
http://www.microsoft.com/downloads/details.aspx?familyid=86a1aa32-9814-484e-bd43-3e42aec7f731&displaylang=en
0
 
trivinAuthor Commented:
when I do a fix network;  I get the following warnings;

could not configure the router (cisco sdsl router)
dhcp is not configured for IPv6
trusted certificate is expired or invalid  (strange because it's a purchaised certificate, only thing is, the server isn't their on the certificate.
problem with exchange connector

I triy to fix this now...
0
 
trivinAuthor Commented:
he fixed it, but still he can't fix the exchange .
i gonna look at the link that you gave me...
0
 
trivinAuthor Commented:
hmm strante... the certificate is removed.
Back to the old self signed one.  And now I'm receiving mail, but I created the connector myself...
0
 
Rob WilliamsCommented:
The certificate is not needed for Exchange but is for OWA and RWW.
0
 
trivinAuthor Commented:
RWW?

But without the certificate it works...
With the ceritificate not damn...
0
 
Rob WilliamsCommented:
Very odd. It does need a certificate to work, but it can be a self signed cert. RWW (Remote Web Workplace) and OWA either need a purchased cert, or the self signed has to be installed on the connecting machine.
0
 
trivinAuthor Commented:
That's why we purchased the certificate.
I add it to for the smtp and the IIS service.
Hmm, I can enable it again for see what it does...?
0
 
trivinAuthor Commented:
crazy... It's al fixed... At least a good running sbs2008 :-)

Thanks to Robwill

Was acting crazy, I add the certificate to the IIS service in exchange.
And now my owa works again nice.  Mailflow is working good.
outlook over http works also with the old certificate on the client.

So the troubleshooter was the purchased certificate on the smtp service, once it was disabled, mails were getting in.
0
 
Rob WilliamsCommented:
Glad to hear you were able to resolve.
0
 
trivinAuthor Commented:
Perfect thanks !!!

I worked till 04 a.m. this night.
Without you, it wasn't finished yet.
Is believed, the config worked with w2k3sbs, why not with w2k8sbs?

And also with the certificates... Really strange, just added my new certificate to exchange, only add it with the http service.
Everything is working.

Again thanks!!!! i'm safed..
0
 
Rob WilliamsCommented:
>>"Is believed, the config worked with w2k3sbs, why not with w2k8sbs?"
Just a change in the design of SBS 2008. 2003 fully supported 2 NIC's and the documentation to run with either 1 or 2 was readily available and supported. The system requirements for 2008 say only 1 NIC, and if you install a second you will get errors from various wizards and the BPA.

I am not sure why you had the certificate errors other than it was possibly not being properly installed.

Thanks trivin.
Cheers!
--Rob
0
 
trivinAuthor Commented:
Yeah, that happends when I'm not reading the requirements :)  Thanks for the info!
The sbs console isn't working good, problems with adding groups etc... Just use active directory console or exchange console, like i'm used to...


I'm getting an error in the event log, to enable the certificate also on the smtp service.  Gonna try to add the smtp service this night again.  I have now a good UCC certificate with al the names.

Thanks for the help Rob!!!!
0
 
Rob WilliamsCommented:
Very welcome.
After a migration there are usually numerous little issue that have to be cleaned up. Usually running the BPA and gradually addressing these will get things "back to normal". Hopefully that will fix the SBS console issues, as it is best to use it rather than ADUC whenever possible.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 13
  • 11
Tackle projects and never again get stuck behind a technical roadblock.
Join Now