?
Solved

Can't Ping Third Router from Switch

Posted on 2009-12-19
17
Medium Priority
?
570 Views
Last Modified: 2012-05-08
I can ping the first two routers from a switch, but not the third. I have switch S1 (VLAN 1 = 192.168.2.9) connected to router R1 (fa0/0 = 192.168.2.1) connected via serial (s0/0 = 192.168.1.1) to serial of router R2 (s0/0 = 192.168.1.2) and that R2 (fa0/0 = 192.168.0.11) is connected to non-Cisco router R3 (192.168.0.1). I thought I was pinging R3 from S1 before, but it's not working. I'm using RIPv2 between routers.
S1#
S1#
S1#ping 192.168.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
S1#
S1#
S1#ping 192.168.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
S1#
S1#
S1#ping 192.168.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
S1#
S1#
S1#
S1#
S1#sh cdp nei det
-------------------------
Device ID: R1
Entry address(es):
  IP address: 192.168.2.1
Platform: cisco 2620XM,  Capabilities: Router
Interface: FastEthernet0/24,  Port ID (outgoing port): FastEthernet0/0
Holdtime : 165 sec

Version :
Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-I-M), Version 12.3(17a), RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Mon 12-Dec-05 14:12 by evmiller

advertisement version: 2
Duplex: full
Management address(es):

S1#
S1#
S1#

============================================
============================================

R1#
R1#
R1#
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

R    192.168.0.0/24 [120/1] via 192.168.1.2, 00:00:10, Serial0/0
C    192.168.1.0/24 is directly connected, Serial0/0
C    192.168.2.0/24 is directly connected, FastEthernet0/0
R1#
R1#
R1#sh cdp nei det
-------------------------
Device ID: R2
Entry address(es):
  IP address: 192.168.1.2
Platform: cisco 2620XM,  Capabilities: Router
Interface: Serial0/0,  Port ID (outgoing port): Serial0/0
Holdtime : 157 sec

Version :
Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-I-M), Version 12.3(17a), RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Mon 12-Dec-05 14:12 by evmiller

advertisement version: 2

-------------------------
Device ID: S1
Entry address(es):
  IP address: 192.168.2.9
Platform: cisco WS-C2950-24,  Capabilities: Switch IGMP
Interface: FastEthernet0/0,  Port ID (outgoing port): FastEthernet0/24
Holdtime : 137 sec

Version :
Cisco Internetwork Operating System Software
IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA13, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by cisco Systems, Inc.
Compiled Fri 27-Feb-09 22:20 by amvarma

advertisement version: 2
Protocol Hello:  OUI=0x00000C, Protocol ID=0x0112; payload len=27, value=00000000FFFFFFFF010221FF000000000000001201BC4AC0FF0000
VTP Management Domain: ''
Native VLAN: 1
Duplex: full

R1#
R1#
R1#

============================================================
============================================================

R2#
R2#
R2#
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.0.0/24 is directly connected, FastEthernet0/0
C    192.168.1.0/24 is directly connected, Serial0/0
R    192.168.2.0/24 [120/1] via 192.168.1.1, 00:00:03, Serial0/0
R2#
R2#
R2#
R2#
R2#sh cdp nei det
-------------------------
Device ID: R1
Entry address(es):
  IP address: 192.168.1.1
Platform: cisco 2620XM,  Capabilities: Router
Interface: Serial0/0,  Port ID (outgoing port): Serial0/0
Holdtime : 125 sec

Version :
Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-I-M), Version 12.3(17a), RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Mon 12-Dec-05 14:12 by evmiller

advertisement version: 2

R2#
R2#
R2#

Open in new window

0
Comment
Question by:GivenRandy
  • 7
  • 7
  • 3
17 Comments
 
LVL 13

Expert Comment

by:GuruChiu
ID: 26088647
can you pls post traceroute result from R3 to S1, and from S1 to R3?
0
 
LVL 57

Expert Comment

by:giltjr
ID: 26088745
Does R3 actually have a route back to R1?
0
 
LVL 9

Author Comment

by:GivenRandy
ID: 26088860
The R3 is a D-Link router. :(

From S1 to R3:

S1#traceroute 192.168.0.1

Type escape sequence to abort.
Tracing the route to 192.168.0.1

  1 192.168.2.1 4 msec 0 msec 4 msec
  2 192.168.1.2 4 msec 4 msec 0 msec
  3  *  *  *
  4  *  *  *
  5  *  *  *
.
.
.
 29  *  *  *
 30  *  *  *
S1#
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 57

Expert Comment

by:giltjr
ID: 26088944
Can you ping 192.168.0.1 from any place?

It looks like you have:

S1 <--> R1 <--> R2 <--> R3

If so what is on the other side of R3?  Can it ping R2, R1, or S1?
0
 
LVL 9

Author Comment

by:GivenRandy
ID: 26088951
That's the correct layout.

I have computers connected to the switchports of R3 (4 port switch on cheap router, which has its WAN connected to cable modem).

From one of those computers, I can ping 192.168.0.1 (R3). I can also ping 192.168.0.11 (fa0/0 of R2) but not 192.168.1.2 (s0/0 of R2) which leads me to believe that something is wrong with the routing of R2, but I can't spot anything.
0
 
LVL 13

Assisted Solution

by:GuruChiu
GuruChiu earned 500 total points
ID: 26088987
Please make sure you have the routes to 192.168.1.0/24 and 192.168.2.0/24 configured on the DLink router, or make sure RIP is working on the DLink router. The problem is with the DLink router.
0
 
LVL 13

Expert Comment

by:GuruChiu
ID: 26089012
If you can let me know which model of DLink router you have, may be I can help you with the exact configuration that you will need.
0
 
LVL 9

Author Comment

by:GivenRandy
ID: 26089039
D-Link DIR-655.
0
 
LVL 57

Expert Comment

by:giltjr
ID: 26089235
Will R2 shows that it knows that it is directly connected to 192.168.0.0/24.  So there should be no routing issues. Could there be an ACL on R2 that blocks ICMP to that subnet?

Can you ping 192.168.0.1  from R2?
0
 
LVL 9

Author Comment

by:GivenRandy
ID: 26089290
Yes, can ping 192.168.0.1 (R3) from R2, but that should be the case anyhow since they're directly connected. There shouldn't be any ACLs -- I started from a clean config in this case and only set up RIPv2. I'll include the show-run from R1 and R2:
===========================
R1
===========================

Current configuration : 1328 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$8oVy$WghYL1yLVvuCKdfo6RkXc0
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 1
no network-clock-participate wic 0
ip subnet-zero
!
!
no ip dhcp use vrf connected
!
!
ip cef
no ip ips deny-action ips-interface
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.2.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 192.168.1.1 255.255.255.0
 clockrate 1000000
 no dce-terminal-timing-enable
!
router rip
 version 2
 network 192.168.1.0
 network 192.168.2.0
 no auto-summary
!
ip classless
ip route 192.168.1.0 255.255.255.0 Serial0/0
ip route 192.168.2.0 255.255.255.0 FastEthernet0/0
!
!
no ip http server
no ip http secure-server
!
!
!
tftp-server flash:/c2600-advipservicesk9-mz.124-1c.bin
tftp-server flash:c2600-advipservicesk9-mz.124-1c.bin
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 password controls
 logging synchronous
line aux 0
line vty 0 4
 exec-timeout 0 0
 password controls
 logging synchronous
 login
line vty 5 15
 exec-timeout 0 0
 password controls
 logging synchronous
 login
!
!
end

===========================
R2
===========================

Current configuration : 1072 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 1
no network-clock-participate wic 0
ip subnet-zero
!
!
no ip dhcp use vrf connected
!
!
ip cef
no ip ips deny-action ips-interface
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.0.11 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 192.168.1.2 255.255.255.0
 no dce-terminal-timing-enable
!
router rip
 version 2
 network 192.168.0.0
 network 192.168.1.0
!
ip default-gateway 192.168.0.1
ip classless
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 password controls
 logging synchronous
line aux 0
line vty 0 4
 exec-timeout 0 0
 password controls
 logging synchronous
 login
line vty 5 15
 exec-timeout 0 0
 password controls
 logging synchronous
 login
!
!
end

Open in new window

0
 
LVL 57

Expert Comment

by:giltjr
ID: 26089320
Do you have access to the D-Link's Managment interface?

If so, on the Advanced Networking page is "enable WAN Ping respond" checked?
0
 
LVL 9

Author Comment

by:GivenRandy
ID: 26089343
I have access. That option is unchecked, but I want to leave it that way -- I don't want pings from the WAN side. I'm on the LAN side of that router.
0
 
LVL 57

Expert Comment

by:giltjr
ID: 26089354
What port on the D-Link is R2 Connected to?
0
 
LVL 9

Author Comment

by:GivenRandy
ID: 26089385
It's one port of the four-port switch on that router.
0
 
LVL 57

Accepted Solution

by:
giltjr earned 1500 total points
ID: 26089400
O.K, from what I can tell in the user's guide you can't update or add routes to this D-Link.

So its default route sends everything that is not on the local IP subnet to the WAN port.

Which explains why you can't ping 192.168.0.1 only from R2 and the only IP address in R2 you can ping is 192.168.0.11.

When you attempt to ping 192.168.1.2 from one of the PC's on the D-Link the D-Link has no clue how to get to 192.168.1.0/24 subnet, so it routes the ping out the WAN interface.

The only way you will be able to ping anything from your other subnets from the PC's on the D-Link is to add routes on them that point to 192.168.0.11.

Basically the D-Link seems to only do switching on the LAN ports.  The only routing it seems to do is between the LAN ports and the WAN port.  You seems to be trying to do routing using the LAN ports.
0
 
LVL 57

Expert Comment

by:giltjr
ID: 26089402
I had been going on the assumption the R2 was connected to the WAN port of the D-Link.
0
 
LVL 9

Author Closing Comment

by:GivenRandy
ID: 31668165
Thanks for the education!
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We've been using the Cisco/Linksys RV042 for years as: - an internet Gateway - a site-to-site VPN device - a leased line site-to-site subnet-to-subnet interface (And, here I'm assuming that any RV0xx behaves the same way as an RV042.  So that's …
In the hope of saving someone else's sanity... About a year ago we bought a Cisco 1921 router with two ADSL/VDSL EHWIC cards to load balance local network traffic over the two broadband lines we have, but we couldn't get the routing to work consi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

807 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question