[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 571
  • Last Modified:

Microsoft Exchange 2003 Server won't receive e-mails after internal IP change.

We have an Exchange server (running on Windows 2003) that we changed the IP address on and moved to a new subnet. It no longer receives external e-mails. It can send just fine and it has no problem accessing internal resources or the internet. But for whatever reason, it will not receive. We didn't make any changes to the external IP nor the ASA firewall rules. I don't even know where to begin troubleshooting on this one. Can anyone help me?
0
ryanmnly
Asked:
ryanmnly
1 Solution
 
MidnightOneCommented:
Does the ASA firewall allow SMTP traffic only to the old IP address.
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
What is the MX record shows at ISP did you change that to the new one ??
Also if there is Firewall settings to send mail to server at xyz IP then chnage that too
0
 
ryanmnlyAuthor Commented:
That's what I thought, but the rules weren't changed, only the IP address of that device. So as far as I can tell, the ASA appears correct.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
ryanmnlyAuthor Commented:
The public IP didn't change, only the internal one. So the MX record is the same. There might be something on the Exchange server, but I'm not completely sure where to look. I'll check that right now.
0
 
MidnightOneCommented:
I'm still thinking the ASA was doing port forwarding for port 25 connections to the old IP address.
0
 
ryanmnlyAuthor Commented:
Ok, so I checked out the ASA routing and was able to telnet to port 25 going through the ASA and our router. So it appears that routing is not causing the issue. Is there some sort of setting in Exchange that may dictate who it receives SMTP data from?  Also, the firewall is not enabled.
0
 
ryanmnlyAuthor Commented:
Also do you know where I could watch this happen in real-time? Or are there log files? I need to narrow this down in a methodical way. If I can see whether it is even hitting the server or not, then I could get a much better idea of whether it is network related or not.
0
 
ryanmnlyAuthor Commented:
Ok, I figured it out. Yes, in the Exchange Systems Manager, you go to your SMTP settings for the Default SMTP Virtual Server. In there I had to set the SMTP server to the new IP address and not the old one. Thanks for the help all, it helped me narrow it down.
0
 
ChiefITCommented:
Just an added thought.

In addition to pointing the clients to the right IP, make sure the HOST A record is registered in DNS.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now