• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1221
  • Last Modified:

HP-UX 11 - SIOC_INQUIRY when running diskinfo

Hello Everyone!
        We recently removed a few disks from an HP-UX server, however they are still showing up when running an ioscan -fnC command.  Here is what we have done:

1. Remove all volume groups and associations with the disks
2. shutdown server
3. Removed LUN association on SAN
4. performed ioscan -fnC (disks still show up as "claimed")
5. removed special files using rmsf 'path to special file'
6. rmfs -H 'hardware path'
7. reboot

From our understanding, the disks should now be gone from HP-UX.  The strange thing is that the disks still show up as "Claimed" when we run an ioscan -fnC, but there are no associated special files.  If we do a diskinfo of the disks, we receive a message that states "SIOC_INQUIRY."

We have tried adding in new disks (we rebuilt our RAID group for RAID 1/0 instead of RAID5) but they are not accessible as the system appears to see the old disks still.  I am not the Unix admin for our company, but I am trying to assist him.  I would appreciate any assistance you can provide!  Please let me know if any further information is required.

JustMirsk
0
jmirsky
Asked:
jmirsky
1 Solution
 
jmirskyAuthor Commented:
We resolved this issue, it turns out Unix was not the problem, we had powerpath installed and it was causing our issues.  We issued a powermt -check command to clean up the entries and this resolved our issue.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now