[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2120
  • Last Modified:

Inbound SMTP mail not being received on Exchange 2010 Server

I have a Windows 2008 R2 domain with a single Exchange 2010 server. I have a firewall that port forwards incoming SMTP port 25 to the Exchange 2010 server. On the Exchange server, I have the default receive connector set to accept mail from 0.0.0.0-255.255.255.255. I have anonymous checked in the permissions on the receive connector.

I can send SMTP mail to the Internet just fine but I can't receive SMTP mail. I have the DNS set up by my ISP with an MX record pointing to the external Internet IP that is port forwarded the the Exchange Server.
 
What am I missing?

Thanks,

Dave

0
dcadler
Asked:
dcadler
  • 3
  • 2
2 Solutions
 
Glen KnightCommented:
Make sure that the only TLS is checked (sorry can't remember the tab name) on the tab before authentication.

Are you receivmg an NDR when you try to send mail?

Make sure it's the Default connector you change and not the Client one
0
 
Alan HardistyCommented:
What port are you forwarding and what port is the receive connector set to?  The default port is 995 I think.  If you are forwarding port 25 and you have not changed the receive connector then mail will fail.
0
 
Glen KnightCommented:
Default CLIENT connector is set to port 587 the connector that says DEFAULT at the beginnng will be set to port 25

assuming you installed the Hub Transport role?
If you didn't then you need to.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
Alan HardistyCommented:
Ah yes - good point Glen, I was thinking about pop3 port number!
0
 
dcadlerAuthor Commented:
I discovered the problem, which was with the firewall. There were two areas that addresses port forwarding and we had only changed the IP address in one of them. Changing the other to the correct IP address got the mail flowing again.

However, your input has brought up a couple of related questions.

1. I deleted the Default Client connector, which was set to port 587, as I was trying to figure out why I was not receiving mail. Now that mail is flowing again, I wonder if I need to add the connector back in. What is it's porpose?

2. You had mentioned TLS. I had disabled TLS because on another site that is running Exchange 2007, I was getting SPAM encrypted with TLS that was bypassing my spam filters. I only have one Exchange server and all roles are on one physical (actually one virtual) server. When I disabled the TLS on the other site, it solved the TLS spam issue. Do I need TLS if I am not communicating with other domain Exchange servers or roles?

Dave
0
 
Glen KnightCommented:
1 > This connector is insalled by default and uses port 587 which is Secure SMTP this is used for all non Exchange Clients, for example POP3 and IMAP to send mail after authenticating.  Also used for application servers that need to relay via SMTP on your exchange server.

2 > Not 100% sure to be honest but if your in a single Exchange server envionment no you shouldn't need it.

Have a look here for more information regarding receive connectors and the default
installation configuration: http://technet.microsoft.com/en-us/library/aa996395.aspx
0

Featured Post

Free recovery tool for Microsoft Active Directory

Veeam Explorer for Microsoft Active Directory provides fast and reliable object-level recovery for Active Directory from a single-pass, agentless backup or storage snapshot — without the need to restore an entire virtual machine or use third-party tools.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now