[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Cummunication between VLANs (shared folders, dns queries,,,etc)

Posted on 2009-12-20
12
Medium Priority
?
1,305 Views
Last Modified: 2012-05-08
Hi

I have crated 3 VLANs in cisco and dlink switches and configured inter routing in the layer3 switches, please show the attached image.
my problem is i cant open shared folders in VLAN1 from  vlan2 and vlan4. should i create access list to allow such protocols and connection between vlans? if you how that can be done?
VLAN.png
0
Comment
Question by:Suliman Abu Kharroub
12 Comments
 
LVL 4

Assisted Solution

by:satyasingh
satyasingh earned 400 total points
ID: 26091451
If currently there is no restriction applied between inter vlan routing, it should work. You may want to check if machines in one vlan allow share folders and the problem is only from different vlan's?
0
 
LVL 21

Accepted Solution

by:
Rick_O_Shay earned 800 total points
ID: 26091475
Without any ACL's or firewall rules to block it everything should be allowed by default. However, since you are going across router interfaces things like Netbios won't go through. I believe there is a setting on the PC network adapter about forwarding Netbios over IP which is what you want. It is in the TCP tab, advanced then wins tab on XP.
0
 
LVL 17

Assisted Solution

by:rochey2009
rochey2009 earned 800 total points
ID: 26091753
Hi,

Can you ping between vlans?
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
LVL 23

Author Comment

by:Suliman Abu Kharroub
ID: 26091883
satyasingh:
Yes , machines in the same VLANs can access shared folders, but between vlans not.

Rick_O_Shay:
I will test it tomorrow and post pack.

rochey2009:
yes i can ping between devices between vlans .

Thank you all,
0
 
LVL 17

Expert Comment

by:rochey2009
ID: 26091931
it could be an issue with name resolution.

from a dos prompt:
try

net use x: \\ipaddress\shared folder

substitute drive letter, ip address of the server and the name of the shared folder.
0
 
LVL 23

Author Comment

by:Suliman Abu Kharroub
ID: 26091961
already tried to access shared by IP address. not working.
0
 
LVL 17

Expert Comment

by:rochey2009
ID: 26091988
Are there any personal firewalls installed on the end devices?
0
 
LVL 23

Author Comment

by:Suliman Abu Kharroub
ID: 26092009
yes one of the file server is windows server 2003 with windows firewall enabled. but i can access shares on it from the same VLAN, so i dont think it is an windows firewall issue.

one thing more,there was an DNS issue, but i solved it by enable DNS relay on the switch and client machines points to switch as a DNS server. now there are no name resolution issues
0
 
LVL 23

Author Comment

by:Suliman Abu Kharroub
ID: 26094596
the only IPs that I can ping is switches interfaces .

so I think my problem is in routing table, as the switch does not route packets between vlans, right ?

here is the core Cisco switch routing talbe :
Gateway of last resort is 10.0.0.1 to network 0.0.0.0

     192.168.8.0/28 is subnetted, 1 subnets
C       192.168.8.0 is directly connected, Vlan6
     192.168.4.0/28 is subnetted, 1 subnets
C       192.168.4.0 is directly connected, Vlan3
     10.0.0.0/16 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, Vlan1
     192.168.2.0/27 is subnetted, 1 subnets
C       192.168.2.0 is directly connected, Vlan2
S*   0.0.0.0/0 [1/0] via 10.0.0.1
C    192.168.6.0/23 is directly connected, Vlan5

Clint confgutation :

connected to port in VLAN2.
IP address 192.168.2.10/27
DG 192.168.2.1
0
 
LVL 23

Author Comment

by:Suliman Abu Kharroub
ID: 26094647
Running-config:

Current configuration : 3432 bytes
!
version 12.2
service config
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Core1
!
enable secret 5 $1$sMc.$FPBgGRqUpT32kGcaA5fuJ.
!
no aaa new-model
system mtu routing 1500
ip subnet-zero
ip routing
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface GigabitEthernet0/5
!
interface GigabitEthernet0/6
!
interface GigabitEthernet0/7
!
interface GigabitEthernet0/8
!
interface GigabitEthernet0/9
!
interface GigabitEthernet0/10
!
interface GigabitEthernet0/11
!
interface GigabitEthernet0/12
!
interface GigabitEthernet0/13
!
interface GigabitEthernet0/14
!
interface GigabitEthernet0/15
!
interface GigabitEthernet0/16
!
interface GigabitEthernet0/17
!
interface GigabitEthernet0/18
!
interface GigabitEthernet0/19
!
interface GigabitEthernet0/20
!
interface GigabitEthernet0/21
!
interface GigabitEthernet0/22
!
interface GigabitEthernet0/23
!
interface GigabitEthernet0/24
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface GigabitEthernet0/27
!
interface GigabitEthernet0/28
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/29
!
interface GigabitEthernet0/30
!
interface GigabitEthernet0/31
!
interface GigabitEthernet0/32
!
interface GigabitEthernet0/33
!
interface GigabitEthernet0/34
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/35
!
interface GigabitEthernet0/36
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/37
!
interface GigabitEthernet0/38
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/39
!
interface GigabitEthernet0/40
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/41
!
interface GigabitEthernet0/42
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/43
!
interface GigabitEthernet0/44
!
interface GigabitEthernet0/45
!
interface GigabitEthernet0/46
!
interface GigabitEthernet0/47
!
interface GigabitEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 ip verify source
!
interface GigabitEthernet0/49
!
interface GigabitEthernet0/50
!
interface GigabitEthernet0/51
!
interface GigabitEthernet0/52
!
interface Vlan1
 ip address 10.0.20.20 255.255.0.0
!
interface Vlan2
 ip address 192.168.2.1 255.255.255.224
!
interface Vlan3
 ip address 192.168.4.1 255.255.255.240
!
interface Vlan4
 no ip address
!
interface Vlan5
 ip address 192.168.6.1 255.255.254.0
!
interface Vlan6
 ip address 192.168.8.1 255.255.255.240
!
ip default-gateway 10.0.0.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.0.1
ip route 192.168.0.0 255.255.254.0 192.168.0.1
ip route 192.168.2.0 255.255.255.224 Vlan2
ip route 192.168.4.0 255.255.255.240 Vlan3
ip http server
!
snmp-server community public RO
!
control-plane
!
!
0
 
LVL 23

Author Comment

by:Suliman Abu Kharroub
ID: 26094733
OPS...

Sorry guys.. I have found my problem. the DG was entered in the file server is incorrect. does not point to the switch interface.
0
 
LVL 23

Author Closing Comment

by:Suliman Abu Kharroub
ID: 31668271
Thanks a lot.
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
How to fix a SonicWall Gateway Anti-Virus firewall blocking automatic updates to apps like Windows, Adobe, Symantec, etc.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question