AjaxPro can't find *.ashx files

Posted on 2009-12-20
Last Modified: 2012-05-08

I'm developing a website using ASP.NET and AjaxPro.
My project works fine as log as the site is within my wwwroot (IIS7).
But when I open it at an other server (IIS6) or using Visual Studio from an other folder than my wwwroot AjaxPro doesn't work anymore.
This is the output by Fiddler:

#      Result      Protocol      Host      URL      Body      Caching      Content-Type      Process      Comments      Custom      
551      404      HTTP      localhost:62243      /webWeb/ajaxpro/core.ashx      3.049      private        text/html; charset=utf-8      firefox:10304                  
552      404      HTTP      localhost:62243      /web/ajaxpro/converter.ashx      3.059      private        text/html; charset=utf-8      firefox:10304                  
553      404      HTTP      localhost:62243      /web/ajaxpro/_Default,App_Web_vmoj5imf.ashx      3.091      private        text/html; charset=utf-8      firefox:10304                  
554      404      HTTP      localhost:62243      /web/ajaxpro/prototype.ashx      3.059      private        text/html; charset=utf-8      firefox:10304                  
555      404      HTTP      localhost:62243      /web/ajaxpro/core.ashx      3.049      private        text/html; charset=utf-8      firefox:10304                  
556      404      HTTP      localhost:62243      /web/ajaxpro/converter.ashx      3.059      private        text/html; charset=utf-8      firefox:10304                  
557      404      HTTP      localhost:62243      /web/ajaxpro/_Default,App_Web_vmoj5imf.ashx      3.091      private        text/html; charset=utf-8      firefox:10304                  

The web.config is like it is suggest and as I say with this it works in my local IIS7:
      <location path="ajaxpro">
                        <add verb="*" path="ajaxpro/*.ashx" name="AjaxPro" type="AjaxPro.AjaxHandlerFactory,AjaxPro.2"/>

Any idea why this happens?


Question by:andre72
    LVL 10

    Accepted Solution

    you should disable "Check File Exists" for ashx file type in your IIS settings. check this

    Author Comment

    Thanks but this is already disabled
    LVL 17

    Assisted Solution

    What subcode do you get for the 404. Fiddler doesn't seem to display this.

    Look in your IIS logs and post back the information from the failing server.

    Author Closing Comment

    I'd just use the wrong settings. Thanks for your support

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Do You Know the 4 Main Threat Actor Types?

    Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

    Prologue It is often required to host multiple websites on a single instance of IIS, mostly in development environments instead of on production servers. I am sure it is not much a preferred solution on production servers but this is at least a pos…
    The Confluence of Individual Knowledge and the Collective Intelligence At this writing (summer 2013) the term API ( has made its way into the popular lexicon of the English language.  A few years ago, …
    Hi everyone! This is Experts Exchange customer support.  This quick video will show you how to change your primary email address.  If you have any questions, then please Write a Comment below!
    This video discusses moving either the default database or any database to a new volume.

    760 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    7 Experts available now in Live!

    Get 1:1 Help Now