[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 957
  • Last Modified:

Grid will not display

Hi,

I am a novice when it comes to Oracle. I am filling in as a temp so please bear with me.
We are running Oralce 10g and I have been managing everythign via the Grid. Now for some reason I keep getting page cannot display when I try to get to the grid.

Thanks,
0
Sainai
Asked:
Sainai
  • 6
  • 5
1 Solution
 
logictankCommented:
Verify services are running on the Grid OMS Server, use the following as the oracle software owner to obtain process status on the OMS node:
opmnctl status

Example Output:

Processes in Instance: EnterpriseManager0.hostname.domain.com
-------------------+--------------------+---------+---------
ias-component      | process-type       |     pid | status  
-------------------+--------------------+---------+---------
DSA                | DSA                |     N/A | Down    
HTTP_Server        | HTTP_Server        |   21039 | Alive  
LogLoader          | logloaderd         |     N/A | Down    
dcm-daemon         | dcm-daemon         |   21667 | Alive  
OC4J               | home               |   21040 | Alive  
OC4J               | OC4J_EMPROV        |   21041 | Alive  
OC4J               | OC4J_EM            |   31070 | Alive  
WebCache           | WebCache           |   21080 | Alive  
WebCache           | WebCacheAdmin      |   21044 | Alive  

You should see "Alive" in the status column for the items above.  If your on a linux/unix platform you can start and stop the Grid/OMS services as root using:
/etc/init.d/gcstartup stop
/etc/init.d/gcstartup start
Also verify that the Grid database associated with the OMS server is up and running, this could be on the same server along with the OMS or on a separate host.
0
 
SainaiAuthor Commented:
Thank you, I will give this a try. I will get back with you.
0
 
SainaiAuthor Commented:
I ran opmnctl status and it keeps giving me an unrecognized command. I ran this as oracle and root and nothing.
I also ran the /etc/init.d/gcstartup start     and it says that the agent is still running.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
SainaiAuthor Commented:
I looked at my logs and this is what I got. I think this is the problem but where and how do I make space?

ORA-19815: Warning: db_recovery_file_dest_sizeof XXXX
bytes is 100% used and has 0 remaining bytes available.

thanks
0
 
logictankCommented:
Verify that your oracle user environment is setup correctly to see the opmnctl command ($ORACLE_HOME & $PATH), this file will be under $ORACLE_HOME/opmn/bin.  The $ORACLE_HOME variable should point to the Grid Server OMS home, you can also run 'opmctl status' directly from the OMS $ORACLE_HOME/opmn/bin directory:
cd $ORACLE_HOME/opmn/bin
./opmnctl status
If any of the services are down such as HTTP_Server or the OC4J containers you can try stopping and starting the OMS services:
As root:
/etc/init.d/gcstartup stop (Wait for all OMS processes to die or kill manually)
/etc/init.d/gcstartup start (Verify services are up with opmctl status)
If you're still experiencing problems check logs in the OMS Home:
$ORACLE_HOME/sysman/log
$ORACLE_HOME/Apache/Apache/logs
Note: If there are other Oracle services running on this node other than Grid OMS be aware not to kill non Grid OMS processes.
0
 
logictankCommented:
alter system set db_recovery_file_dest_size=100G scope=both; (If using spfile)
Otherwise:
alter system set db_recovery_file_dest_size=100G; (Update pfile manually to maintain setting for next DB restart).
Note:  The size of 100G is just an example, set it to your desired value depending on your available storage space.
0
 
logictankCommented:
Additional:
If you don't have available storage space to grow the db_recovery_file_dest_size value you'll need to either allocate additional storage space or start removing archivelogs and backupsets as necessary.  You can also run the "crosscheck" command from RMAN:
crosscheck backupset;
crosscheck copy;
crosscheck archivelog all;
as well as the delete command:
delete noprompt obsolete;
delete noprompt expired backup;
delete noprompt expired copy;
and set a retention policy in RMAN using the "configure retention policy" command.
0
 
SainaiAuthor Commented:
Thanks a bunch. I will try your suggestions and get back with you in a few.
0
 
SainaiAuthor Commented:
Ok I realize that I am unable to use the alter command because I cannot get in as Ops Oracle, System or anything. I am also getting this error when I run the crosscheck:
Not connected to the target database. It seems the db is down. I tried using the crs_start command as well as the srvctl command to start it and it won't come up. I think the error ORA-19815: Warning: db_recovery_file_dest_sizeof XXXX
bytes is 100% used and has 0 remaining bytes available." is preventing me from doing so.

any suggestions so I can get the db up so I can later the spfile?
thanks a bunch
0
 
logictankCommented:
Do you have access to the oracle software owner account for the Grid Database?  If so you can use the following to connect as sys to run the alter system command and connect to rman to run crosscheck and delete commands.

While logged in as the oracle software owner account for the Grid/OMS Database:

connect as sys:
$ sqlplus / as sysdba
SQL> alter system set db_recovery_file_dest_size=100G scope=both;

Connect to target database with RMAN catalog:
$ rman TARGET / CATALOG rman@RCAT

Connect to target database without RMAN catalog:
$ rman TARGET /

Then you can run your crosscheck and delete commands:

RMAN>
crosscheck backupset;
crosscheck copy;
crosscheck archivelog all;
delete noprompt obsolete;
delete noprompt expired backup;
delete noprompt expired copy;

If you don't have access to the oracle sofware owner account or sys privileges you'll need to obtain the access before you can make these changes.
0
 
SainaiAuthor Commented:
Tanks LogicTank I'll give it another go. I'll get back with you.

thanks
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 6
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now