problems with exchange server 2009

Having a problem with out of office assistant.  When Outlook is connected to the exchange server and you try to click on out of office assistant, it pauses and comes up with an error message saying your out of office settings cannot be displayed because the server is currently unavailable, please try later.  The only way you can get into the out of office assistant is to enter via the web version.  Looking to get this resolved so that people can access it through Outlook.
Cheers
Warren
OzwazzaAsked:
Who is Participating?
 
dlepakCommented:
Check out these urls they helped me. http://support.microsoft.com/kb/940881, http://www.msexchange.org/articles_tutorials/exchange-server-2007/management-administration/configuring-exchange-server-2007-web-services-urls.html 

If you have the above setup correctly and are still having problems see if the following will help.

If your Client Access Server (CAS) is Windows 2008 go into IIS on the CAS and check the following. Under the 'default web site' you will see the Autodiscover, EWS and OAB folders. Make sure the SSL Settings are as follows. Client certificates should be set to Ignore (mine was set to accept). Check the Authentication settings  also. Right click on Windows Authentication and go to advanced settings. Make sure that 'Enable Kernel-mode authentication' is uncheck. Do this for all three directories. If you have more than one CAS then make these changes on both servers. This resolved the Out of Office problem for me.  
0
 
Alan HardistyCo-OwnerCommented:
I hope you are referring to Exchange Server 2010 - unless you have an interim release that no-one else has ;-)
What version of Outlook are you using?
Have you tried Help> Detect & Repair or Help> Office Diagnostics
0
 
Burns2007Commented:
Are you using Outlook 2007? Out of office is handled through autodiscover whihc you likely haven't configured proerply.

http://technet.microsoft.com/en-us/library/bb124251.aspx
That's an opening article to understanding the autodiscover service,and has a link to deployment details.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
OzwazzaAuthor Commented:
Yeah, sorry guys, Exchange Server 2007
0
 
Alan HardistyCo-OwnerCommented:
Thanks - What about the version of Outlook?
Have you tried Help> Detect & Repair or Help> Office Diagnostics?
0
 
OzwazzaAuthor Commented:
I've been reading that Exchange uses Autodiscover for the services, but I am lost as to how to configure it to make sure that it works correctly.

Cheers
Warren
0
 
OzwazzaAuthor Commented:
Using Outlook 2007 on the client machines
0
 
Alan HardistyCo-OwnerCommented:
Yes - but can you answer the questions put to you first please so we can rule out the obvious and then we can move on to other possibilities.
Thanks
Alan
0
 
OzwazzaAuthor Commented:
Ran the Office Diagnostics and no change same message still comes up
0
 
Alan HardistyCo-OwnerCommented:
What is the latest Rollup that you have installed on the Exchange Server?  The latest available is Exchange 2007 Rollup 9 for SP1.
http://www.microsoft.com/downloads/details.aspx?FamilyID=55320be2-c65c-48bb-bab8-6335aa7d008c&displaylang=en 
0
 
OzwazzaAuthor Commented:
ran the latest rollup, same response.

Warren
0
 
Alan HardistyCo-OwnerCommented:
Did you install as per my suggestion or was it already there?
If you have just installed, have you rebooted the server?
Have you setup an Autodiscover A record in your domains DNS pointing to your Internet fixed IP Address?
0
 
MesthaCommented:
Out of Office is connected to availability service, which is connected to autodiscover.
Primary reasons for autodiscover not working correctly is incorrect URLs configured for the various services or the lack of SSL certificates, or installed incorrectly.

Do you have a commercial SAN/UC SSL certificate on this server? If not then I suggest that you correct that first.

http://blog.sembee.co.uk/archive/2008/05/30/78.aspx

Simon.
0
 
OzwazzaAuthor Commented:
Went through the blog and created a SSL certificate, still not connecting, when I right click and test autoconfiguration I get the following error:

Autodiscover to https://whyallamain.centacarecdpp.local/Autodiscover/Autodiscover.xml FAILED ()x80072F0c)

Does this shed any light on what I am doing wrong?

Cheers
Warren
0
 
MesthaCommented:
So you have a commercial certificate in place?
Did you follow all instructions on setting it up. If it was a GoDaddy certificate that includes the installation of intermediate certificate and if this is Windows 2008, disabling some as well.

Simon.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.