[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 733
  • Last Modified:

Outlook asking for password after moving mailbox to Exchange 2007

Hi Guys,

Just installed a new Exchange2007 on Server2008 into an SBS2003 enviroment and last night moved the mailboxes from the old SBS2003 to the new Exchange2007 box. Now a user tries to open up Outlook (through VPN) it just keeps asking for username and password and even when it's entered it won't connect.
Any ideas ?

Thanks
0
Netexperts
Asked:
Netexperts
  • 5
  • 2
  • 2
  • +3
1 Solution
 
SmukecCommented:
When the user is asked for credentials let him enter the username in the form "domain\username".
0
 
p_nutsCommented:
did you try and reset the password?
is it only happening over vpn? try to start up outlook.exe /rpcdiag to see if the client can connect right.
is anything filtered on the vpn connection?
0
 
Glen KnightCommented:
You need to configure an autodiscover A record in your external DNS.

Contact whoever controls your external DNS and ask them to configure an A record for autodiscover.yourdomain.com to point to the external IP address of your exchange server.

Have you moved therouting of port 443/25 to the new server on your router/firewall?
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
shauncroucherCommented:
Make sure you have ALL the latest service packs and patched up to date. There was an issue like this sorted by an update.

Shaun
0
 
SmukecCommented:
dematzer - I think they don't have to do anything with external access, as they run VPN.
0
 
Glen KnightCommented:
You would be suprised!
Normally on a VPN the Internet access is used via the local machine.

outlook WILL look for autodiscover.domainname.com (over the local Internet connection) in SBS you have a split DNS so this record may alread be in the INTERNAL DNS but not in the EXTERNAL
0
 
Glen KnightCommented:
Have you configured outlook to use RPC-HTTPS?
Or are you just connecting like any other resource?

0
 
NetexpertsAuthor Commented:
I've just tried it from another external location with a test account and wouldn't connect at all but after adding the new mail server to the local host file it seemed to work fine so looks like a DNS issue. We have an external domain that users connect to which has a seperate DNS zone in DNS on the main server, should i add the new mail server's A record to this and point to the internal IP of it ?
i.e VPN users connect to vpn.domain.co.uk and in here put newmailserver.domain.co.uk pointing to the internal IP of it ?

Thanks
0
 
Glen KnightCommented:
Yes whatever DNS your using for those clients needs to have the correct records.

There is no harm in adding them if it doesn't work you can always remove it again :-)
0
 
Glen KnightCommented:
You will also need the autodiscover record.

Exchange 2007 relies on it.
0
 
NetexpertsAuthor Commented:
I have not got any further but at least the settings you've advised will discount any problems relating to them.

Thanks
0

Featured Post

Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

  • 5
  • 2
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now