?
Solved

IP Phone registration through ASA Site-to-Site VPN - Routing issue

Posted on 2009-12-21
5
Medium Priority
?
902 Views
Last Modified: 2012-05-08
Ip phone on remote site can not register on CUCS. VPN is up, pings are ok, I can ping from remote voice subnet to the local CUCS subnet. However, when IP phone tries to register with CUCS, I get the following:

%ASA-6-302015: Built outbound UDP connection 68507 for vpn-baku:192.168.128.10/69 (192.168.128.10/69) to astara_data:192.168.140.5/49152 (192.168.140.5/49152)
%ASA-6-302015: Built outbound UDP connection 68508 for vpn-baku:192.168.128.10/34488 (192.168.128.10/34488) to astara_data:192.168.140.5/49152 (192.168.140.5/49152)
%ASA-6-110003: Routing failed to locate next hop for UDP from vpn-baku:192.168.128.10/34488 to astara_data:192.168.140.5/49152

Local ASA:

ASA Version 7.0(8)
!
hostname azt-bridge-asa
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
dns-guard
!
interface GigabitEthernet0/0
 nameif azt-inside
 security-level 100
 no ip address
!
interface GigabitEthernet0/0.32
 vlan 32
 nameif azt_data
 security-level 100
 ip address 192.168.32.9 255.255.255.0
!
interface GigabitEthernet0/0.129
 vlan 129
 nameif azt_voice
 security-level 100
 ip address 192.168.128.9 255.255.255.0
!
interface GigabitEthernet0/1
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/3
 nameif baku-outside
 security-level 0
 ip address 10.253.17.1 255.255.255.0
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0
 management-only
!            
ftp mode passive
same-security-traffic permit inter-interface
access-list 110 extended permit ip 192.168.32.0 255.255.255.0 any log
access-list 110 extended permit ip 192.168.128.0 255.255.255.0 any log
access-list 110 extended permit ip 10.253.17.0 255.255.255.0 any log
access-list 110 extended permit ip any any log
access-list nonat extended permit ip 192.168.128.0 255.255.255.0 192.168.140.0 255.255.255.0
access-list nonat extended permit ip 192.168.32.0 255.255.255.0 192.168.86.0 255.255.255.0
pager lines 24
logging monitor debugging
logging asdm informational
mtu azt-inside 1500
mtu azt_data 1500
mtu azt_voice 1500
mtu baku-outside 1500
mtu management 1500
no failover
asdm image disk0:/asdm-508.bin
no asdm history enable
arp timeout 14400
nat (azt_data) 0 access-list nonat
route baku-outside 192.168.140.0 255.255.255.0 10.253.17.2 1
route baku-outside 0.0.0.0 0.0.0.0 10.253.17.2 1
route baku-outside 192.168.86.0 255.255.255.0 10.253.17.2 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00
timeout mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
username admin password fOxbBT5HEEz5OxJT encrypted
aaa authentication ssh console LOCAL
aaa authentication enable console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set myset esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map bakumap 10 set security-association lifetime seconds 28800
crypto map bakumap 10 set security-association lifetime kilobytes 4608000
crypto map mymap 20 match address 110
crypto map mymap 20 set peer 10.253.17.2
crypto map mymap 20 set transform-set myset
crypto map mymap 20 set security-association lifetime seconds 28800
crypto map mymap 20 set security-association lifetime kilobytes 4608000
crypto map mymap interface baku-outside
isakmp enable baku-outside
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
tunnel-group 10.253.17.2 type ipsec-l2l
tunnel-group 10.253.17.2 ipsec-attributes
 pre-shared-key *
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 azt_data
ssh timeout 30
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd lease 3600
dhcpd ping_timeout 50
dhcpd enable management
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map global_policy
 class inspection_default
  inspect dns maximum-length 512
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect skinny
  inspect tftp
!
service-policy global_policy global
Cryptochecksum:1e9b30c67a892c2a5111102814efa994
: end

Remote ASA:

ASA Version 7.0(8)
!
hostname azt-astara-asa
enable password zk4oxIHVgmgitTUn encrypted
passwd XeY1QWHKPK75Y48j encrypted
names
dns-guard
!
interface Ethernet0/0
 speed 100
 duplex full
 nameif astara_inside
 security-level 100
 no ip address
!
interface Ethernet0/0.86
 vlan 86
 nameif astara_data
 security-level 100
 ip address 192.168.86.1 255.255.255.0
!
interface Ethernet0/0.140
 vlan 140
 nameif astara_voice
 security-level 100
 ip address 192.168.140.1 255.255.255.0
!
interface Ethernet0/1
 shutdown
 no nameif
 security-level 100
 no ip address
!
interface Ethernet0/2
 nameif vpn-baku
 security-level 0
 ip address 10.253.17.2 255.255.255.0
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0
 management-only
!
ftp mode passive
same-security-traffic permit inter-interface
access-list nonat extended permit ip 192.168.86.0 255.255.255.0 192.168.32.0 255.255.255.0
access-list nonat extended permit ip 192.168.140.0 255.255.255.0 192.168.128.0 255.255.255.0
access-list 120 extended permit ip 192.168.86.0 255.255.255.0 any log
access-list 120 extended permit ip 192.168.140.0 255.255.255.0 any log
access-list 120 extended permit ip 10.253.17.0 255.255.255.0 any log
access-list 120 extended permit ip any any log
pager lines 24
logging monitor debugging
logging asdm informational
mtu astara_inside 1434
mtu astara_data 1434
mtu astara_voice 1434
mtu vpn-baku 1434
mtu management 1434
asdm image disk0:/asdm-508.bin
no asdm history enable
arp timeout 14400
nat (astara_data) 0 access-list nonat
route vpn-baku 0.0.0.0 0.0.0.0 10.253.17.1 1
route vpn-baku 192.168.32.0 255.255.255.0 10.253.17.1 1
route vpn-baku 192.168.128.0 255.255.255.0 10.253.17.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00
timeout mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
username admin password fOxbBT5HEEz5OxJT encrypted
aaa authentication ssh console LOCAL
aaa authentication enable console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set myset esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map mymap 10 set security-association lifetime seconds 28800
crypto map mymap 10 set security-association lifetime kilobytes 4608000
crypto map mymap 20 match address 120
crypto map mymap 20 set peer 10.253.17.1
crypto map mymap 20 set transform-set myset
crypto map mymap 20 set security-association lifetime seconds 28800
crypto map mymap 20 set security-association lifetime kilobytes 4608000
crypto map mymap interface vpn-baku
crypto map bakumap 10 set security-association lifetime seconds 28800
crypto map bakumap 10 set security-association lifetime kilobytes 4608000
crypto map bakumap 20 set security-association lifetime seconds 28800
crypto map bakumap 20 set security-association lifetime kilobytes 4608000
isakmp enable vpn-baku
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
tunnel-group 10.253.17.1 type ipsec-l2l
tunnel-group 10.253.17.1 ipsec-attributes
 pre-shared-key *
telnet 0.0.0.0 0.0.0.0 astara_inside
telnet 0.0.0.0 0.0.0.0 vpn-baku
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 astara_inside
ssh 0.0.0.0 0.0.0.0 astara_data
ssh 0.0.0.0 0.0.0.0 vpn-baku
ssh timeout 30
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd lease 3600
dhcpd ping_timeout 50
dhcpd enable management
!
class-map inspection_default
 match default-inspection-traffic
!            
!
policy-map global_policy
 class inspection_default
  inspect dns maximum-length 512
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect skinny
  inspect tftp
!
service-policy global_policy global
Cryptochecksum:098102765abe4083a2747930e3d4a1bb
: end
azt-astara-asa#



Basically, I can ping from 192.168.140.0 (remote voice) to 192.168.128.10 (local CUCS) and vice versa.

Thank you in advance
0
Comment
Question by:fgasimzade
  • 4
5 Comments
 
LVL 33

Expert Comment

by:MikeKane
ID: 26097101
Some items that caught my eye...  

On the 1st ASA,
route baku-outside 192.168.140.0 255.255.255.0 10.253.17.2 1
route baku-outside 192.168.86.0 255.255.255.0 10.253.17.2 1

And on the 2nd ASA,
route vpn-baku 192.168.32.0 255.255.255.0 10.253.17.1 1
route vpn-baku 192.168.128.0 255.255.255.0 10.253.17.1 1

I don't think these are needed since the catchall of 0.0.0.0 would route these correctly anyway.    Comment them out for testing.
0
 
LVL 18

Author Comment

by:fgasimzade
ID: 26098438
When I did it I see the same :
%ASA-6-110003: Routing failed to locate next hop for UDP from vpn-baku:192.168.128.10/35287 to astara_data:192.168.140.5/49152
%ASA-6-302013: Built outbound TCP connection 72145 for vpn-baku:192.168.128.10/2428 (192.168.128.10/2428) to astara_data:192.168.86.114/58125 (192.168.86.114/58125)
%ASA-6-302014: Teardown TCP connection 72136 for vpn-baku:192.168.128.10/2428 to astara_data:192.168.86.114/42244 duration 0:00:30 bytes 0 SYN Timeout
%ASA-6-302016: Teardown UDP connection 72120 for vpn-baku:192.168.128.10/35272 to astara_voice:192.168.140.5/49152 duration 0:02:12 bytes 2064
%ASA-7-609002: Teardown local-host astara_voice:192.168.140.5 duration 0:02:12
%ASA-6-302015: Built outbound UDP connection 72146 for vpn-baku:192.168.128.10/35289 (192.168.128.10/35289) to astara_data:192.168.140.5/49152 (192.168.140.5/49152)
%ASA-6-302015: Built outbound UDP connection 72147 for vpn-baku:192.168.128.10/35291 (192.168.128.10/35291) to astara_data:192.168.140.5/49152 (192.168.140.5/49152)
%ASA-6-302016: Teardown UDP connection 72116 for vpn-baku:192.168.128.10/69 to astara_data:192.168.140.5/49153 duration 0:02:20 bytes 174
%ASA-6-110003: Routing failed to locate next hop for UDP from vpn-baku:192.168.128.10/35285 to astara_data:192.168.140.5/49152
0
 
LVL 18

Author Comment

by:fgasimzade
ID: 26098486
I already tried to remove skinny and tftp inspection but resullt doesnt change
0
 
LVL 18

Author Comment

by:fgasimzade
ID: 26102699
MakeKane, I reconfigured access lists, made them mirror each other, I changed routing table as you suggested, nothing helps. I still get Routing failed to locate next hop
0
 
LVL 18

Accepted Solution

by:
fgasimzade earned 0 total points
ID: 26102985
Issue is solved, I removed interface GigabitEthernet0/0.129 from ASA, left only interface GigabitEthernet0/0.32 and used it as a default gateway.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

You deserve ‘straight talk’ from your cloud provider about your risk, your costs, security, uptime and the processes that are in place to protect your mission-critical applications.
This article is in regards to the Cisco QSFP-4SFP10G-CU1M cables, which are designed to uplink/downlink 40GB ports to 10GB SFP ports. I recently experienced this and found very little configuration documentation on how these are supposed to be confi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question