• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 664
  • Last Modified:

Display PivotTable from SQL data in WSS 3

I've installed the Office Web Components (client and server) for WSS 2 on my WSS 3.0 SP1 server (following Microsoft instructions). The install went okay, and I believe the components are working.

I'm now trying to use the PivotTable Web Part to display data from an SQL database (server located on same machine, but I don't think that makes any difference).

I've tried a couple of methods: 1. creating a working .ODC file and storing it in a document library, then liking the Web Part to this. 2. Clicking the 'Connect to external data source' link and creating a new connection using OLEDB for SQL Server.

Both methods return the same error: 'There was an error while retrieving data from the data source."

I'm not even sure if what I want to do is possible in WSS 3  -- I'm really after confirmation whether this should work or whether to stop trying.
0
matbeard
Asked:
matbeard
  • 2
2 Solutions
 
zephyr_hex (Megan)DeveloperCommented:
i'm not aware of how to do this the way you're going about it... with wss 3.0.  i thought pivot table web part required Excel Services, which is in moss 2007, but not wss 3.0

the method i'm aware of for displaying external data in wss 3.0 is using Data View web part (DVWP)
0
 
matbeardAuthor Commented:
Well, strictly speaking, the Office Web Componments were for WSS 2, but Microsoft provides a method for extracting them and manually installing on WSS 3.

I've done this, and all the required Web Parts are displayed, they just don't seam to work -- I can't imagine MS would explain how to install them on WSS3 if they wouldn't work.

I can use the DVWP to display data from extrenal sources, but it really was the PivitTable functions I was after. Maybe I'll have to upgrade to MOSS for the Excel Services?
0
 
matbeardAuthor Commented:
Actually - I've got it working now. It was my own stupid fault. The .ODC file had carriage returns in the SQL query. These were being lost when used with the Web Part, making the query invalid.

Once I spotted that, removed them and added appropriate spaces, it started working!
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now