Tasklist error

Tasklist /s <remote_system> is giving me the error message "Error : RPC Server Unavailable".
I have checked Remote Procedure Call (RPC) service in the particular Remote systems, the status is Running.
TG_SekharAsked:
Who is Participating?
 
QlemoConnect With a Mentor Batchelor, Developer and EE Topic AdvisorCommented:
Sorry, interpreted that as Expert comment ...
Tasklist uses RPC (AFAIK), which opens epmap (135/tcp) port.
0
 
Glen KnightCommented:
Probably down to the Windows firewall or other security product on the device you are trying to attatch to.
0
 
TBK-ConsultingCommented:
If these are machines not in a domain then you may need to supply credentials to make it work ... as follows - TASKLIST /S system /U domain\username /P password
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
TG_SekharAuthor Commented:
Demazter,
I am unable to understand your comment. Can you explain me little more.
TBK-Consulting,
When I am using TASKLIST /S system /U domain\username /P password also I am facing the same problem.
0
 
TBK-ConsultingCommented:
it just sounds like a permission problem to me is all .. are you using the username/password from the remote machine?
0
 
Glen KnightCommented:
Disable the windows firewall on the server you are trying to connect to.
0
 
TG_SekharAuthor Commented:
TBK-Consulting:
I have administrator account in the particular remote system.
demazter:
Windows firewall is already disabled status.
0
 
TG_SekharAuthor Commented:
Is the tasklist command running through any port?
0
 
TG_SekharAuthor Commented:
Can anybody respond to my above query.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.