?
Solved

issue with doing more all for sent items blackberry after moving from standloen to cluster server

Posted on 2009-12-21
10
Medium Priority
?
330 Views
Last Modified: 2012-05-08
Greetins,

We had a standalone server running e2k7 sp1 and blackberry 4.1 sp6. We have setup a cluster with e2k7sp2 and as per RIM recommendation, upgraded bes to 4.1.7. the current scenario is that i moved few test users to new cluster server. teh serice accoutn is still on the old one. ran the handheld cleanup utility and restarted the blackberry server. i am able to send /receive emails, do meetings requets etc, the hiccup is when i try and retrieve any old message or a sent item , it just keeps telling me that the mailox cant find the original message.

the service account permissions have been verified. the sql database is local to the blackberry server and the account has systadmin,serveradmin and dbowner permissions.

i am not having any issues with activation or none so ever except for the weird th ign happenign. have a migration coming up and blackberry nto workign, all trouble breaks loose.

help is highly appreciated. if i add a user directly to the new server and then do the activation, it is working and i am not having issues. this happens only when a user is already activated and moved from the old to the new one.

Sorry if this is too lengthy. kindly advise
0
Comment
Question by:junaidIT
  • 8
  • 2
10 Comments
 
LVL 12

Expert Comment

by:Shekhar2cool
ID: 26099197
Have you tried recreating the MAPI Profile and then restarting BES.
0
 
LVL 11

Author Comment

by:junaidIT
ID: 26099423
I haven't moved the bes service account till now.shud I be doing tht.thought will test first to see if everything is working before moving everything else.the mapi profile, no I vaent recreated it.
0
 
LVL 12

Assisted Solution

by:Shekhar2cool
Shekhar2cool earned 400 total points
ID: 26099554
Recreating MAPI Profile is just a troubleshooting step. It wont harm any of the functionality/. Login using the service account and then do it.

http://www.port3101.org/featured-blackberry-kb-articles/362-kb10285-how-re-create-blackberry-enterprise-server-mapi-profile.html
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
LVL 11

Author Comment

by:junaidIT
ID: 26102490
Wht wud be the right way to install the exchangecdo tool from microsoft.when I search the server, I find one under system32,one under syswow64 folder under windows.not sure if this has got to do with any of these.and also want to know if having the service account on different server is an issue. All these boxes r in the same organization

Thanks
0
 
LVL 11

Author Comment

by:junaidIT
ID: 26103344
recreated the mapi profile for the bes service account.ran the handheld cleanup utility and restarted teh bes services. still the same issue.


when the mailbox is on teh new server, the handheld does not retrieve any of teh old send/received items, when i do more all after opening the message. if i move back the mailbox fromt he new server to the old machine, everything seems to be working . the only error that shows up in the event viewer is msexchange cdo and it comes up every time people send a meeting request. the version of cdo.dll is 6.5.8131 on the blackberry and 6.5.8147 on the cluster mailbox servers.

please advise.
0
 
LVL 11

Author Comment

by:junaidIT
ID: 26105401
This has been escalated to RIM directly. Will keep you posted on the solution
0
 
LVL 11

Author Comment

by:junaidIT
ID: 26111539
Troubleshooting steps performed so far :

Recreated the mapi profile
removed and gave teh permissions again for the bes service account
oab and public folder recreated
ran handheld cleanup.exe and it updates the user account.
tried even setting up a different user with the same results. the same user if you move back to the old server,things are back to normal .

no other erros in the event log on the server. any thing else that we  could do. havent heard frm RIM till now. still waitng
0
 
LVL 11

Author Comment

by:junaidIT
ID: 26118660
Ok ,

this is gettign really crazy. any new mailbox that i create on the old server, send emails to that mailbox, activate on bes, move it to new server, run handheld cleanp and restart bes server, things are normal and working fine.

but i move any old existing user to the new exchange and try to use blackberry, i am not able to find any of the old messages.

any idea guys
0
 
LVL 11

Author Comment

by:junaidIT
ID: 26129972
havent got a response yet from RIM about the case. The only work around they suggested was to reactivate the user on the device.  i reinitialized the device by going to enterprise activation,pressing alt and then typing cnfg and disable wireless sync, wait for one minute and enabled wireless sync again. this infact took the device through the full reinitialization and got a msg activation complete. but still no luck and i cannot do a retrieve all for old messages.

my issue is this happens only with the legacy users on the existing exchange box. all new mailboxes created and if i move those to the new server and restart the services, it works fine.

has anyoen come  across issues with upgradign exchange 2007 to sp2. my bes was also upgraded to service pack 7 as per suggestion from the local service provider for blackberry
0
 
LVL 11

Accepted Solution

by:
junaidIT earned 0 total points
ID: 26152396
Issue finally fixed.

Steps that were carried out were :

Stopped all blackberry services.
Uninstalled exchangecdo utility
renamed all instances of mapi32.dll and cdo.dll
downloaded and installed the latest version of exchangecdo
deleted and recreated the mapi profile
ran handheldcleanup to ensure the devices are updated
also removed and redid the permissions for the blackberry service account.

The os was a 64 bit operating system and not sure if this caused it to create all the mess.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will help those of you having problems with the Nextel Blackberry 8350i.  Recent Software updates cause the problems issues described below, and this article will help you revert back to the older software. As we know, Nextel has alw…
When a user’s mailbox is first created and his Blackberry account enabled how do we provision the device and what happens in the background? Stage 1 – Activation The user of the BlackBerry device types the email address and activation password i…
This lesson discusses how to use a Mainform + Subforms in Microsoft Access to find and enter data for payments on orders. The sample data comes from a custom shop that builds and sells movable storage structures that are delivered to your property. …
Whether it be Exchange Server Crash Issues, Dirty Shutdown Errors or Failed to mount error, Stellar Phoenix Mailbox Exchange Recovery has always got your back. With the help of its easy to understand user interface and 3 simple steps recovery proced…

807 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question