oab error for exchange 2007

Greetings,

we are getting error 0x80190194 and 0x8004010f error for outlook 2007 clients. this happend after changing teh generating server for the offlien adderess book to a new one.

so far have tried dleting and recreating the item, making only web distribution enabled. changed teh urls under server configuration for oab to point to the new ones. all the storage groups point to the new offline addres book.

have restarted the msexchagnefds service on the hub cas servers
tehre is no event error or warning on the mailbox server and i see teh instance of oab from mbox server showing up on the hub cas also.

please advise
LVL 11
junaidITAsked:
Who is Participating?
 
Narayan_singhConnect With a Mentor Commented:
TestEmailautoconfiguration make sure you have the cirrect URLs and to set the Urls use the cmds in this articles : http://support.microsoft.com/kb/940726

Check the OAB URL where it is pointing, it should point to your new OAB server.

Follow below steps to check the OAB generation :

Make sure Your exchange 2007 Mailbox server is OAB generating Server.
Go to
C:\program file >microsoft >exchange >ExchangeOAB (shared folder) >guid value
and make sure you have 1 XML and daily LZX files.

On CAS server restart microsoft exchange File distribution service

Go to IIS > default website > and under OAB see if you have the folder with the same guid value.

C:\program file >microsoft >exchange >Clien access >OAB
Check if there is the folder with the same guid.

and Authenticated users should have atleast read permission on OAB folder.(C:\program file >microsoft >exchange >Clien access >OAB)

Check the authentication type as below :

1)Autodiscover: Basic and Integrated authentication   SSL Optional
2) EWS : Integrated authentication                            NO SSL
3) Exadmin : Basic and Integrated authentication       NO SSL
4) Exchange : Basic and Integrated authentication      SSL Optional
5) Exchweb : Basic and Integrated authentication       NO SSL
6) Microsoft-Server-ActiveSync: Basic authentication   SSL Optional
7) OAB : Integrated authentication                             NO SSL
8) OWA : Basic authentication                                 SSL Optional
9) Public : Basic and Integrated authentication          SSL Optional

0
 
Glen KnightCommented:
Do you have an autodiscover record configured in your DNS server that deals with the zone that comes after your email @ sign?

Either your external DNS or your internal DNS if you have a split DNS setup.
0
 
junaidITAuthor Commented:
we do have that configured. i am using an internal ssl cert though.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
Glen KnightCommented:
Did you create a new Cert on the new server?
If so have you installed this on the client?

Assuming your not using a single CAS server and multiple mailbox servers?
0
 
junaidITAuthor Commented:
It is a cluster server with two hub cas.the clients don't give any error when I go to owa or on the pc even.the certs r added on the client also
0
 
junaidITAuthor Commented:
Hi ,

I have for the url that you had asked for and also teh replicaton of the file on the cas servers from the mailbox server and all are happening. if i run the test-outlookwebservices thing, everything passes other than the rpc/http. i am attaching the screenshot that i got for test autoemail configuration thing and teher are no errors in it as well.

The funny thing is all the error messages that i was getting yesterday when trying to download oab are gone now and the send/receive screen stays as it is . no progress bar, nor any errors
autodiscovertest.JPG
0
 
junaidITAuthor Commented:
Greetings. thank you very much for the help. figured it out. the issue wwas the the URL for oab. just changed that and it worked like a charm.
0
 
Narayan_singhCommented:
Thats greate ...Yes URL wasnt set right .....Sorry for late responce didnt login to experts for last two days.. was kind of busy.
Yes the Url for OAB doesnt seem to be correct ... i dont think it was pointing to right place....it should be pointing to same server as EWS.

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.