OWA FBA Ask me Basic User Prompt and Password

Hi,

I've followed this to Enable the OWA FBA on Exchange 2003:
http://ww.petri.co.il/configuring_forms_based_authentication_in_exchange_2003.htm

But When I request the HTTP page of the OWA the IIS ask me a basic prompt with username and password. I've already reset the IIS metabase to the default permission but the problem still remain!

What can I do?

Kind Regards

Fabio Tonon
Sies srl
SIES di Andrea BarbonAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
Narayan_singhConnect With a Mentor Commented:
I dont think without typing https :// you will get the FBA page.

Try to browse OWALOGON.ASP from IIS (right click and browse)... if you get FBA page then there is no issue with IIS.

Just install one self signed certificate for test purpose and see if you get the FBA by typing https://url
0
 
Glen KnightCommented:
Sounds like you haven't enabled Forms based Authentication in Exchange System Manager?

If you browse to https://servername/exchange what do you get?
0
 
SIES di Andrea BarbonAuthor Commented:
Hi,

i get a Basic Authentication Form.
The form require me to insert username and password!

0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
Glen KnightCommented:
Can you please capture the "basic" form you are talking about?

Have you enabled Form Based Authentication in Exchange System Manager?

Under Administrative Groups > First Administrative Group > Servers > servername > protocols > HTTP right click Exchange virtual and select properties ensure the form based authentication is checked.

0
 
Narayan_singhCommented:
Even with Forms Based authentication enabled you will have to type the credentials .
What kind of Box are you getting Normal windows Pop-Up prompting credentials or the Forms page in ex 2003 blue in coulour ?
If you getting forms page then that wat you should be getting and if you getting normal pop then, somthings not working
let us know
0
 
SIES di Andrea BarbonAuthor Commented:
Hi Dematzer,

Yes I've enabled the FBA with none compressione on ESM.
I don't have an SSL certificate, so I've inserted in the registry the key AllowRetailHTTPAuth.
I attach the windows prompt that I obtain when I try to logon to the OWA FBA.

The strange thing is that if I insert the credentials I logon perfectly to my mailbox! in FBA mode!!!
Only the First FBA page it's not displayed!!!


Error.jpg
0
 
SIES di Andrea BarbonAuthor Commented:
Hi,

Yes, I've read your post! I've checked various time the flags and the key.
As you can see I obtain an User Credential Box instead of the OWALOGON.ASP page!!
It's an IIS permission problem?
0
 
Glen KnightCommented:
Wouldn't have thought so.
You could try resetting the Exchange Virtual directories I normally use method 2 but method 3 might be better in this instance: http://support.microsoft.com/kb/883380
0
 
SIES di Andrea BarbonAuthor Commented:
Hi Dematzer,

I've already followed the KB (the first method)!! But nothing has changed
I'll try to follow the third method!!!
0
 
Glen KnightCommented:
I would also go back through and just check the FBA has been enabled.
Disable it then re-enable if you have to
0
 
SIES di Andrea BarbonAuthor Commented:
Hi  Dematzer,

I've already done this but nothing changed!
0
 
Glen KnightCommented:
And your definately going to /exchange ?

Is it a single server configuration?
You don't have any redirects configured?
0
 
SIES di Andrea BarbonAuthor Commented:
Hi Dematzer,

in the root of the default web site i've insert the redirect to /exchange folder in the same server.
It's a single server configuration !!!

The only thing i can do in my opinion is reinstall the sp2 for exhchange ...
The server is W2K3R2 Standard with SP2, the Exchange is SP2 ...

0
 
Glen KnightCommented:
You can try reinstalling SP2 (that's normally one of my suggestions)
0
 
SIES di Andrea BarbonAuthor Commented:
HI dematzer,

the SP2 for the exchange or for the W2K3?
I've double checked the Windows Event Log - the IIS log but haven't found something.

0
 
Glen KnightCommented:
Exchange.
0
 
Glen KnightCommented:
FBA does work without HTTPS if you set the registry key!
0
 
SIES di Andrea BarbonAuthor Commented:
Hi,

yes i've set the registry key. I've already configured the FBA without SSL on another Server with that registry key...

I don't understand why this installation doesn't work well.
I've already follow all the possible way to solve the problem (I think).....

Tomorrow I'll start configure all in SSL mode....

Kind Regards

Fabio Tonon
Sies srl
0
 
SIES di Andrea BarbonAuthor Commented:
Hi,

I've reinstalled the Exchange SP2 ... but nothing ...
Have you another solution?

Kind Regards
Fabio Tonon
Sies srl
0
 
Narayan_singhCommented:
install one self signed certificate for test purpose and see if you get the FBA by typing https://url
0
 
Glen KnightCommented:
FBA will work without SSL!
I had it running for years in a test environment with the exact same
key!

Can you remove the redirect and go directly to http://webmail_addess/exchange

also can you screen print what authentication methods you have in use on the Exchange virtual directory?
0
 
SIES di Andrea BarbonAuthor Commented:
Hi  Dematzer,

I've remove the redirect and pointed directly to http://webmail_address/exchange but  nothing changed !!
I've also created a new Virtual Server in ESM but nothing changed!!

ASAP i will show you the auth methods of Exchange dir
0
 
SIES di Andrea BarbonAuthor Commented:
Ok,

i've deleted and reinitialized the IIS metabase !! Nothing Changed ...
0
 
Glen KnightCommented:
Can you screenshot the IIS virtual directories and the HTTP server in the Exchange System Manager
0
 
Glen KnightCommented:
Can you check there is content in the C:\Program Files\Exchsrvr\ExchWeb\bin\auth folder?
0
 
SIES di Andrea BarbonAuthor Commented:
Hi,

Using SelfSSL tool in IIS6.0 Resource Kit I've created a simple test certificate.
Now I can see the FBA fancy page ....

I've removed the Registry Key ...
In the pas I've already enabled OWA in http mode with the Registry Key
I don't understand why In this installation the tips doesn't do the work !!!
0
 
Glen KnightCommented:
And if you now remove the SSL and pit the reg keys back?
0
 
Glen KnightCommented:
Not that I am suggesting you should run without SSL in a production environment.

Even a self signed SSL cert is better than none.
0
 
SIES di Andrea BarbonAuthor Commented:
Hi experts,

sorry for the delay of my answer !!
Dematzer: I've removed SSL and put the reg key back in the registry but it still doesn't funtion.

So in the first time I've generated a Self Signed crt and after a few days I've buy a valid SSL certificate.
Now, the problem is solved !!

Kind Regards
 
Fabio Tonon
Sies srl
0
 
Narayan_singhCommented:
I had suggested you to Put the Self signed certificate which solved the probelm ... so why not award the points
0
All Courses

From novice to tech pro — start learning today.