Windows 7 file sharing problem

I'm trying to share out folders on a Windows 7 machine with two other XP machines.  IP networking works fine; the Windows 7 machine is able to access the Internet and ping other machines.  The workgroup name is correct.  From the Windows 7 machine I can see what is shared on the XP machines and access them.  But I cannot view everything that is shared on the Windows 7 machine from the XP boxes, only some items.  

I noticed that the shares on the Windows 7 machine that do work correctly are the ones that, when I right-clicked on them, had the menu option to specify with whom to allow sharing.  Other folders, when I right-click on them to specify sharing, only have one option showing: "Advanced file sharing".  These items are the ones that are not accessible from the XP boxes.  I can see them there from the XP boxes but I only get the '...is not accessible...' message back when I click on them.   In the Properties (I believe) the 'Share' button is greyed-out.

 --> So my main question is:   What makes the 'Share with' options available for some folders and only the 'Advanced' option available for other folders?

I have gone into the Advanced File Sharing Properties and selected the options: 'Turn on Network Discovery', 'Turn on file and print sharing', 'Turn on sharing so everyone with network...', and 'Turn off password protected sharing'.  I have also tried going into the sharing permissions for the problem folders and tried giving 'Everyone' Read and Write access, with no luck either.  I have duplicated login credentials on all the machines.  Some are Administrators and some are not; the problem exists for all users regardless.
CTechMNAsked:
Who is Participating?
 
CTechMNAuthor Commented:
Well, I found the solution.  This is from a MS forum:

<http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/033c418b-1096-4df7-bfad-fd3d431f3cd5>

...Because Password Protected Sharing turned off, the security permissions have to be changed on the folder(s) to allow Everyone access. Right-click the shared folder > Properties > Security Tab > Edit > Add and type Everyone (not the quotes) into the box and select OK. Tick the boxes next to the permissions you want to allow (e.g. Read or Write, etc.) then Apply > OK.  Some messages may appear: An error occurred while applying& This is not unusual and can be ignored by clicking Continue...

It is not clear to me why this is needed in some situations but not in others when sharing between Win7 and XP.  Most references do not mention having to do this, so I am assuming that it is not necessary in all instances.

Paul
0
 
Syed Mutahir AliTechnology ConsultantCommented:
http://www.howtogeek.com/howto/windows-7/share-files-and-printers-between-windows-7-and-xp/
Have a look at the above article which specifies the procedure to setup file sharing between 7 and xp.
HTH
0
 
CTechMNAuthor Commented:
Thanks mutahir, but I've already been through that one and have done those steps without success.  I'm still not able to see what is shared out on the Windows 7 machine from the XP boxes.  

If I have selected 'Turn ON password protected sharing' in Win7, I get a login dialog on the XP box when I try to access one of the shares.  If I 'Turn OFF password protected sharing' in Win7, then I just get the standard '...is not accessible...' message.

I should add that this is all after restarting both machines multiple times and also turning off/removing firewalls and security software on both machines.

The main folder that I need to share from the Win7 machine to the XP machines is a database program called Eclipse that stores it's data in C:\Program Files\Eclipse.  This folder needs to be shared in order for the XP users to access the database.  This folder is one that, when I right-click on it and select 'Sharing', I only have one option appear: 'Advanced file sharing'.  I do not get other options like 'Share with'.  And the 'Share' button in the advanced settings is greyed out.

I'm still approaching the problem from the standpoint of 'why do some folders have the 'Share with' option under Properties->Sharing and some folders do not?'
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.