• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 771
  • Last Modified:

The new task could not be created.

I am trying to automate a scheduled task in Windows 2003 from the Task Scheduler, only problem is when I try to set the task to be automatically executed on a daily basis, I get the following error:

The new task could not be created.
The specific error is:
0x80070005: Access is denied.
Try using the Task page Browse button to locate the application.

The funny thing is I was able to find the application, it's just an executable that I created in Visual Basic, but I get this error after I try to automate through Scheduled Tasks.  What gives?  How do I fix this?  Thanks!
0
VBBRett
Asked:
VBBRett
  • 2
  • 2
1 Solution
 
megs28Commented:
Assuming you've confirmed that you are a local administrator on that machine, try this suggestion:

add the "Access this computer from the network" permission to the user account that will run the scheduled task.

Click Start, Run and type Gpedit.msc to bring up the Group Policy editor. In the Local Computer Policy list, expand Computer Configuration, Windows Settings, Security Settings, Local Policies.

Click on "User Rights Assignment" and double click "Access this computer from the network" and then click Add User or Group. Add the the user name or the group name in the Enter the object names to select area.

Click Check Names to verify what you selected and click OK twice to exit.

This will allow you to program access in scheduled tasks.
0
 
VBBRettAuthor Commented:
I am still getting the error

0x80070005: Access is denied.
Try using the Task page Browse button to locate the application.
0
 
megs28Commented:
Does the account you are going to run the task as have access to the file?  Does the system account have access to your executable and its dependencies?
0
 
VBBRettAuthor Commented:
Yes, when running it manually from that particular user account, everything works fine.  I just don't understand why it would not run the automatic process through Windows Server 2003.
0
 
jefforammaCommented:
i have been battling this all day. this is what fixed it for me.

http://support.microsoft.com/kb/867466

add your user your running your task as to the cmd.exe in %systemroot%\system32

hope it works for you.
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now