exchange 2007 sending emails

Posted on 2009-12-21
Medium Priority
Last Modified: 2013-11-30
i am trying to setup a new exchange 2007 server. it is a stand alone server with out and edge trsnsport. We are using a Spam filter to send out going emails.

My issue;
After setting up the exchange, i am able to do everything but recivie any emails.  I am able to send to internal email, and external email fine, but when people reply test emails they are getting
"The e-mail system was unable to deliver the message, but did not report a specific reason.  Check the address and try again.  If it still fails, contact your system administrator.
            < maila.Sanmanuel.com #5.0.0 X-Spam-&-Virus-Firewall; host[] said:    530 5.7.1 Client was not authenticated (in reply to MAIL FROM command)>

So after looking around i read that i should try a command on the command line in shell. which is
set-receiveconnector -permissiongroups anonymouseuers

but i got this error message.
the operation could not be performed because object 'servername" could not be found on domain controller..

so im confuse if this is an email issue or a DNS issue. or if i am even doing the command right. for the servername i am putting in my exchange server name.

please help.
Question by:sirichaiphumirat
LVL 76

Accepted Solution

Alan Hardisty earned 1000 total points
ID: 26101203
The rejection message you are getting is not from your exchange server, so either your MX records are pointing to the wrong IP or there is sometign else in between your internet connection and your exchange server.
It is also unusual to have a spam filter sending outgoing mail - it is more usually setup before receiving mail.  Are you sure you have this setup correctly?
It may be that you have your mail arriving to your spam filter first and have not configured this properly.
LVL 76

Expert Comment

by:Alan Hardisty
ID: 26101218
If I try to telnet to or maila.sanmanuel.com I don't connect to anything at all.
Have you opened up TCP port 25 on your firewall and is it being forwarded to your Exchange server or your spam solution?
LVL 16

Assisted Solution

Narayan_singh earned 1000 total points
ID: 26101260
You can even set the annonymous authentication from Exchange management console.
Use NSlookup and check if your MX is set correctly and see if you can telnet port 25 of your telnet and the exchange server.
i think maila.sanmanuel.com is you MX record.
Check if you can telnet port 25 of your exchange server try from server it self.
What about the internal mailflow is it working, if not it is the issue with receive connector.
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

LVL 32

Expert Comment

ID: 26101478
Go to www.mxtoolbox.com, Check MX records there, ....
Also verify on the Exchange Server --> EMC | Server configuration | Hub Transport | Default (Receive connector) | Permissions Group | Check - Anonymous users


Expert Comment

ID: 26101867
@ Alanhardisty, I think the MX record is correct because I am able to send out to external emails like yahoo and aol accounts. I figured if the MX record was wrong, yahoo or aol would reject it. The problem I am having is, when people reply to the email. They get a rejection.

The MX record should be setup. The domain is mysmbmi.com.. When you do an MX record lookup for that, you'll get the external ip for maila.sanmanuel.com.. the  .

@ Narayan and Qupnit
I was able to set the anonymous though the EMC and now looks like everything is work. I am able to send and receive.  Why wouldn't it work though the shell,  Is setting up the exchange with anonymous dangerous?
LVL 28

Expert Comment

ID: 26103465
When dealing with a problem like this it's not sufficient to "think" the MX records are set up properly. You need to know. Thus use the tool nslookup:
> set type=mx
> maila.sanmanuel.com
Server:  xxx.xx

        primary name server = cbru.br.ns.els-gms.att.net
        responsible mail addr = rm-hostmaster.ems.att.com
        serial  = 4
        refresh = 10800 (3 hours)
        retry   = 3600 (1 hour)
        expire  = 604800 (7 days)
        default TTL = 86400 (1 day)
> exit

C:\Utils>ping rm-hostmaster.ems.att.com
Ping request could not find host rm-hostmaster.ems.att.com. Please check the name and try again.

Hence no (public) MX record. There you have it.

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to effectively resolve the number one email related issue received by helpdesks.
Among the most obnoxious of Exchange errors is error 1216 – Attached Database Mismatch error of the Jet Database Engine. When faced with this error, users may have to suffer from mailbox inaccessibility and in worst situations, permanent data loss.
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an anti-spam), the admin…
Suggested Courses

580 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question