• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 908
  • Last Modified:

Remote site switched to MPLS WAN Link, Citrix XenApp and Web Interface no longer working

I have four sites all worked fine on private point-to-point T1 WAN links back to headquarters. The Citrix PS 4.5 farm is in headquarters. We recently switched one of our sites to MPLS (3x T1's MLPPP) and all site-to-site traffic works except for Citrix XenApp PNA and Web Interface connections. All other sites continue to work fine using private point-to-points WAN links. I can ping between sites and routing is working with static routes.

XenApp just shows connection in progress....
Web Interface never logs in with FQDN, but IP logs in but App result in XenApp Connectionin progress hung....

Help!
0
lseeman
Asked:
lseeman
  • 5
1 Solution
 
satyasinghCommented:
couple of tests

1. is PING working both ways
2. are we able to telnet on the port required for this to work from source machine.
0
 
lseemanAuthor Commented:
* I can ping in all directions by IP or FQDN
* I tried removing the HKLM registry key .../mslicensing/store/Licencexxx
* Web-interface (WI) loads but login never processes with fqdn, but logs in via IP URL
* Executing citrix published app via XenApp PNA or WI hang at Connection in progress...

* I removed all in between appliances; router to router still no good
* All other remote sites to headquarters work fine for Citrix
* I can telnet from the affected site computer(s) on port 1494, 80, 443; all are open and listening with ICA...

I AM STUMPED!?!?!?!?!
0
 
lseemanAuthor Commented:
One thing that is strange, is I cannot login to WI using computername or fqdn; but I can using IP from the remote site. Even so, neither let me get a published app to launch.....PNA or ICA client hang at Connection in progress.

As far as the infrastructure, the only thing that changed is the following:

1. remote site router went from using single serial private t1 to multiple serial bonded t1's over MPLS

2. at headquarters, we have an additional router connected to same lan switch as original router interconnected the MPLS WAN link to the production network via static routes.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
lseemanAuthor Commented:
I discovered one computer that works.  The only difference is that there is a MSTS license under hklm/microsoft/mslicensing/store. All other computer are not getting new licenses after deleting this key.

It appears that the MSTS licensing server is not issuing device cal's......to this site. All 3 other sites work fine though....
0
 
lseemanAuthor Commented:
Turns out after much analysis and troubleshooting, I am 95% confident the problem is on the MPLS carriers side (PaeTec). The issues might be a result of PPP Encapsulation....so we're trying fram-relay encapsulation....

Stay tuned....
0
 
lseemanAuthor Commented:
I resolved the issue by identifying an incorrect MTU and encapsulation issue on the MPLS carriers network, which was causing improper packet handling and timing. We went from PPP to FR encap on one side and removed any MTU settings on edge routers.
0

Featured Post

Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now