Help with "the local policy of this system does not allow you to logon interactively"

I'm working on someones home PC.  Just the other day when they booted it takes them to the screen where they'd click a user icon but now there aren't any user icons.  Just a blank screen where they can only shut down or restart.  I've hit ctrl-alt-del twice and got the GUI logon and when I try the admin or the user account I get the following message....

"the local policy of this system does not allow you to logon interactively"

I've tried it in safe mode and get the same message.  I've checked all the accounts and they aren't locked.  I tried copying the secuirty file from winnt\repair directory in to the windows\system32\config and that doesn't fix it.  The only thing I haven't done yet is take out the drive and hook it in to one my test PC's and scan it.  Does anyone have a fix for this or any idea?  I'm thinking it must be some sort of a virus but I am not for sure.  I've read about people using ntrights as follows.....

"ntrights -m \\ProblemComputer -u Administrator +r SeInteractiveLogonRight"

I can't seem to figure out of ntrights works with xp or not because microsoft says it only works with 2000.

Thanks in advance.
LVL 1
pmac38CDSAsked:
Who is Participating?
 
pmac38CDSConnect With a Mentor Author Commented:
Okay so here is what I ended up doing.  I booted up with a BartPE disk.  I then went and renamed the system file in windws\system32\config to system.old.  Then I copied over a system file from the restore fodler from about 5 days previous when the user said it was working.  Once I did that I rebooted and the problem was solved.  Once in windows then I did a system restore to 5 days earlier so It would restore all the files and not just the one I did.
0
 
kortinaCommented:
Basically you need to edit the local policy on the machine.

If you had access to the machine, you would run secpol.msc
Navigate to Local Policies\User Rights Assignment

In there you will find a setting called: "Allow log on locally"
This should normally contain "Administrators", "Backup Operators", "Power Users"

The best bet is to hit F8 when the PC loads, and try "Last known good" configuration. Try it twice in a row. Hopefully this will roll back the setting. When you get back in check the setting yourself.

If the computer is a member of a domain, you can set the value with Group Policy then wait for it to apply. But I am guessing that you are in a home situation where the person doesnt have a domain.
0
 
xtreminatorDIYerCommented:
check link could help...

http://www.computing.net/answers/windows-nt/cant-logon-locally-domain-help/21774.html

if this computer in LAN... access its registry editor from another computer......
0
 
4eosCommented:
You could try overwriting the C:\WINDOWS\system32\GroupPolicy directory with a default one which would take those restrictions out.
0
 
pmac38CDSAuthor Commented:
I forgot to mention this is XP HOME so I am pretty sure it doesn't have the GroupPolicy Directory.  I am at work and will have to look tonight but I think that home doesn't have that.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.