?
Solved

Cisco ASA 5505 site to site

Posted on 2009-12-22
8
Medium Priority
?
406 Views
Last Modified: 2012-05-08
Hi,
I have configured an ASA 5505 via the site to site wizard but am unsure how to diagnose or check connectivity.
Local inside IP is 192.168.3.x
Remote inside IP is 192.168.1.x
local outside ip is 86.x.x.x
remote outside ip is 79.x.x.x

I have performed same setup on remote ASA device and made sure to choose same encryption etc. All settings have been saved to flash etc.

Grateful for any help, J.

: Saved
:
ASA Version 8.2(1)
!
hostname ciscoasa
enable password xxxxx encrypted
passwd xxxxx encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.3.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 192.168.0.7 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
access-list outside_access_in extended permit icmp any any
access-list outside_1_cryptomap extended permit ip 192.168.3.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.3.0 255.255.255.0 192.168.1.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 192.168.3.0 255.255.255.0
nat (inside) 1 0.0.0.0 0.0.0.0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 192.168.0.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.3.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs group1
crypto map outside_map 1 set peer 79.x.x.x
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.3.5-192.168.3.36 inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics port
threat-detection statistics protocol
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
tunnel-group 79.x.x.x type ipsec-l2l
tunnel-group 79.x.x.x ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:xxxxxxxxxx
: end
no asdm history enable

0
Comment
Question by:jerryhatt
8 Comments
 
LVL 21

Expert Comment

by:Rick_O_Shay
ID: 26104439
I would start by pinging first the remote outside ip is 79.x.x.x address and then the Remote inside IP is 192.168.1.x from the local end and then repeat the reverse from the other end. If all of those pings are good move on to pinging a remote PC from a local one to confirm end to end connectivity.

 
0
 
LVL 3

Accepted Solution

by:
emonda earned 2000 total points
ID: 26104629
You can also type "sh crypto isakmp sa" on either ASA.

That will show if it is active or not...here is an example:

1   IKE Peer: 209.X.X.X
    Type    : L2L             Role    : initiator
    Rekey   : no              State   : MM_ACTIVE

You might have some issues with the VPN Though...I see that your WAN IP is a LAN IP.  You must be behind another router or firewall?  That router or firewall might be blocking IPSEC traffic.
0
 

Author Comment

by:jerryhatt
ID: 26105264
Thanks, this is what I got:
Result of the command: "sh crypto isakmp sa"

   Active SA: 1
    Rekey SA: 0 (A tunnel will report 1 Active and 1 Rekey SA during rekey)
Total IKE SA: 1

1   IKE Peer: 79.xxx.xxx.xxx
    Type    : user            Role    : initiator
    Rekey   : no              State   : MM_WAIT_MSG4

I am also getting lots of log messages such as:
6      Dec 21 2009      15:17:32      713219                              IP = 79.xxx.xxx.xxx, Queuing KEY-ACQUIRE messages to be processed when P1 SA is complete.

5      Dec 21 2009      15:18:30      713904                              IP = 79.xxx.xxx.xxx, Received an un-encrypted INVALID_COOKIE notify message, dropping
3      Dec 21 2009      15:18:54      713902                              IP = 79.xxx.xxx.xxx, Removing peer from peer table failed, no match!
0
Rewarding opportunities for women in IT

Across the nation, technology jobs are vacant because there aren’t enough qualified professionals to fill them. With a degree from WGU, you can get the credentials it takes to become an in-demand IT professional. Plus, WGU’s IT programs include industry certifications.

 
LVL 3

Expert Comment

by:emonda
ID: 26106505
Ok,
so your VPN is not connecting.  

Do you have a firewall behind the ASA?  You might need to open udp port 500 or configure port forwarding to forward udp 500 to the 192.168.0.7
0
 
LVL 7

Expert Comment

by:Texas_Billy
ID: 26115310
No peer match indicates that one of the ASAs is trying to build a tunnel to an IP address that isn't advertising itself as an IPSec peer at all.  Make sure you don't have any typos in the external IPs of either ASA.  For instance, on the config you have shown, the outside IP is 192.168.0.7.  I assume that's just to have something in this example, right?

Make sure you don't have any typos in the external IPs, the crypto map set peer statements, or in the tunnel-group configs.  --TX
0
 

Author Comment

by:jerryhatt
ID: 26116689
Thanks emonda and TX. The 192.168.0.7 is the address of a netgear router connected to the internet. It does have an external IP and the ASA is set as the DMZ target so should receive all traffic (or so I thought). The asa at that end is configured correctly as firewall and has connectivity.

I am going to install the ASA in a data centre in the next few days so will have a proper external IP to set in the tunnel settings. Hopefully this will clear up the problem. I will report back and close this thread after that.
0
 

Author Comment

by:jerryhatt
ID: 26128842
Both ASA are now in data centres and have internet connectivity.
I have setup the site to site connection on both devices using the following:
Info:
site 1 local network 192.168.1.0
site 1 external Ip 79.x.x.x

site 2 local network 192.168.3.0
site 2 external Ip 213.x.x.x

site 1 commands sent via CLI:

access-list outside_20_cryptomap extended permit ip 192.168.1.0 255.255.255.0 192.168.3.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 192.168.3.0 255.255.255.0
nat (inside) 0 access-list inside_nat0_outbound
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto map outside_map 20 match address outside_20_cryptomap
crypto map outside_map 20 set pfs
crypto map outside_map 20 set peer 213.x.x.x
crypto map outside_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
tunnel-group 213.x.x.x type ipsec-l2l
tunnel-group 213.x.x.x ipsec-attributes
pre-shared-key xxxxxxxxxxxxxxxx

site 2 commands sent via CLI:

access-list outside_20_cryptomap extended permit ip 192.168.3.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.3.0 255.255.255.0 192.168.1.0 255.255.255.0
nat (inside) 0 access-list inside_nat0_outbound
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto map outside_map 20 match address outside_20_cryptomap
crypto map outside_map 20 set pfs
crypto map outside_map 20 set peer 79.x.x.x
crypto map outside_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
tunnel-group 79.x.x.x type ipsec-l2l
tunnel-group 79.x.x.x ipsec-attributes
pre-shared-key xxxxxxxxxxxxxxxx


All commands were accepted by the CLI and saved to flash.
running sh crypto isakmp sa at site 1 shows only an existing site to site that works OK and the IKE connection I am dialling in on

running sh crypto isakmp sa at site 2 reports "There are no isakmp sas"
0
 

Author Closing Comment

by:jerryhatt
ID: 31668929
he problem has now changed and different errors are happening. This question is no longer relevant but I will accept the most relevant answer to previous problem and recreate a new question.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

You deserve ‘straight talk’ from your cloud provider about your risk, your costs, security, uptime and the processes that are in place to protect your mission-critical applications.
Considering cloud tradeoffs and determining the right mix for your organization.
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
Suggested Courses
Course of the Month14 days, 13 hours left to enroll

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question