[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3878
  • Last Modified:

oracle forms 6i does not work in 11g

we have production version of oracle forms 6i which works fine in our current oracle version 10g (rel2) when we upgraded to 11g the forms does not work, since it is the form that user uses we have a problem to get it up and running in oracle 11g, what are my options, we have also oracle apps installed in sun solaris and that has OAF capabilities as well, I want to find out if it is possible to make the 6i form work either in oracle 11g or in oracle apps using OAF - I do not want to rewrite the form code for OAF also since it is very time sensitive issue. looking for quick options to try..
0
mahjag
Asked:
mahjag
  • 3
  • 3
  • 2
1 Solution
 
x77Commented:
What is the error ?
Are you installed Oracle client 11 ?
The path to Oracle 8 client is prior other oracle paths ?
0
 
x77Commented:
http://forums.oracle.com/forums/thread.jspa?threadID=590187

 - Oracle 11g database has a new parameter SEC_CASE_SENSITIVE_LOGON (case sensitive password enabled for logon) - default is TRUE.
But Forms transforms (for example) "scott/tiger" to "SCOTT/TIGER".


0
 
Mark GeerlingsDatabase AdministratorCommented:
We did some testing with Forms6i and an Oracle11g database, and that combination worked for us.  What doesn't work for you or what kind of errors do you get?  Are you able to log in, but then get erros, or are you not able to log in?
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
mahjagAuthor Commented:
Sorry could not respond earlier - we could not even login to the forms - it shuts down giving no error -
0
 
Mark GeerlingsDatabase AdministratorCommented:
Forms6i has been desupported by Oracle for some time, so Oracle Support isn't going to help you with this combination, but we have gotten it work, so it can be done.  Which patch level (or exact version) of Forms6i do you have?  We have Forms version: 6.0.8.26.0.  Maybe you need a later patch level.  Also, which version of Oracle11 do you have?  We have 11.1.0.7.
0
 
mahjagAuthor Commented:
Forms [32 Bit] Version 6.0.8.27.0 (Production) - oracle 11.2.0.1.0
0
 
Mark GeerlingsDatabase AdministratorCommented:
Ok, so your version s are slightly different.  Maybe that is significant.  For example, we tried Forms6i with an Oracle10.2 database, but that didn't very well at all (lots of problems with record locks).  For that reason, we kept our production database on Oracle10.1 for three years after 10.2 was available, because our application was Forms6i.  Now, we have migrated most of our business away from our custom app to EBS, which runs for us on an Oracle11.1 database.  We still have a tiny Forms6 application that we still use, and I've tried connecting that to Oracle11.1, and that works.  Do you have an Oracle11.1 database that you can test with?
0
 
mahjagAuthor Commented:
have to go with accepted results but the solution was not tested
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

  • 3
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now