• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 689
  • Last Modified:

Routing between hp 2610 procurve switches

I have to two HP 2610 procurve switches that are connected.  Switch one has an ip address of 10.40.1.1 and a second vlan - Vlan10 with a ip address of 192.168.129.3, there are 2 ports assigned to Vlan10.  I have a cable from one of the vlan10 ports connected to Switch one to Switch two.  

Switch two has the default Vlan1 with an ip address of 192.168.129.1.  Access from Switch two to one is fine.

The problem is hosts on Switch one cannot get to 192.168.129.1 but can ping any other hosts on Switch two.  Host on Switch one use 10.40.1.1 as the DG.  Shouldn't I be able to get to 192.168.1.1?

Switch one has ip routing enabled, switch two does not.
0
dmwynne
Asked:
dmwynne
  • 3
  • 2
1 Solution
 
jburgaardCommented:
Clients in vlan 10 should have dgw set to 192.168.129.3
also netmask in vlan10 should be the same all over.

HTH
0
 
dmwynneAuthor Commented:
jburgaar I ran into an issue where I can ping and access host from 10.40.1.1 to 192.168.129.1 but not the other way arround.  I can't ping 10.40.1.1 from the switch at 192.168.129.1.  There is no route for 10.40.1.1 on the 192 switch but it has the direct cable.  How can I get this to work.
0
 
jburgaardCommented:
Hi dmwynne,
if you still have problem and host DOES answer ping within own IP-network, then please provide details:
show run from each of the switches
switchports connecting the switches
switchports with the PC's in case
ipconfig of PC's with IP, mask & dgw
0
 
dmwynneAuthor Commented:
Actually I need to amend my last comments.  From a host connected to 192.168.129.1 switch I can ping to hosts on 10.40.1.1 but from the actual switch 192.168.129.1 I get the message network is unreachable.

I attached the show run from both switches

Port 50 on 10.40.1.1 switch connects to port 23 on the 192.168.129.1 switch
Running configuration:

; J9087A Configuration Editor; Created on release #R.11.22

hostname ""
snmp-server contact ""
snmp-server location ""
interface 1
   name "host1"
exit
interface 20
   name "host2"
exit
interface 23
   name "data switch"
exit
ip default-gateway 192.168.129.3
ip routing
snmp-server community "public" Unrestricted
vlan 1
   name "Avaya"
   untagged 1-28
   ip address 192.168.129.1 255.255.255.0
   exit



Running configuration:

; J9088A Configuration Editor; Created on release #R.11.25

hostname ""
snmp-server contact ""
interface 45
   name ""
exit
interface 46
   name ""
exit
interface 47
   name ""
exit
interface 48
   name ""
exit
interface 49
   name ""
exit
interface 50
   name "Connected to 192.168.129.1"
exit
ip default-gateway 10.40.1.3
ip routing
snmp-server community "public" Unrestricted
vlan 1
   name "DEFAULT_VLAN"
   untagged 1-47,49,51-52
   ip address 10.40.1.1 255.255.0.0
   no untagged 48,50
   exit
vlan 10
   name "VLAN10"
   untagged 48,50
   ip address 192.168.129.3 255.255.255.0
   tagged 26
   exit
ip route 0.0.0.0 0.0.0.0 10.40.1.3

Open in new window

0
 
jburgaardCommented:
I would try removing the 'ip routing', that is:
no ip routing
on the switch with only one vlan.
HTH
0

Featured Post

Veeam and MySQL: How to Perform Backup & Recovery

MySQL and the MariaDB variant are among the most used databases in Linux environments, and many critical applications support their data on them. Watch this recorded webinar to find out how Veeam Backup & Replication allows you to get consistent backups of MySQL databases.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now