Netboot Client Mac OS 10.5.8

Posted on 2009-12-22
Last Modified: 2013-11-11

I am unable to get clients to netboot to our server. I have two servers in two different offices and i've copied one image up to the second office and it doesnt seem to work. The server setup is identical but the clients can never get connected to the server. In the logs I find:
Can't open /etc/bootptab and subnets: Failed to convert 'router' : Invalid IP Address
Question by:ddbla
    LVL 15

    Expert Comment

    how have you got the netboot servers configured on your network?  are they providing DHCP addresses?  are they on the same subnet as the clients?

    which logs are you quoting?  client or server?

    Is the original server working?  how is this configured if it is working?  the same as the second server?

    Is the server the same version of OS - you say Identical, did you clone the first one to the second one or just install with the same settings?

    is your DHCP server (presuming you are using a separate DHCP server) providing the netboot address to the clients?

    lots of questions I know, but need a clearer picture of your environment. :)

    Author Comment

    the servers do not provide  DHCP for the clients. In the SF office it is supplied by a Windows Server and on LA office it is provided by our Core 4507 switch.

    the clients are on the same subnet as the server.

    the logs are quoted fromt the netboot log screen on the server.

    Both servers are at 10.5.8, but as far as cloning they are not in that sense. the configurations are installed with the same settings.  

    The clients get the spinning globe but then just boot to the desktop.
    LVL 15

    Accepted Solution

    So are either of your servers working correctly as netboot servers for your clients?  or neither?

    I heard of a similar problem and it was to do with the bootpd.plist file or problems getting to the .nbi files.  Try the following as this seems to have provided resolution in a couple of incidents::

    Solution: Part of the problem was the bootpd.plist file. The other part of the problem was that the Share Points got all messed up.

    Move all .nbi folders out of SP0 folder on your netboot server

    Go to Server Admin
    Disable Netboot

    select server
    go to File Sharing
    go to Share Points

    Unshare all NetbootSP* and NetbootClients* shares.

    Enable Netboot. Configure.
    Modify the Protocol Options of the new shares (File Sharing).

    Move all .nbi folders back into SP0 folder.

    Try the netboot again after this. and let me know how it goes.

    I trust you have tested the neboot image to make sure this is good?

    Author Comment

    Hi Roy,

    Just one question, how do you change the protocol options?

    and the image works in the LA office fine.
    LVL 15

    Expert Comment

    in the file sharing tab / section for that server in the server admin application.  It's what used to be available in the workgroup manager and is now moved to a subsection for each 10.5.x server in server admin.

    Author Comment

    Hi Roy,

    Thanks for pointing that out.
    I was adjusting the permissions on the .nbi folders as it looks like the Everyone permission was not pushing all the way down to the files inside. That seems to have allowed the clients to connect to the image. Perhaps this permission fell off when transferring across our network?

    2 systems are currently imaging now.
    LVL 32

    Expert Comment

    Before that can you even select the netboot image from your system preferences and boot from it?  If this cannot be done there may be a problem with the image itself.

    Also, have you restricted the image to specific hardware builds, which may be preventing it from booting the target machine?

    Is the DHCP server on the same subnet as the netboot server?  

    Author Comment

    hi nappy d,

    it actually looked to be the permissions on the .nbi folder. After allowing the permissions to propagate the systems imaged successfully.

    Yes, they were able to see the image in the system preferences. There was also no filtering enabled.



    Author Closing Comment

    This should have reset the permissions on the image.

    I accept this as the solution.

    Thanks, Roy!

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Better Security Awareness With Threat Intelligence

    See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

    Suggested Solutions

    The /etc/authorization file in Mac OS X 10.x can be used to control access to the various panes of the System Preferences amongst other things. It’s used by some of us Mac Sys Admin’s to give Standard Users access to System Prefs panes that only adm…
    Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
    Need more eyes on your posted question? Go ahead and follow the quick steps in this video to learn how to Request Attention to your question. *Log into your Experts Exchange account *Find the question you want to Request Attention for *Go to the e…
    Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

    737 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    22 Experts available now in Live!

    Get 1:1 Help Now