• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1003
  • Last Modified:

How do i fix opatch it gives an error after patchset database upgrade

I just completed installing patchset and upgrade my database. when I type any opatch command I get the following error:
File Not Found Java could not be located. OPatch cannot proceed! OPatch failed with error code = 1
Could someone tell me what could be wrong and how I fix this?
  • 2
3 Solutions
NikSystems SpecialistCommented:
Seems like this patch, changed the path to local Java installation.
Have you tried upgrading Java?
I'm not strong in DB field, but since no one is responding, I'll try to help you.
Try the following:
opatch lsinventory jre %ORACLE_HOME%\jdk
Not sure why the !! characters are before jre after the post but it should be:
opatch lsinventory -jre %ORACLE_HOME%\jdk
Looks like your JAVA_HOME environment variable is not set or it is set to a wrong directory.
Are you you experiencing problems with other Java Tools ?
Set it properly and this should be ok.

In addition to setting your JAVA_HOME, you can also tell opatch the path to your jdk or jre install using -jdk or -jre option of opatch:

opatch apply <patch number> -jdk /path_to_jdk/bin

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now