• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 376
  • Last Modified:

SteadyState PDF Crash

When I'm logged on to this machine as a SteadyState User, when I try to open a PDF, Firefox crashes.  It doesn't when I'm logged on as the administrator.
0
hrolsons
Asked:
hrolsons
  • 5
  • 4
1 Solution
 
Maniac_47Commented:
As a first step, please right click "My Computer" and choose "manage"
expand local users and groups
Expand Groups
click on the "Administrator's" group and add the user in question temporarily so we can see if its a permissions related issue (a dll or program file that may be denied either by policy or by default).

If that fixes the issue, I would give "domain users" or "users" more permissions on the items in question.
0
 
hrolsonsAuthor Commented:
That did the trick, now I'm trying to figure out how to give my "users" more permissions.  I'll start a new question if that is appropriate.
0
 
Maniac_47Commented:
I'd be happy to help.

Can you give them permissions to the PDF Program's folder (modify permissions), as well as permissions to Firefox's program files (modify as well).

It may be that an update was trying to install, a plugin, or even an active x something or other and it would crash since they didn't have the permissions.

As a side note:
we sometimes give our users Local Admin rights so they can work with what they need, but give them the basic "User" access via the domain.  This keeps them functional on their local 1 workstation, and enables the domain security to exist for all files and shares.

I'd start with the permissions above and let me know if that still causes a problem.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
hrolsonsAuthor Commented:
Sorry, I don't know how to "Modify Permissions".
0
 
Maniac_47Commented:
you can right click the folder (c:\program files\mozilla or wherever you install firefox) and choose properties -> choose "security" tab, and choose to add domain users or the specific users with "modify" permissions (the checkbox will automatically fill in others)

Let me know if you still have issues with this - this is XP Pro right?  XP home won't have the security tab.
0
 
hrolsonsAuthor Commented:
It is XP Pro, but I don't have a "Security" tab.
0
 
Maniac_47Commented:
is this machine a member of a domain?  You could just leave them as local administrators if this is just for the local machine (or even power users if you'd like).

   1. Launch " My Computer ".
   2. Click on the Tools at the menu bar, then click on Folder Options.
   3. Click on View tab.
   4. In the Advanced Settings section at the bottom of the list, uncheck and unselect (clear the tick) on the Use simple file sharing (Recommended) check box.
   5. Click OK.


You'll have that tab now and you can check the permissions as I listed above.
0
 
hrolsonsAuthor Commented:
Boy, you sure know your stuff!!!  I've made all the changes and give the group "users" full control of the Mozilla and Adobe directories.  It still fails.

Since I'm using SteadyState, I think if I add the user to "Administrators", it won't matter if they change something because it will revert back to the original C: drive, right?
0
 
Maniac_47Commented:
Thats why I was stating earlier that leaving them as a local administrator shouldn't hurt anything.  I believe they need access to system files and dlls, and we could spend a long time adding the permissions, or we could just set them loose as local admins or power users.

Some applications just need admin access because of how they run, what they call, and what they want to access.

please let me know if there's anything else I can do.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now