• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 798
  • Last Modified:

Iphone Synch with Exchnge 2003 through ActiveSync not working

Here is some background:
1) Iphone 3GS with Exchange activr Sync
2) Exchange 2003 SP2 with OWA HTTPS Access - Working
3) I browse to: https://myserver.domain.com/Microsoft-Server-ActiveSync and I get the user field prompt. I enter a name and I then get  HTTP 501 Not Implemented/HTTP 505 Version Not supported
4) ActiveSynch MobileAdmin is installed for 2003
5) with IIS I see a Virtual directory called Microsoft-Server-ActiveSynch
6) Under System Manager I see Mobile Serviceswith all checkmarks enabled (No Check makrs enabled under "Device Security.."
7) Form Authentication is turned off

On the Iphone I add the username, password and email. Then I prompts me for the Server address so I input the OWA Address: myserver.domain.com. "Exchange Account Verified" then it forwards to the screen where I select which items to sync Mail, Contacts and Cal. I leave them all on and press Done

iI completes with "Configured Sync"

When i click on the Mail Icon I quickly see "Connecting..." but the inbox remains blank. Nor does anything else Sync.

After it connects I do not see the device in the ActiveSyncAdmin console
0
skyjumperdude
Asked:
skyjumperdude
  • 6
  • 6
  • 4
4 Solutions
 
Alan HardistyCommented:
Please run through my Exchange 2003 and Activesync FAQ and check your settings, run the tests and if required, run through the troubleshooting steps:
http://www.it-eye.co.uk/faqs/readQuestion.php?qid=1 
0
 
skyjumperdudeAuthor Commented:
I Ran the test and recieved the errors in the attached screenshot. The server is not a front end.. but the primary Exchange server I am trying to connect to


Error.jpg
0
 
Alan HardistyCommented:
My FAQ has recommendations for the HTTP 500 error (further down the article).  Shout if you need more guidance.
0
 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

 
skyjumperdudeAuthor Commented:
Thanks Alanhardisty but after going through your article and MS.. still getting the HTTP 500 Error. Even with SSL Disabled "Remove SSL settings from the Exchange IIS virtual directory
" Run iisreset "
0
 
Alan HardistyCommented:
Did you run through the FAQ exactly?  It is important to perform the steps in the exact sequence.
Did you run through method 2 of KB883380?
0
 
skyjumperdudeAuthor Commented:
Ah yes! I will do that.. cant belive I missed that one..ill try it
0
 
Alan HardistyCommented:
Well - it is a fairly packed FAQ article!
0
 
skyjumperdudeAuthor Commented:
Reviewed the article and re-created the Virtual directories and still no luck. Same error

Even when doing performing these steps. the 500 error appears...
 Disable Forms Based Authentication - Exchange HTTP Protocol (if enabled)
" Remove SSL settings from the Exchange IIS virtual directory
" Run iisreset
" Test activesync without SSL selected - hopefully this should work or give the OK result


0
 
9vijakCommented:
1. Try to install the hotfix mentioned in below article.
http://support.microsoft.com/default.aspx?scid=kb;en-us;967046
If you have already applied that ignore this.

2. Have you ever used SSL on Exchange Vdir in iis?
If yes check following registy:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MasSync\Parameters look for ExchangeVDir Dword if it is there remove that.

3. Any user with WM device?If yes what is the behaviour?

4. Any events on server related to ServerActiveSync?

5. Which certificate you are using is it your own certificate CA or you have a 3rd party certificate?
If you can provide your owa url.

6. Any file level anti virus installed on exchange server? if yes check the exclusions for C:\Inetpub,C:\windows\System32\inetsrv,C:\Program Files\Exchsrvr.

7. Do you have any URL scan running on server?

8. Check for service FAMV4 in registry:
Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
Look for FAMv4 under the Services Key.Set the "Startup" value to 4 so that it disables the FAMv4 service

9. Follow http://support.microsoft.com/kb/943612

10. Create new user account with mailbox and test with that.

11. Also try with WM emulator on the internal machine with internal IP address of server. http://msexchangeteam.com/archive/2007/09/17/447033.aspx

12. Goto properties of Default web site in iis manager and verify if HTTP KeepAlive Check box is checked (if not check that box).
0
 
skyjumperdudeAuthor Commented:
1) The file version for Massynch currently is: 6.5.7638.1. The KB article states: Massync.dll 6.5.7655.0
2) I added the Registry key as http://support.microsoft.com/kb/817379 was applied
3) No other user with Window Mobile device (Blackberry Shop).. until we got this Iphone
4) See attached
5)Thris Party Cert from Verisign which is okay and working
6) Syamntec Endpoint is on the system but it is not excluding the folders listed
7) No URL scan running
 8) Do not see the Services FAMv4 within the registry
12) Keep alive is set withn IIS
12-23-2009-10-48-21-AM.jpg
0
 
Alan HardistyCommented:
If you have require SSL on the Exchange virtual directory, then you have to have SSL not required on the Exchange-OMA virtual directory.  One of them needs to be non-SSL.
Generally, you only need the Exchangeoma virtual directory if you are using Forms Based Authentication, so if you are not, then you don't need the exchange-oma IIS directory (unless you are using SBS 2003).
If you are not using FBA - please delete the exchange-oma IIS directory and ensure that Exchange does not have SSL enabled.  If you are using FBA - chek that the Exchange virtual directory has SSL enabled and the exchange-oma does not.
Run iisreset (Start> Run> iisreset {press enter})
Test with https://testexchangeconnectivity.com using the Exchange Activesync Test.
0
 
skyjumperdudeAuthor Commented:
1) If you have require SSL on the Exchange virtual directory, then you have to have SSL not required on the Exchange-OMA virtual directory.  One of them needs to be non-SSL.
-----> I disbaled it on the Exchange-OMA and did the IISreset same error as above

2) If you are not using FBA - please delete the exchange-oma IIS directory and ensure that Exchange does not have SSL enabled.  If you are using FBA - chek that the Exchange virtual directory has SSL enabled and the exchange-oma does not.
------> Not using an FBA so I know deleted the exchange-oma folder (OWA connects directly to exchange) and the registry ley for it.I disabled SSL on the Exchange VDIR and did the IIsreset. I tried the site again and got the same error: Attempting FolderSync command on ActiveSync session
  FolderSync command test failed

Thanks everyone for all the help so far.. just dont know what could be left at this point
0
 
Alan HardistyCommented:
Have you got Forms-Based Authentication Enabled?
Check using Exchange System Manager> Server> Protocols> HTTP> Exchange Virtual Server Properties> Settings Tab.
0
 
9vijakCommented:
1. If you are not using FBA or SSL on Exchange Vdir in iis you have to remove:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MasSync\Parameters look for ExchangeVDir Dword.
2. Do an IISRESET from the command prompt.
3. If still dosent work follow the KB 883380 method 2 once more.(First take backup of current iis)
4. Apply the hotfix for upgading the version of MasSync.dll file.
5. Follow http://support.microsoft.com/kb/943612 and make the registry changes.
6. Run Netsh int ip set chimney DISABLED on exchange server command prompt.
7. -Follow http://support.microsoft.com/kb/896861and add the below registry
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
DisableLoopbackCheck
Value data box, type 1, and then click Ok
8. If dosent work  setup WM emulator on the internal machine with internal IP address of server. http://msexchangeteam.com/archive/2007/09/17/447033.aspx.
0
 
9vijakCommented:
-Also make sure the chain of certificate is ok.(run testexchangeconnectivity.com exchange activesync to verify same)
0
 
9vijakCommented:
-Make sure that on the default web site properties next to ip address drop down in advance button no host header is defined.
-And important thing if you are using more than one network card make sure that the active nic is on the top on in network bindings(Start->Run->ncpac.cpl (enter)->Advance menu->Advance settings).
0

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

  • 6
  • 6
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now