Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 312
  • Last Modified:

VPN Connection lost - Cisco Pix 501

One of my users deleted his VPN settings - now i cant seem to connect him back on. HE was connecting through CISCO VPN Client 4.8,and i tried to get settings from my router's running config, but its not working. I am trying to do it from my home - is it possible that our server is configured that only he can connect from his office? How do I get him connect to us again through Cisco VPN Client 4.8? thanks

Here is the running config:
Ok, here is the running config - and i was able to see the password on the tftp server. Just to make sure, in the cisco vpn client these will be my settings:

Host: xxxxxxx.org
Group Name: jaremotes
password: *********

and it should work right? - I see something about crypto map to Dayton Client - which is where this person is located. Does this means only he can connect with vpn to use or I can try these settings from my home? Thanks!

PIX Version 6.3(5)
interface ethernet0 10baset
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password GWrHuOdSnP3vVpxD encrypted
passwd GWrHuOdSnP3vVpxD encrypted
hostname pixfirewall
domain-name xxxxxxx.org
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
access-list aclin permit tcp any host xx.x.xx.xxx eq 4899
access-list aclin permit tcp any host xx.x.xx.xxx eq smtp
access-list aclin permit tcp any host xx.x.xx.xxx eq www
access-list aclin permit tcp any host xx.x.xx.xxx eq citrix-ica
access-list aclin permit tcp host xx.x.xx.xxx host xx.x.xx.xxx eq ldap
access-list aclin permit tcp any host xx.x.xx.xxx eq 3389
access-list vpn_nat_acl permit ip 172.16.1.0 255.255.255.0 192.168.200.0 255.255
.255.0
access-list outside_cryptomap_dyn_20 permit ip any 192.168.200.0 255.255.255.0
access-list jaremotes_splitTunnelAcl permit ip 172.16.1.0 255.255.255.0 any
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside xx.x.xx.xxx 255.255.255.248
ip address inside 172.16.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool RemoteVPNPool 192.168.200.1-192.168.200.254
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list vpn_nat_acl
static (inside,outside) xx.x.xx.xxx 172.16.1.2 netmask 255.255.255.255 0 0
static (inside,outside) xx.x.xx.xxx 172.16.1.3 netmask 255.255.255.255 0 0
static (inside,outside) xx.x.xx.xxx 172.16.1.4 netmask 255.255.255.255 0 0
access-group aclin in interface outside
route outside 0.0.0.0 0.0.0.0 xx.x.xx.xxx 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
http 172.16.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
floodguard enable
sysopt connection permit-ipsec
sysopt noproxyarp inside
crypto ipsec transform-set strong esp-des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set strong
crypto map toDayton 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map toDayton client configuration address initiate
crypto map toDayton client configuration address respond
crypto map toDayton interface outside
isakmp enable outside
isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
isakmp client configuration address-pool local RemoteVPNPool outside
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 1
isakmp policy 10 lifetime 86400
isakmp policy 15 authentication pre-share
isakmp policy 15 encryption des
isakmp policy 15 hash md5
isakmp policy 15 group 2
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 1
isakmp policy 10 lifetime 86400
isakmp policy 15 authentication pre-share
isakmp policy 15 encryption des
isakmp policy 15 hash md5
isakmp policy 15 group 2
isakmp policy 15 lifetime 86400
vpngroup jaremotes address-pool RemoteVPNPool
vpngroup jaremotes dns-server 172.16.1.2
vpngroup jaremotes default-domain xxxxxxxx.org
vpngroup jaremotes split-tunnel jaremotes_splitTunnelAcl
vpngroup jaremotes idle-time 7200
vpngroup jaremotes password ********
telnet 172.16.1.0 255.255.255.0 inside
telnet timeout 5
ssh xx.xx.x.x 255.255.255.0 outside
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:a939584ebafeaba60b199056eb90789a
: end




0
Cubbybulin
Asked:
Cubbybulin
  • 5
  • 5
1 Solution
 
periferralCommented:
i dont see anything wrong. It looks like if he has a group name, password, he should be able to connect.
It should assign him an IP from this pool range
ip local pool RemoteVPNPool 192.168.200.1-192.168.200.254

What do you see when you connect from your home using these settings?
0
 
CubbybulinAuthor Commented:
it says:
Secure VPN connection terminated locally by the client.
Reason 412: The remote peer is no longer responding.
0
 
periferralCommented:
I remember there being something about protocol to connect. Not sure what the default is. Try using NAT-T/TCP in your profile

0
Prepare for an Exciting Career in Cybersecurity

Help prevent cyber-threats and provide solutions to safeguard our global digital economy. Earn your MS in Cybersecurity. WGU’s MSCSIA degree program curriculum features two internationally recognized certifications from the EC-Council at no additional time or cost.

 
CubbybulinAuthor Commented:
The default is IPSEC over UDP (NAT/PAT)
I changed it to IPSEC over TCP (TCP Port 10000)  Then i get message:
REason 414: Failed to establish a TCP connection
0
 
periferralCommented:
okay i think the default UDP is fine. What is the server configuration in the profile. Can you ping the server?
0
 
CubbybulinAuthor Commented:
no, it says request timed out
0
 
periferralCommented:
thats odd. so you cant ping the server you are trying to connect to?

debug crypto isakmp
debug crypto ipsec

on the pix. and try connecting. See if you see anything on the console.
0
 
CubbybulinAuthor Commented:
What does this mean - does this have anything to with it? This client is in Dayton, so I thought maybe I had to be in his office to VPN? I Will try the debugging tomorrow
crypto map toDayton 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map toDayton client configuration address initiate
crypto map toDayton client configuration address respond
crypto map toDayton interface outside
0
 
periferralCommented:
that crytomap just means it will respond to client connections.. it had an access-list associated with it
which leads to this one
access-list outside_cryptomap_dyn_20 permit ip any 192.168.200.0 255.255.255.0

this just means it accepts connection from ip address 192.168.200.X

this matches the set of IP addresses which are a part of the VPN pool  which gets assigned when the client connects to the PIX.
0
 
CubbybulinAuthor Commented:
Thank you -thank you! The problem was i used a wrong outside IP, but you helped me to get there! It's working now. YEAY!
0

Featured Post

The Lifecycle Approach to Managing Security Policy

Managing application connectivity and security policies can be achieved more effectively when following a framework that automates repeatable processes and ensures that the right activities are performed in the right order.

  • 5
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now