[Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Simple RIPv2 Mis-configuration ?

Posted on 2009-12-22
3
Medium Priority
?
291 Views
Last Modified: 2012-05-08
I'm using a simple setup, a portion here with 2950 and 2620XM:

Host (PC) <--->  Switch (S1) <---> Router (R1) <---> Router (R2)

The PC is 192.168.1.150 (DHCP via R1). The VLAN 1 for S1 is 192.168.1.9. The S1-to-R1 is fia Fa0/0 at 192.168.1.1. The S1-to-S2 is via R1's S0/0 at 192.168.2.1 and R2's S0/0 at 192.168.2.2. I can't ping R2 from the PC but I can from S1. It would appear that RIPv2 is okay on S1:

==================================
R1#
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, FastEthernet0/0
C    192.168.2.0/24 is directly connected, Serial0/0
R    192.168.3.0/24 [120/1] via 192.168.2.2, 00:00:21, Serial0/0
R1#
R1#
R1#sh ip rip database
192.168.1.0/24    auto-summary
192.168.1.0/24    directly connected, FastEthernet0/0
192.168.2.0/24    auto-summary
192.168.2.0/24    directly connected, Serial0/0
192.168.3.0/24    auto-summary
192.168.3.0/24
    [1] via 192.168.2.2, 00:00:29, Serial0/0
R1#
=========================================

Why can't I ping from the PC? "Destination host unreachable."

The code snippet has show-run for S1.
S1#
S1#
S1#sh run
Building configuration...

Current configuration : 1379 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname S1
!
enable secret 5 $1$j72v$.FTOMvXK62I63vUV6FZtE/
!
ip subnet-zero
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
 ip address 192.168.1.9 255.255.255.0
 no ip route-cache
!
ip default-gateway 192.168.1.1
ip http server
!
line con 0
 exec-timeout 0 0
 privilege level 15
 password controls
 logging synchronous
line vty 0 4
 exec-timeout 0 0
 password controls
 logging synchronous
 login
line vty 5 15
 exec-timeout 0 0
 password controls
 logging synchronous
 login
!
!
end

S1#
S1#

Open in new window

0
Comment
Question by:GivenRandy
3 Comments
 
LVL 10

Accepted Solution

by:
lanboyo earned 2000 total points
ID: 26110070
What is the default route on the PC?  Does the DHCP server point it to 192.168.1.1? Can it ping 192.168.1.1?
0
 
LVL 6

Expert Comment

by:gcl_hk
ID: 26110080
you need to provide more inform:
sh run for R1 and R2
sh ip route on R2
which device to return the "Destination host unreachable."

0
 
LVL 9

Author Closing Comment

by:GivenRandy
ID: 31669275
Of course, I forgot to add default-route. Thanks!
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hello , This is a short article on how would you go about enabling traceoptions on a Juniper router . Traceoptions are similar to Cisco debug commands but these traceoptions are implemented in Juniper networks router . The following demonstr…
There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

864 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question