Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 549
  • Last Modified:

Some Sharepoint 3.0 pages don't work with public URL after exposing to Internet

I have a Sharepoint site that I extended and set up for FBA. I set my firewall to redirect http requests to port 81 on my SharePoint server.
I have the external URL listed in AAM.
If I access the Sharepoiont sites from the internal AD url (call it http://server) everything is fine. If I access the Sharepoint sites from the internal FBA URL http://server:81 sverything is fine.
If I access from the external URL, http://intranet.domainname.com, the site comes up. I cam authenticate with FBA and initially everything looks fine. If I try to access the contents of any libraries however, I get "An unexpected error has occurred.

Web Parts Maintenance Page: If you have permission, you can use this page to temporarily close Web Parts or remove personal settings. For more information, contact your site administrator. " 
Also, when I click "sign out", it just simply cannot load the page.
Any ideas?
0
needspace
Asked:
needspace
  • 7
  • 5
2 Solutions
 
mccarthybriCommented:
Make sure that there isnt something on the  page that is referenceing the absolute url.  that may be causing the issue  as in a picture or link that is tied to the complte url.  does it have a problem with subsites as well or just the homepage
0
 
needspaceAuthor Commented:
Subsites are fine. So is the homepage. The problem is with any document libraries. Also, if you go to sign out, the page times out. It is almost as if the path did not propigate through the database properly or something. I'm going to keep poking at it over the holidays and see what I come up with.
Nothing is referencing an absolute url to my knowledge.  
0
 
MsShadowCommented:
Let's first take a look at what the real error message is:
http://koenvosters.wordpress.com/2009/08/06/showing-the-real-error-message-in-sharepoint/
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
needspaceAuthor Commented:
This is what I get if I try to get to a Library. If I am on an internal URL, I can see the issue. When accessing the libraries, it is trying to use the External URL even when internal (if that makes any sense). So if I am at http://internalurl/default.aspx and I click on a library, it will try to goto http://externalurl/libraryaddress instead of http://internalurl/libraryaddress.
If accessing from the outside, the url should be translated at the firewall but for some reason, sharepoint has other plans.
It is behaving like the Alternate access paths did not propigate properly or something.

Server Error in '/' Application.
--------------------------------------------------------------------------------

Object reference not set to an instance of an object.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.  

Stack Trace:


[NullReferenceException: Object reference not set to an instance of an object.]
   CKS.FormsBasedAuthentication.Utils.GetMembershipProvider(HttpContext context) +123
   CKS.FormsBasedAuthentication.MembershipRequestWebPart.AddCreateUserControl() +159
   CKS.FormsBasedAuthentication.MembershipRequestWebPart.CreateChildControls() +30
   System.Web.UI.Control.EnsureChildControls() +87
   System.Web.UI.Control.PreRenderRecursiveInternal() +44
   System.Web.UI.WebControls.WebParts.WebPart.PreRenderRecursiveInternal() +42
   System.Web.UI.Control.PreRenderRecursiveInternal() +171
   System.Web.UI.Control.PreRenderRecursiveInternal() +171
   System.Web.UI.Control.PreRenderRecursiveInternal() +171
   System.Web.UI.Control.PreRenderRecursiveInternal() +171
   System.Web.UI.Control.PreRenderRecursiveInternal() +171
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +842

 


--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.3603; ASP.NET Version:2.0.50727.3601
0
 
needspaceAuthor Commented:
Alternate Access Mappings, not paths. Sorry.
0
 
MsShadowCommented:
Your AAM settings are indeed not correct, can you post them here?
0
 
needspaceAuthor Commented:
OK. I have 2 sites, one being the extension of the other.
For security reasons I will change names.
http://sharepointserver is the site for active directory users
http://sharepointserver:81 is the site for forms based authentication - this site is extended from the first site I listed.

For AAM I have the following:
Internal URL     Zone     Public URL for Zone
http://sharepointserver     Default     http://sharepointserver
http://sharepointserver:81     Internet     http://sharepointserver:81
http://externalurl.com     Custom     http://externalurl.com

0
 
needspaceAuthor Commented:
I called Microsoft and had them take a look. You are correct in that my AAM was not correct.

MS had me add http://externalurl     custom      http://externalurl

and change http://sharepointserverr:81     custom      http://sharepointserver:81  to
 http://externalurl:81     custom      http://externalurl
So that my AAM now look like this:
Internal URL     Zone     Public URL for Zone
http://sharepointserver     Default     http://sharepointserver
http://sharepointserver:81     Internet     http://sharepointserver:81
http://externalurl.com     Custom     http://externalurl.com
http://externalurl.com :81    Custom     http://externalurl.com

Also, the bindings for the FBA site now have 2 entries:
* :81
externalurl  * 80

Everything functions correctly now. :-)
Even though MS solved it, thanks for the assistance.
0
 
MsShadowCommented:
If we pointed you in the right direction and allowed you to give the specific problem location, it would be nice to attribute points to the people who contributed.
0
 
MsShadowCommented:
If we pointed you in the right direction and allowed you to give the specific problem location, it would be nice to attribute points to the people who contributed.
0
 
needspaceAuthor Commented:
I did. I awarded the points to you.
0
 
MsShadowCommented:
I think you did something wrong mate, as the question is still marked as open. You should click the post(s) that helped you and sellect "accept as solution" or "accept as multiple solutions" if more than one answer helped you. My apologies for the double post, that was unintentional.
0
 
needspaceAuthor Commented:
It won't close immediately because I selected my post as the solution, but I awarded the points to you. The contested period has to expire first.... At least that is what it said when I accepted the solution.
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 7
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now