[Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3893
  • Last Modified:

Exchange 2010 CAS coexisting with OWA 2003 - HTTP 500 error

Exchange 2010 CAS and Exchange 2003 OWA server are co-existing. I've already specified the exchange2003URL parameter for the redirection in the exchange command shell. For exchange 2003 mailbox users, I can successfully login directly https://ex2k3server.domain.com/exchange.
But If I login via https://ex2010.domain.com/exchange, I get redirected (exchange 2003 login prompt) then
when I enter the username\pwd, I get  500 Internal error at https://ex2k3server.domain.com/exchweb/bin/auth/owaauth.dll.

If I enable Forms based auth on the exchange 2003 server, login works fine. I do not want to enable forms based auth because although this may
work fine internally, my owa machine is published on ISA 2006 for remote users and per Microsoft, " When ISA Server is being used to publish Exchange Web client access, forms-based authentication should only be configured on the ISA Server computer"

Another thing, why do I always need to enter the domain name \ username prefix when logging in to exchange 2101 OWA ?
In OWA 2003 I can simply enter the username and password, without the domain\ prefix.
0
anarine
Asked:
anarine
1 Solution
 
anarineAuthor Commented:
Ok so for the second question, the solution was to select the default domain name in ESM --> Server configuration --> Client access --> Outlook web app --> auth settings.
Still can't figure out the first problem with the redirection
0
 
LeeDerbyshireCommented:
The 500 error message you get from IIS is a very vague way of telling you that 'something went wrong at the server end'.  See if you can get more information by turning of the 'Friendly HTTP Errors' in your browser.  If you still don't see anything helpful, then it means that the error is caused by something that IIS doesn't know about, and you will have to look in the server's Event Logs.
0
 
Narayan_singhCommented:
On exchange 2003 Server on Exchange virtual directory remove SSL and FBA and set Integrated authentication and then try again.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
anarineAuthor Commented:
I cannot remove SSL from the exchange 2003 frontend, since exchange 2010 CAS will not be able to redirect as it requires ssl target for redirecting..
0
 
anarineAuthor Commented:
The answer for the time being is to use the manual legacy redirect cmdlet: legacyredirecttype to manual
0
 
WilmetteCommented:
anarine:  
I am currently running into the same problem.  Would you please explain how you use the legacyredirecttype to fix this issue.  As much detail as possilbe please.

Thanks!
0
 
rebisadvisorCommented:
Hi there.
use the following PS command

Get-OwaVirtualDirectory -server Exchange2k10 | set-OwaVirtualDirectory -LegacyRedirectType manual
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now