?
Solved

POP/IMAP not working Exchange 2007

Posted on 2009-12-23
12
Medium Priority
?
1,923 Views
Last Modified: 2013-11-29
We recently installed a new exchange server running Exchange 2007.  After three days and multiple changes, we are still unable to get POP/IMAP working to allow users to POP from outside the network.  Ports are opened and firewall is otherwise configured correctly as we can see.  Anyone have any suggestions that may aid in remedying this issue?
0
Comment
Question by:MemberMinded
  • 6
  • 4
  • 2
12 Comments
 
LVL 1

Assisted Solution

by:CASheridan
CASheridan earned 900 total points
ID: 26112884
Are the users able to access their email via POP3 or IMAP from inside the network? (i.e., the Microsoft Exchange POP3 and Microsoft Exchange IMAP services are running on the CAS Server and the user mailboxes have the POP3 and IMAP4 features enabled?) Are you able to telnet to the CAS server from both inside and outside the network?

Instructions on testing IMAP via telnet:
http://support.microsoft.com/kb/189326

Instructions on testing POP3 via telnet:
http://www.msexchange.org/tutorials/Telnet-Exchange2003-POP3-SMTP-Troubleshooting.html
0
 
LVL 1

Author Comment

by:MemberMinded
ID: 26113010
We can pop/imap inside the network.

When I try to telnet, it is acting odd.  I'm doing this:

telnet xx.xx.xx.6 25         (the real ip address of course... and I get a connection)

Then I go use "ehlo domain.com"    ...sometimes it replies, sometimes i get unrecognized command, sometimes I get invalid domain.

When it does work, I then use "mail from:name@domain.com"   ...but I either get invalid account or unrecognized command...

I'm not sure what the deal is....
0
 
LVL 65

Expert Comment

by:Mestha
ID: 26113231
That sounds like either firewall or DNS isn't pointing where you expect.

Hopefully you are using host.example.com and not just example.com, because the root of the domain should be pointing to the public web site, not an internal resource.

Simon.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 1

Author Comment

by:MemberMinded
ID: 26113278
Yes.  I am using the format mail.domain.com

This thing is perplexing.  DNS records "appear" correct... I cant see anything that should be changed from current state.
0
 
LVL 65

Expert Comment

by:Mestha
ID: 26113403
You can tell from the banner whether it is Exchange answering the request or not.
Exchange answers like this:

220 host.example.com Microsoft ESMTP MAIL Service ready at Wed, 23 Dec 2009 16:02:36 +0000

Anything else either indicates it isn't Exchange answering, or something is getting in the way.

Simon.
0
 
LVL 1

Author Comment

by:MemberMinded
ID: 26113427
That is the banner I get when i do the telnet to connect to the exchange server.  that never fails.  

when we just now tried "ehlo mail.domain.com" we got "bad command error 11"
0
 
LVL 65

Expert Comment

by:Mestha
ID: 26113440
If you do

helo mail.example.com

What happens?

The bad command error is classic interference.

Simon.
0
 
LVL 1

Author Comment

by:MemberMinded
ID: 26113519
We tried "helo mail.domain.com" and got the same result... unfortunately.
0
 
LVL 65

Expert Comment

by:Mestha
ID: 26113716
Something is interfering.
If you do the same test internally, what happens?

Simon.
0
 
LVL 1

Author Comment

by:MemberMinded
ID: 26113821
Okay.

"EHLO mail.domain.com" returns

250-xxxxxxx.domain.com Hello [192.168.0.114]
250-SIZE
250-PIPELINING
250-DSN
250-ENHANCEDSTATUSCODES
250-STARTTLS
250-X-ANONYMOUSTLS
250-AUTH NTLM LOGIN
250-X-EXPS GSSAPI NTLM
250-8BITMIME
250-BINARYMIME
250-CHUNKING
250-XEXCH50
250 XRDST


So that works fine on port 25.  However, if I attempt to connect on port 143 for IMAP, anything I type returns a "Bad Command Error".
0
 
LVL 1

Accepted Solution

by:
CASheridan earned 900 total points
ID: 26114220
"telnet xx.xx.xx.6 25" - the 25 in this command means port 25, which is the port for SMTP.  To test POP3, use port 110 (telnet xx.xx.xx.6 110).  To test IMAP4, use port 143 (telnet xx.xx.xx.6 143).  You will need to ensure that ports 110 and 143 are opened in your firewall and port forwarded to your CAS server.  (I am not a networking guy at all, so check with your firewall/network guy for better instructions.)

ehlo is a verb for for testing SMTP.  They will not work for testing POP3 or IMAP4.  (See the links in my previous post for the syntax for testing POP and IMAP)

If you get unrecognized command sometimes and invalid domain other times, it suggests to me that there may be an issue with the port forwarding on the firewall but like I said, I am not a network guy so don't take my word for it.
0
 
LVL 1

Author Closing Comment

by:MemberMinded
ID: 31669445
Between the links you provided and the other input, we were able to resolve this.  Thanks!
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you have come across a situation where you need to find some EDB mailbox recovery techniques, then here you will find the same. In this article, we will take you through three techniques using which you will be able to perform EDB recovery. You …
There can be many situations demanding the conversion of Outlook OST files to PST format and as such, there is no shortage of automated tools to perform this conversion. However, what makes Stellar OST to PST converter stand above the rest? Let us e…
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
Whether it be Exchange Server Crash Issues, Dirty Shutdown Errors or Failed to mount error, Stellar Phoenix Mailbox Exchange Recovery has always got your back. With the help of its easy to understand user interface and 3 simple steps recovery proced…
Suggested Courses

616 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question