Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

404 error when using connect to join sbs 2008 domain

Posted on 2009-12-23
3
Medium Priority
?
2,303 Views
Last Modified: 2012-05-08
Hello
I have a problem when joining an SBS 2008 domain. When I go to http://connect I get to the correct site, but when I go to join I get a 404 file or directory not found error. I can browse to that directory through IIS however and launcher.exe is there.

c:\program files\Windows small business server\bin\webapp\clientdeployment\package

anyone else encounter this issue?
0
Comment
Question by:Mysterhays
  • 2
3 Comments
 
LVL 15

Expert Comment

by:Tray896
ID: 26113434
You'll get a 404 if you're attempting to launch something like an exe and don't have it defined as a web service extension.  To fix this, go into INET Manager and click on web service extensions.  Click on add a new web service extension, and point to your executable and give it a name.  Make sure you click the check box to set it as allowed.

You'll then need to make sure that your website or virtual directory that is running the executable has Scripts and Executables. allowed.  This is done by going to the properties of your site-->Home Directory.

For more info, check out this link: http://blogs.msdn.com/david.wang/archive/2005/07/11/Allow_file_downloads_on_IIS_6.aspx
0
 

Author Comment

by:Mysterhays
ID: 26113475
Thanks for that Tray896 but how would that have changed?

The launcher.exe is the way that Microsoft setup SBS 2008 to add clients through http://connect. Also that article doesn't describe a 404 error...unless it has something to do with the package folder not allowing IIS to browse therefor not allowing you to drill down further and returning a file not found error...
0
 
LVL 15

Accepted Solution

by:
Tray896 earned 2000 total points
ID: 26113567
So if you open IIS and right click on launcher.exe, does it give you a 404?  That article covers the situation where you get a 404 when trying to browse to an .exe, even though the file is clearly there.  That is caused by the extension not being allowed.

If your situation here is different then I may have misunderstood.  I also agree that it's odd that this would have just suddenly happened on its own.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Prologue It is often required to host multiple websites on a single instance of IIS, mostly in development environments instead of on production servers. I am sure it is not much a preferred solution on production servers but this is at least a pos…
Network ports are the threads that hold network communication together. They are an essential part of networking that can be easily ignore or misunderstood, my goals is to show those who don't have a strong network foundation how network ports opera…
Despite its rising prevalence in the business world, "the cloud" is still misunderstood. Some companies still believe common misconceptions about lack of security in cloud solutions and many misuses of cloud storage options still occur every day. …
When cloud platforms entered the scene, users and companies jumped on board to take advantage of the many benefits, like the ability to work and connect with company information from various locations. What many didn't foresee was the increased risk…
Suggested Courses
Course of the Month21 days, 5 hours left to enroll

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question