Cannot get the master page in "Edit" mode in Share point

I have customized my master page as per the need of the user.  When I go into site setting and select "Edit Page" it tells me that I am in edit mode but it does not give me the option to add or remove webparts. Any idea on why it would do that.
test.docx
pratikshahseAsked:
Who is Participating?
 
StevenMulkerrinsCommented:
No, you can't have the web part zone in the master page itself, you never edit the master page via sharepoint so you would never get the oppertunity to add web parts to it. The web part zone needs to go in your content page that is connected to the web part zone. Tyically your master page would just contain layout, style and branding etc. You would then define a ContentPlaceHolder in the part of the master page where you want your content pages to have a web part zone. Then in your content pages you add a web part zone for that content area.

Alternately, if you really really need to define your web parts in your master page you can add them to the master page directly (i.e. not in a web part zone). In SharePoint Designer when you're editing the master page go to Insert->SharePoint Controls-Web Part. It will show the web part task pane on the right and you can drag and drop web parts into the design screen.
0
 
StevenMulkerrinsCommented:
One possibility is that the master page is missing some elements which are needed. I'm not sure how you created your custom master page, but I would recommend downloading a base master page (I've found Heather Solomon's to be excellent http://www.heathersolomon.com/blog/archive/2007/01/26/6153.aspx) and make sure yours contains all the relevant elements.

The other possibility is the page you are using with the master page. I'm not sure if you're using customised page layouts or custom aspx pages? Anyway, the pages/layouts need to have a web part zone added for you to then add web parts to the page. You can add multiple web part zones layed out within your markup as nessecary. You can add these within sharepoint designer by going to the place in your markup that you want to have the web part zone, go to the Insert menu, select Sharepoint Controls and then Web Part Zone. (if the option for web part zone is greyed out, save your file and then try again.)
0
 
manojceCommented:
I think your customized master page doesn't contains any WebPart Zone.
So you can't add new webpart in edit mode.
0
 
pratikshahseAuthor Commented:
it does not allow me to add web part zone. i get an error message saying that a web part zone cannot be added in a master page. is there a way whhere i can add a web part zone in my master page.
0
 
MsShadowCommented:
What Steven said is spot on, you should accept his answer, it contains all the information.
I would advise against putting webparts in a masterpage, but it's of course all up to you.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.