• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 937
  • Last Modified:

Strange NIC issue when using PXE boot with Symantec Ghost and Microsoft Sysprep

Hi,

Hopefully somebody has seen this before.
I have a PXE server working that serves out a pxe menu. This menu by default chooses to boot from the local hard drive but also has the option for the client machine to boot to a symantec ghost console client network image.
This works fine.

After booting into the ghost console client I run a clone task to push an image to the machine.
This also works fine.

The client machine reboots after the image has been written to disk.
During the reboot the client machine goes through the PXE boot process. When it gets to the menu I leave it to time out and the default option of booting from the local hard disk is choosen.

Now for the strange bit.
When windows starts, and the sysprep mini setup runs, the network card (an onboard Realtek RTL 8111/8112 with the correct driver loaded in windows) does not show any network link and I can't join the machine to the domain.
If I enter the bios, before the mini setup runs, disable the PXE boot and save, then everything is fine and the network card shows a connection and the computer joins the domain as expected.

Has anybody seen something like this before, where windows won't recognise a NIC if it has been started from a PXE boot menu?

Some specs:

Motherboard: Asus P5KPL-AM IN/GB
NIC: Realtek RTL 8111/8112
OS: Windows XP Pro
Imaging Software: Symantec Ghost Solutions Suite 1.0
PXE Server: 3Com PXE Server v1.10 build 3

Thanks for any help,
Rory
0
Red-King
Asked:
Red-King
  • 2
1 Solution
 
Ravi AgrawalCommented:
Did you try updating with latest NIC drivers?

Ravi.
0
 
TobiasCommented:
Dear Red-King,

I suggest you, for bypass this problem to change the boot order in the BIOS settings.

Put the local hard drive first or before the PXE, and see if the problem goes out.

Then when you want boot from PXE you could press the button according to your BIOS. Many time it's F12, then you choose the PXE.

Best Regards
0
 
Red-KingAuthor Commented:
Thanks for your replies.
I am using the latest drivers for the NIC so this is not the issue.

I think MadShiva's workaround is the best option for now.
Maybe if we get some different hardware in the future the process will work.

Thanks again. Happy Christmas and new years!
Rory
0
 
Red-KingAuthor Commented:
Acceptable as a work-around.
0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now