[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

iPhone trouble with Exchange - Account not valid, but pulls email and not all contacts

Posted on 2009-12-23
6
Medium Priority
?
227 Views
Last Modified: 2012-05-08
I have a client that has a Windows SBS 2003 server with Exchange 2003 SP2 installed on it. They have had no trouble in the past with email to iPhones, but as of late I am having some difficulty. When I create the account on an iPhone, I get the prompt that the certificate is not recognized for the user at the external domain which is fine because it is looking for a certificate at userdomain.com but that is not the actual mail server. So then I put in the actual Exchange server and I then get a notice at the top that the Exchange account verifiecation failed. The catch is, if I save the account anyway, I then get email just fine and my calendar. I am however missing some contacts. I can't for the life of me figure out why it tells me that the account fails, but then it still connects to the server fine.

I have tried different variations of the username and domain, but in the past it has worked just fine by just adding the info in the field that requests it (such as the domain in the domain field, the username in the username field, etc).
0
Comment
Question by:robynhowes
  • 3
5 Comments
 
LVL 76

Accepted Solution

by:
Alan Hardisty earned 2000 total points
ID: 26118088
Please run the Exchange Activesync test at https://testexchangeconnectivity.com and report back the results.
If it errors in any way, please read my FAQ on Activesync with Exchange 2003 for guidance, troubleshooting steps and hopefuly resolution.
http://www.it-eye.co.uk/faqs/readQuestion.php?qid=1 
0
 

Expert Comment

by:PBridges
ID: 26119322
I ran this earlier and it looked good to me. The only warning I get is the one below:
Validating certificate trust for Windows Mobile Devices   The test passed with some warnings encountered. Please expand additional details.   Additional Details   Certificate is only trusted on Windows Mobile 5.0 AKU2 (MSFP) and later. Windows Mobile 5.0 devices will not be able to sync. Root = E=info@valicert.com, CN=http://www.valicert.com/, OU=ValiCert Class 2 Policy Validation Authority, O="ValiCert, Inc.", L=ValiCert Validation Network  
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 26120085
PBridges - are you robynhowes?  It is confusing if you answer as another Expert.  Please can you reply in future as robynhowes otherwise I may delete the email as it just comes up as a comment not Author Comment.
That message is fine - it just says that you will have problems with Windows Mobile 5 phones if you don't install the 3rd Party Root Certificate to the device, otherwise, Windows Mobile phones and iPhones etc should work happily.
Was that the only error?
0
 
LVL 1

Author Comment

by:robynhowes
ID: 26120122
SOrry about the confusion, yes Robyn is my boss and I was under her account when I posted earlier.

The error I posted under PBridges was the only error that was generated.

I did find someone pointing to possible Message Store corruption and steps to resolve that in this ticket: http://www.experts-exchange.com/viewQuestion.jsp?shareit=NXlaom/Lk0W6fmR64YvOl%2BGMsq%2BhHV/L&shared=0&cid=859

0
 
LVL 76

Assisted Solution

by:Alan Hardisty
Alan Hardisty earned 2000 total points
ID: 26120174
That would be my next recommendation after trying to sync another account to see if everything sync happily with an alternative account.

As the tests pass happily, all mail should get synced.

I have another FAQ about partial sync problems which might be useul:
http://www.it-eye.co.uk/faqs/readQuestion.php?qid=5
0

Featured Post

Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The main intent of this article is to make you aware of ‘Exchange fail to mount’ error, its effects, causes, and solution.
Steps to fix error: “Couldn’t mount the database that you specified. Specified database: HU-DB; Error code: An Active Manager operation fail”
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
Whether it be Exchange Server Crash Issues, Dirty Shutdown Errors or Failed to mount error, Stellar Phoenix Mailbox Exchange Recovery has always got your back. With the help of its easy to understand user interface and 3 simple steps recovery proced…
Suggested Courses

829 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question