Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 321
  • Last Modified:

sql server add valid owner

TITLE: Microsoft SQL Server Management Studio
------------------------------

Database diagram support objects cannot be installed because this database does not have a valid owner.  To continue, first use the Files page of the Database Properties dialog box or the ALTER AUTHORIZATION statement to set the database owner to a valid login, then add the database diagram support objects.

------------------------------
BUTTONS:

OK
------------------------------
0
rgb192
Asked:
rgb192
2 Solutions
 
lofCommented:
try this

alter authorization on database::databasename to sa

obviously change databasename to your database name
0
 
Raja Jegan RSQL Server DBA & ArchitectCommented:
This should help:

In SQL Server Management Studio do the following:

1. Right Click on your database, choose properties
2. Goto the Options Page
3. In the Dropdown at right labeled "Compatibility Level" choose "SQL Server 2005(90)"

I got it working after I execute the following command to transfer the database ownership to sa

ALTER AUTHORIZATION ON DATABASE::DatabaseName TO sa

http://www.dotnet-tips.com/2008/11/database-diagram-support-objects-cannot.html
0
 
rgb192Author Commented:
thanks
0

Featured Post

Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now