[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1326
  • Last Modified:

Network printers go offline after the print spooler is restared.

This morning the only 2 printers (Cannon IR 5055 and IRc5185i) that are setup on my print server (Windows Server 2003 SE SP2) are showing as offline. I can ping the printers, I can connect to them via their web app to manage them, they can ping out to the environment but they show as offline.

If I stop and start the print spooler service on the print server they show as ready and the queue empties. However, after 30 seconds (timed it. every time.) they both will show as offline and jobs start to queue up again. I can duplicate this at anytime.

No changes were made to the drivers or the server overnight. Printing was fine as recently as last night. What makes it less fun is the lack of information in the Windows event log. The printers going offline doesn't seem to generate any notification or error messages.

I've cycled the power on the printers, tested connectivity as well as I can and I've even rebooted the print server. Issue still remains. Hope I'm missing something simple.
0
drav
Asked:
drav
  • 6
1 Solution
 
FayazCommented:
It appears your network credentials are expaired, verify the passwords and that you are able to logon/ connect to the print server.  
Regards, Fayaz
0
 
dravAuthor Commented:
The print spooler service is running. The "Local system account" is being used for authentication for this service. The active directory object for the print server appears to be fine (not disabled). I am able to start, stop and pause the service. The printers are not set up in active directory (I should have mentioned this is not a workgroup but a domain) as objects.
0
 
dravAuthor Commented:
Let me check the controllers and see if there are any authentication issues when they go offline. Though, I am not seeing any in the security log on the server itself.
0
Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

 
dravAuthor Commented:
I found no authentication issues either locally or on the domain controllers using the event logs on each. I just stopped and started the print spooler service again and 30 seconds later the printers statuses went from ready to offline.
0
 
Rob HutchinsonDesktop SupportCommented:
Did you check the power management settings on the printers. Sounds like they are being told to go into a sleep or idle mode since it happens at 30 secs.

Try logging into their web interface and see if there are any power managment settings controlling this.

One thing you can try is to send a priter job of multiple pages that lasts longer than 30 secs to see if the print job completes, or if it's 30 secs after the last print job completes.
0
 
dravAuthor Commented:
I will check that out, WiReDNeT but it may be a couple of days due to the holiday. If that were the issue that would make sense.
0
 
dravAuthor Commented:
I have eliminated the printers as being the issue. At least I have for now. I have done so by setting up the printers on my laptop running XP SP3 directly bypassing the print server and they maintain a status of "ready" without going offline.

I have also tried installing the printers on another server and setting it up to share them. Same result. After 30 seconds the printers go offline. I am currently investigating the Windows updates that I pushed out on December 13th. Not having experienced this problem until December 24th has me skeptical but I am left with little avenues to pursue at the present time.
0
 
dravAuthor Commented:
This appears to indeed be a Windows Server 2003 issue and not a machine issue specific to the Canon printers. Well, not exactly anyways.

I have resolved the issue by unchecking the SNMP Status Enabled feature

Printers and Faxes
Select the Ports Tab
Select the Printer's Properties
Select the TCP/IP port's configuration button
Uncheck the SNMP Status Enabled button

The status instantly went to Ready and has been ever since I made the change. There can be other methods to resolve this issue now that I know it's related to SNMP but for my needs this was a satisfactory solution.

Thanks to both of you for lending your advice.
0

Featured Post

NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now