iCal and Google DAV server not connecting

Posted on 2009-12-25
Medium Priority
Last Modified: 2014-11-12
I have upgraded a client's MacBook to OS 10.6.2 (from 10.5.8, since 10.5.8 wouldn't give me a sync checkbox for Google in Address Book no matter what I tried, even a hack). A clean install on a new hard drive.  Got the checkbox after the upgrade and successfully set up the account (yay!)

Went into iCal prefs to set up Google calendar sync. Entered the data required, and I got the message, "Verifying calendar account at address (null)".

The settings are:

Account Template - CalDAV
User name - the user's gmail account address
Password - the user's password
Server path - /calendar/dav/username@gmail.com/user/

If I set the Account type to "Google", I get "No CalDAV server was found at the specified address."

Getting this set up for my client is critical to her business.  She currently does not have access to her calendar on her Palm Pre.

Where do I go from here?
Question by:splait
  • 5
  • 2

Expert Comment

ID: 26123186
In 10.6+ you can choose Google as account type!

Simply select that, and enter the users account and PW.

Else, CalDAV
Host: www.google.com
SSL: Checked

Username & PW as required.
LVL 12

Author Comment

ID: 26123931
I have posted four window shots below,  I tried your first suggestion and I got something like "no CalDAV server was found at this address."

As for your second suggestion, I don't get the window you thought I would. See below starting with third shot.

I moved both pref files (com.apple.ical.plist and com.apple.ical.helper.plist), which changed nothing.

What else can I try?
LVL 12

Author Comment

ID: 26123941
Correction:  The last screen shot should have been the one I posted below.  It shows that, even when I set the DAV path, we couldn't log in.  The username and password are correct.  I logged into her gmail account a few minutes ago just to be sure.

The DAV path I entered was http://www.google.com/calendar/dav/username@gmail.com/user/
where "username" is my client's gmail address.  You can see the response I got.
The DAV path is the same one listed in my Mac, except for the username.
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

LVL 12

Author Comment

ID: 26123972
Inn addition, when I use the "automatic" setting in the Add Account screen (instead of "Google" or "CalDAV"), it finds a DAV and gives me a second screen that looks like the first one below.  

When I change the server address to "google", I get the same result.

When I change the server address to "http://www.google.com/calendar/dav/username@gmail.com/user/", I get "iCal found the CalDAV server "www.google.com", but couldn't log in with the user name...."  I used the correct login information.


Assisted Solution

marook earned 1000 total points
ID: 26124479

It needs to be HTTPS ! I think SSL is required (at least, I only use it with SSL enabled - aka https.

Initially, only www.google.com should be in the servername, and the path after detection should be like:


Also, the Google account type should just work.
Hmm, maybe check if you have a wrong password stored in your Keychain?
LVL 12

Accepted Solution

splait earned 0 total points
ID: 26124617
I typed the password in by hand.  Keychain hasn't gotten hold of it yet.

My client has decided o go straight to Google Calendar and bypass iCal and Entourage.  So, hopefully, her issue is resolved.  This is one of those situations where I wish I had found the answer, but I never will.

Thank you for your help. I will give you some points for your efforts.
LVL 12

Author Comment

ID: 26129445
I wish to award some points.  Please lift the request to close.

Thank you!

Expert Comment

ID: 33029631
I tried to set up a google calendar account in iCal, and got the message that "no CalDav servers were found at www.google.com" or "no CalDav server was found at this address". Turns out, I had never logged in to the calendar for my gmail account, so my calendar didn't exist. Duh. The solution was to log in to gmail, click the Calendar link at the top, and then go through the setup for my calendar. Once my calendar was set up, I was able to go through the normal Apple iCal setup for a Google account and everything worked perfectly.

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article outlines the struggles that Macs encounter in Windows-dominated workplace environments – and what Mac users can do to improve their network connectivity and remain productive.
Most folks would know the basics of how Dropbox works, so that’s not the purpose of this article. Security is what it’s all about, so here I’ll share how I choose to secure my Dropbox Account and the Data it contains.
CodeTwo Sync for iCloud (http://www.codetwo.com/sync-for-icloud?sts=6554) automatically synchronizes your Outlook 2016, 2013, 2010 or 2007 folders with iCloud folders available via iCloud Control Panel. This lets you automatically sync them with…
This video tutorial shows you the steps to go through to set up what I believe to be the best email app on the android platform to read Exchange mail.  Get the app on your phone: The first step is to make sure you have the Samsung Email app on your …

615 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question