?
Solved

The system cannot find the file specified.

Posted on 2009-12-25
9
Medium Priority
?
2,929 Views
Last Modified: 2012-05-08
Merry Christmas!


The backups on ONE of my servers failed last night.  It happens to be on the server that has two enclosures on it.  I'm fairly crertain I know what the problem is already, I'm just curious about one thing.

I've got two enclosures on this box;  SATA (yuck) and HP.  The SATA promise enclosure is faulty right now, taking IT forever and a day to backup, and we had already intended to bounce it this weekend.

the problem has been in affect for a couple weeks, maybe, and my backups have never failed..... until now.

I'm just trying to confirm the source of the failure is in fact the enclosure.  The backup target directory is 'G\MSSQL\Backup\*.*', and this is on the sata.

I can see the target drive, where the BAK files are written.  But maybe SQL can't - these are the errors I received from the backup failure, in the order of receipt:


BackupIoRequest::ReportIoError: write failure on backup device 'G:\MSSQL\BACKUP\dbname\dbname_20091224.BAK'. Operating system error 2(The system cannot find the file specified.).

BACKUP failed to complete the command BACKUP DATABASE dbname. Check the backup application log for detailed messages.

The operating system returned the error '2(The system cannot find the file specified.)' while attempting 'SetEndOfFile' on 'G:\MSSQL\BACKUP\dbname\dbname_20091224.BAK'.

The operating system returned the error '2(The system cannot find the file specified.)' while attempting 'FlushFileBuffers' on 'G:\MSSQL\BACKUP\dbname\dbname_20091224.BAK'.

SQL Server Scheduled Job 'User Database Maintenance' (0xEAA8B9AE5C368446BAD522BE8692D7DE) - Status: Failed - Invoked on: 2009-12-24 22:00:01 - Message: The job failed.  The Job was invoked by Schedule 18 (User Database Maintenance Schedule).  The last step to run was step 3 (Send Notification - Failure).



I just now tried it manually (separate from the agent job).  It failed immediately, with this:

Msg 3201, Level 16, State 1, Line 1
Cannot open backup device 'G:\MSSQL\BACKUP\dbname\dbname_20091225.BAK'. Operating system error 2(The system cannot find the file specified.).
Msg 3013, Level 16, State 1, Line 1
BACKUP DATABASE is terminating abnormally.


so i am thinking maybe the enclosure issue is just escalating... but, here's the query -  i saved a test.txt file to the root of G, no problems.  I just tried to save the test.txt file to the backup target directories -- these are just the 'dbname' subdirectories within G:\MSSQL\Backup -- it failed w/this:

test.txt
Path does not exist.
Verify the correct path was given.


Anybody seen this before?
0
Comment
Question by:dbaSQL
  • 5
  • 3
9 Comments
 
LVL 26

Expert Comment

by:tigin44
ID: 26122213
do the sql server clustered?
0
 
LVL 17

Author Comment

by:dbaSQL
ID: 26122215
nope
0
 
LVL 26

Expert Comment

by:tigin44
ID: 26122226
so... check the permissions on the drive forlders...
You would be having some builtin SQL Server user groups named SQLServerMSSQLUser$ComputerName$MSSQLSERVER or SQLServerMSSQLUser$ComputerName$InstanceName .. if this does not exists you should add this user and give enough permissions.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 17

Author Comment

by:dbaSQL
ID: 26122233
it's not a permissions issue.  the backups, and all my maint jobs, are run under the sql server service account, which is most definitely an administrative account.

and, as i said, this failure only occurred on one server last night.  they're all using the same account.
0
 
LVL 26

Assisted Solution

by:tigin44
tigin44 earned 150 total points
ID: 26122250
can the disk be full?
0
 
LVL 17

Author Comment

by:dbaSQL
ID: 26122255
of course it could be.  but it isn't.  is 6TB
0
 
LVL 5

Accepted Solution

by:
rk_india1 earned 600 total points
ID: 26123834
I have encountered same kind of issue before. If you would like to delete the folder then u cant do that. The reason is whatever the data folder is created on the drive all information saved as pointer in Disk itself. If we are click on the folder the pointer refer the exact address on the disk. Due to some issue the failure occurred at disk and destroys the link that time the disk could not recognize the folder. To resolve the issue the best solution is to reformat the drive and as a resource join in sql server once again.
0
 
LVL 17

Author Comment

by:dbaSQL
ID: 26130808
I will split the points, and thank you both for looking, rk and tigin.
it was a problem with the enclosure.  having booted it, all data and functions are fine.  i knew the sata was flawed... i guess this is just a reminder  

thank you for looking
0
 
LVL 17

Author Closing Comment

by:dbaSQL
ID: 31669934
It wasn't perms, or anything of that nature.  It was a problem with the enclosure.  No need to reformat it, just a restart was sufficient.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Microsoft Access has a limit of 255 columns in a single table; SQL Server allows tables with over 255 columns, but reading that data is not necessarily simple.  The final solution for this task involved creating a custom text parser and then reading…
This shares a stored procedure to retrieve permissions for a given user on the current database or across all databases on a server.
This videos aims to give the viewer a basic demonstration of how a user can query current session information by using the SYS_CONTEXT function
Via a live example, show how to shrink a transaction log file down to a reasonable size.
Suggested Courses

864 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question