• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1423
  • Last Modified:

Cannot create outlook profile for exchange 2010 users

Exchange 2010 installation is coexisting with exchange 2003 in my environment.
Outlook web app works fine and I can move mailboxes to 2010 no problem.

If I try to setup first time the outlook profile for any exchange 2010 mailbox user, when I click on the 'check name' in outlook 2003, even though I have entered the name of the Exchange CAS server and enabled the checkbox in outlook for encrypting exchange connections,I receive the following error "The connection to Microsoft exchange server is unavailable. Outlook must be online or connected to complete this action"

If instead of the exchange 2010 cas name, I use the exchange 2003 server name, and I click 'check name' in outlook, the username resolves correctly and the exchange server name is automatically changed to the exchange 2010 server name. However when outlook opens, I receive error:

"Unable to open your default folders. You must connect to your exchange server computer with the current profile before you can sync your folders with your offline folder file"
0
anarine
Asked:
anarine
1 Solution
 
Glen KnightCommented:
Does the mailbox still spear on the exchange 2003 server?
How long since you moved it?
0
 
anarineAuthor Commented:
Problem resolved for the time being.
3 things
1) When you click on 'check name' in outlook, and you have an exchange 2010 server name as the exchange name, verify that the encryption     setting in outlook is on, otherwise it can't resolve.
2) I deleted the CAS array that was created. Then when I pointed mailbox databases to the actual exchange 2010 CAS server names and not the CAS array name using the set-mailboxdatabase command, outlook profiles began working.
3) When I recreated the CAS array object using new-clientaccessarray, outlook profiles for exchange 2010 users worked with the cas array name as the exchange server.

When I initially got the error '"Unable to open your default folders. You must connect to your exchange server computer with the current profile before you can sync your folders with your offline folder file", this may have been because the CAS array exchange object was not created in active directory. I think this may be so because when I tried  to run set-mailboxdatabase -rpcclientaccessserver <fqdn>, the command would not work unless I replaced the fqdn with the cas array identity name. When I deleted the CAS array object using remove-clientaccessarray command, and recreated it, it then allowed me to use the fqdn parameter.
0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now