[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 604
  • Last Modified:

IP address and localhost (127.0.0.1)

I am using Windows Vista.  I am using a ASP.Net to create a web site.  I can access it locally using:

http://127.0.0.1:54840/Default.aspx

However, if I use the actual IP address (192.168.0.100)

http://191.168.0.100:54840/Default.aspx

I got a page saying the page is broken.

The content for Default.asp is shown below.

I am sitting behind a router with the router configure to allow internet access via the port number (54840) both TCP and UDP

What do I do to access the Default.aspx via internet?
<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="Default.aspx.cs" Inherits="WebApplication1._Default" %>

<%@ Register assembly="OPCWebControls" namespace="OPCWebControls" tagprefix="cc1" %>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" >
<head runat="server">
    <title></title>
</head>
<body>
    <form id="form1" runat="server">
    <div>
    
        <span lang="en-us">Hello to the ASP.Net World</span></div>
    <p>
        &nbsp;</p>
    <p>
        &nbsp;</p>
    </form>
</body>
</html>

Open in new window

0
tommym121
Asked:
tommym121
  • 2
1 Solution
 
torimarCommented:
191.168.0.100 is not your internet address, it's the LAN address for your PC that allows the router and other computers on your network to address and communicate with your machine.

You will find the actual internet IP by checking your router settings, or by visiting a page like www.whatismyip.com
0
 
torimarCommented:
What are you trying to achieve?
Do you simply wish to test your page, or do you wish to host a website privately which can be reached from the internet?

In the latter case, please note that ":54840" is not the usual port for websites, it's 80 or 8080. If you are running a webserver (like IIS on Windows) - which you will have to in order to serve the page -  you shouldn't have to specify a port at all, since webservers by default use port 80 for serving.
0
 
tommym121Author Commented:
my IIS is not being setup
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now