Set language Arabic in sql server 2008

Hello
when i write the following statement
set language ITALIAN
select datename(weekday,getdate())
it comes with italian name of datename , that's good
But when i tried the following
set language ARABIC
select datename(weekday,getdate())

it comes in English not in arabic
i tried many language Korean , russian and it comes good , but in Arabic it comes with english
ali_alannahAsked:
Who is Participating?
 
pcelbaCommented:
The regional format of date parts is given by sys.syslanguages view contents. You may try:

SELECT  * FROM sys.syslanguages

and it seems the SQL Server installation does not have Arabic date parts defined properly.

But the following conversion works:
SELECT CONVERT(nchar, GETDATE(), 130)

It seems you will need to convince Microsoft for a change or use some work around like described e.g. here:
http://forums.asp.net/p/1422004/3160700.aspx

To create a function as Arabic replacement of Datepart should be very easy.
0
 
Raja Jegan RSQL Server DBA & ArchitectCommented:
>> it comes in English not in arabic

Do you have Arabic language installed in that server..
Hope you have Italian language installed in your OS where SQL Server resides.
Kindly confirm..
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
pcelbaCommented:
rrjegan17, I don't have Corean and Japanese languages installed on my copmputer but SQL Server is able to return date names in these languages. The Arabic language is a MSFT mistake.

Unfortunately, there is no possibility to update the syslanguages table on SQL 2008 even not in admin mode... Or do you know how to update this table?
0
 
Raja Jegan RSQL Server DBA & ArchitectCommented:
pcelba,

>> The Arabic language is a MSFT mistake.

Kindly try setting the default Language to Arabic for that database and give it a try..
(currently I dont have access to a server and will test it out shortly)

>> Unfortunately, there is no possibility to update the syslanguages table on SQL 2008 even not in admin mode... Or do you know how to update this table?

No, Starting from 2005 you can't update a system table.
0
 
pcelbaCommented:
When I set the language to japanese all messages are in Japanese, Russian switches it also etc. Arabic uses English even when the Database collation is Arabic and language is Arabic.

Attached is the sys.syslanguages table printscreen.

But I did not try to install SQL Server on Arabic Windows.

Untitled.jpg
0
 
Raja Jegan RSQL Server DBA & ArchitectCommented:
pcelba,
     Yes, Just tried to check as you mentioned and you are correct..
Entries for Arabic Language contains English values instead of the Arabic ones and hence the issue..

ali_alannah,
    Just report this bug / issue to Microsoft so that it can be handled in further releases..
0
 
ali_alannahAuthor Commented:
Hi rrjegan17:
How can i report microosft for this issue is there any email for reporting bugs to Microsoft ?
0
 
Raja Jegan RSQL Server DBA & ArchitectCommented:
pcelba got the links correctly..
0
 
ali_alannahAuthor Commented:
Good
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.